-   Slackware (
-   -   slackware 10 dhcpcd problem solved yet? (

taek 08-15-2004 04:57 AM

slackware 10 dhcpcd problem solved yet?
Hey, I'm really dying to know what is going on here. I have used slackware 9.1 without any problem for a while and recently I have upgraded to slackware 10, which gives me a dhcp problem.

I'm using RealTek RTL8139 card and configured the dhcp using netconfig. After reinstalling slackware three times and sleepless nights I found that rc.inet1 starts dhcpcd OK during booting process, but after I log in network just doesn't work. If I check the network with ifconfig, my eth0 looks OK. When I tried a new rc.inet1 file (short one from's DHCP mini HOWTO), then it worked for a couple bootings and stopped working? I also tried to put dhcpcd in rc.local and almost everything I could think of, but it doesn't work.

The only way to use network is to do the following everytime I log in (which I don't want to):
> su
> dhcpcd -k (kill dhcpcd)
> dhcpcd

Then dhcpcd starts and works fine with no problem. I really don't understand how this is possible! I tried FC and Mandrake to check and they worked just fine (But, I want to use slackware!) I found the similar posts in this forum with no solution. If somebody knows what could be a problem, please let us know. I'm willing to try anything now.

kilgoretrout 08-15-2004 08:38 AM


The only way to use network is to do the following everytime I log in (which I don't want to):
> su
> dhcpcd -k (kill dhcpcd)
> dhcpcd
You should be able to reproduce the above net effect of those commands by placing this in rc.local:

/sbin/dhcpcd -k

If that doesn't work(not clear whether you already tried it) then something starting after rc.local runs is causing the trouble. If your using kde you can make a little bash script to run those commands(dhcpcd -k and dhcpcd), have it run with suid root permissions and put the script in your ~/.kde/Autostart directory.

taek 08-15-2004 08:59 AM

Thanks for a quick reply. I tried to put those two lines in rc.local, but didn't work. I'm not sure what is starting after rc.local. When I didn't use X, it didn't work either (so not startx or gdm I'm using). I thought about writing a short script, but don't know how (and it's best if I didn't have to do that). I would appreciate if you could let me know how to write a script. Thanks again!

ringwraith 08-15-2004 09:22 AM

I had a similar problem at one point. Hotplug wanted to load the wrong module for my nic card. It kept loading tulip rather than what mine actually needed. The symptoms were similar to yours. I would have to kill dhcpcd and restart. Sometimes it would just sort of die after a time period. I had to add tulip to the blacklist for hotplug. YMMV.

taek 08-15-2004 11:08 AM

Finally I found out my problem! It turns out that dhcpcd was not killed correctly (?) at shutdown. I commented the following second line and added the last line in /etc/rc.d/rc.6 and now it works just fine:

# Try to kill dhcpcd so the DHCP leases can be returned:
#killall -15 dhcpcd 1> /dev/null 2> /dev/null
/sbin/dhcpcd -k

I don't know why the second line doesn't do its job yet, but I don't really care anymore. Thank you for your help!

cardak 08-15-2004 11:44 AM

me too
i alredy installed slackware 10, but it appears a message that say, that appear i have not any ethernet adapter, i use two realtek 8139, and it doesn't work, what sould i do?,

one nic to internet via dhcp
and the another for home net


(i have to use mandrake 10 CD, and it works perfect)

taek 08-15-2004 08:01 PM

I'm using hotplug (I installed hotplug package, and chmod a+x /etc/rc.d/rc.hotplug) and it is detecting network card correctly (8139too) during the booting process. Or, could it be tcpip package that may not be installed in your system? I'm not sure if this helps.

waever 08-16-2004 01:55 AM

for dhcp, I use the kernel level autoconfiguration in kernel 2.6.7
Just check the network options.

All times are GMT -5. The time now is 02:58 PM.