-   Slackware (
-   -   Slackware 10.2 NIC problem (

jmattshirey 06-03-2006 11:47 PM

Slackware 10.2 NIC problem
Hi everyone... I am a newbie to the LINUX world. I just installed Slackware 10.2 on my newly built server and I was wondering if someone could help me with getting my NIC installed. I have two onboard NICS and a separate NIC. My board is an ASUS A7N8-X Deluxe (i might have a few numbers wrong)..... Anyways, I am trying to find where in the Slackware GUI i can find my NIC and set it up along with how to set it up. Can someone please give me some help.... I would greatly appreciate it.

P.S. Does anyone know where I can get a copy of Apache2Triad for Linux? I use to have it for my XP-Pro server but I haven't been able to find a Linux version yet.


Tinkster 06-04-2006 12:14 AM

Hi, and welcome to LQ!

slackware doesn't come with administrative GUI tools, sorry to
disappoint you. Open a shell (as root) and run netconfig.
With a little luck it will pick the NIC up automatically.


jmattshirey 06-04-2006 12:42 AM

Okay.... What do i need to put into all of these fields? I have no idea what im doing...

Tinkster 06-04-2006 01:05 AM

Ok. What would you have done in the days of windows?
Has your network got static or dynamic IP addresses?


jmattshirey 06-04-2006 12:55 PM

In the old Windows days I would get the drivers off-line and then install them. I have a static IP comin into my home but then my router assigns an internal IP address. Im sorry to bother y'all with this but I really want to get my server box back up. Thanks for all of the help.


jmattshirey 06-04-2006 01:22 PM I found this link while looking for Slackware Setup..... I tried all of the steps here and nothing happens. What am I doing wrong?

If yall need me to run any commands to see what some settings are please let me know cuz I will be online all day today tryin to figure this d*mn thing out.


Nylex 06-04-2006 01:29 PM

What kind of network card do you have and is there anything apart from "lo" when you run "ifconfig -a"?

jmattshirey 06-04-2006 02:21 PM

2 onbard cards (ASUS motherboard)
1 external (Dynex) * chosen b/c I work there and it was the cheapest with my discount

ifconfig -a:

lo Link encap: Local Loopback
inet addr: Mask:
RX packets:58 errors:0 dropped:0 overruns:0 frames:0
TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4700 (4.5 kb) TX bytes:4700 (4.5 kb)

~ :newbie: ~

Nylex 06-04-2006 02:32 PM

Ok. Which card do you want to use and what kind of chipset has it got? Running lspci might give you an idea of the chipset. It would appear that you don't have a module for your card loaded, since you don't have an ethx listed.

jmattshirey 06-04-2006 02:56 PM


Originally Posted by Nylex
Ok. Which card do you want to use and what kind of chipset has it got? Running lspci might give you an idea of the chipset. It would appear that you don't have a module for your card loaded, since you don't have an ethx listed.

Aight... To answer your first question... I really don't care as long as it works.... But most likely one of the onboard cards. When i used lspci it showed all three cards on a list of items.

Secondly, when i ran the ifconfig -a earlier it showed an eth0. Here are the results.

Link encap:Ethernet hwaddr: 00:13:46:3A:70:08
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen: 1000
RX bytes:0 (0 kb) TX bytes:0 (0 kb)
Interrupt:11 Base address:0xf000

~ :newbie: ~

Nylex 06-04-2006 03:11 PM

Ok, so it IS showing eth0, that's good. Just run netconfig now then. You can put whatever you want for hostname and domain, but when it asks whether you use DHCP or have a static IP, choose DHCP (presumably your router is using DHCP, as it's assigning addresses). You can leave the DHCP hostname field (I think that's what the wording is, I can't remember exactly) blank. After that, try running "ifconfig eth0 up" and check if you have an IP address (run ifconfig again and it should tell you).

jmattshirey 06-04-2006 03:18 PM

I did everything you said and i still cant get online. What seems to be the problem?

~ :newbie: ~

Nylex 06-04-2006 03:22 PM

Actually, you probably have to run "dhcpcd eth0" as well.. oops. Are you sure the cable's plugged into the right card?

cwwilson721 06-04-2006 03:23 PM

Post three things for us:
  1. Code:

  2. Code:

  3. Code:

    ifconfig -a
lspci will tell us your hardware (chipsets, etc, to figure out what modules you need loaded

lsmod lists the modules loaded

ifconfig tells us what network settings are up

Until you can post all of that, we'll just be shooting in the dark

jmattshirey 06-04-2006 03:28 PM

Aight.. ur gonna have to give me a bit cuz its alot of stuff to write down and then copy over.

All times are GMT -5. The time now is 02:24 PM.