LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 10.1 to 10.2 cedega error (https://www.linuxquestions.org/questions/slackware-14/slackware-10-1-to-10-2-cedega-error-370744/)

gazer69r 10-07-2005 04:28 PM

Slackware 10.1 to 10.2 cedega error
 
I just upgraded slackware from 10.1 to 10.2 everything worked great in 10 .1
now when i try to run Cedega i get an error ,could not load graphics driver x11drv.
than it quits.
I have a Pent 4, 1.8ghz, 512m of ram ,Nvidia Geforce4.
I have installed Nvidia.run file with no problems and the tests in Point2play all went great.
i am running 2.4.31 kern. with x11 6.8.2
I would like to know, What can fix this problem??
I have looked at the forums for an answer but found nothing to help.
have also installed cedega and point2play as .tgz files with no errors.
Everything is fine but Cedega.

Any Help would be appreciated.

jong357 10-07-2005 10:30 PM

It's because of the threaded glibc Pat introduced. Your still running a 2.4 kernel that can't handle threads and cedega wants to use it by default now that it sees an NPTL enabled glibc. Unless you plan on upgrading to a 2.6 kernel, you'll have to:

Code:

cedega -use-pthreads no /path/to/windows/exe
make an alias for it in /etc/bashrc or your home .bashrc

Code:

alias cedega='cedega -use-pthreads no'
Then you can just "cedega /path/to/windows/exe"

This new glibc tends to cause more problems than it's worth.

gazer69r 10-07-2005 11:32 PM

Thank You,
That worked Great.
I made the .bashrc file and can use cedega fine now.
I still have to figure out how to make Point2Play work (for multiple disks and addon's)but knowing that this is a minor problem sets my mind at ease.
I really like all the new features in 10.2 just have to figure out how to tweak things.(just takes time to learn).
Some time in the future i will upgrade my kernel to 2.6
I appreciate the help!!!

gazer69r 10-07-2005 11:50 PM

I also did some reading at Transgaming and found out that there is a line in the point2play.rc for pthreads .
changed it from auto to off and point2play works fine now too!

gazer69r 10-10-2005 11:35 AM

Slackware 10.2 2.6 kernel
 
I just upgraded the kernel to 2.6 and what a difference it makes.
Everything works great .


All times are GMT -5. The time now is 07:34 PM.