LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-04-2005, 11:44 AM   #1
Grimm
LQ Newbie
 
Registered: Jun 2005
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
Slackware 10.1 & ICH5 SATA Install Problems


Sorry if this subject has been dealt with before, however i have been searching for a while to a solution to this problem with no luck

I have a P4 3ghz system running on a Gigabyte mainboard that has a ICH5R chipset for SATA disk / raid support.

I have been trying for a while to install Slackware 10.1 with the same problem repeating itself. I run through booting from the CD, setting keyboard map etc and logon as root.

I then run cfdisk to partition the disk (2x 160gb Maxtors). I have been selecting a 4gb swap partition and the rest as a bootable root partition. Having written the table to the disk i fire up the setup prog, which seems to format the swap and root partition correctly (have tried different file systems, mainly ext3 and reiserfs).

My problems begin when the setup program starts to attempt to write to the disk, when it gives errors over space. On opening a new console and checking the mounted disks i find that the main hdd is not mounted and its attempting to install to what i can only assume is a ramdisk. I have tried changing the raid config of the disks (raid 0,1) and also non raid (setup as single disks) without any change. Manual attempts to mount the disk fails. I have had a look through the dmesg output without spotting any errors, however errors do turn up after disk access is attempted.

This is the first system i have attempted to setup Slackware with SATA so im a little confused as to what to do next.

All suggestions greatly appreciated.

Grimm.
 
Old 06-04-2005, 03:33 PM   #2
cragwolf
Member
 
Registered: Jan 2004
Location: arse-end of the world
Distribution: Zenwalk 2.8
Posts: 73

Rep: Reputation: 15
Here's a link you might not have seen:

http://linux.yyz.us/sata/sata-status.html

I'm not sure if it will help you, but just in case.
 
Old 06-05-2005, 11:24 AM   #3
bonecrusher
Member
 
Registered: Mar 2004
Location: St. Louis, MO
Distribution: Ubuntu, Debian, Slack, RH, Gentoo
Posts: 207

Rep: Reputation: 30
Re: Slackware 10.1 & ICH5 SATA Install Problems

Quote:
Originally posted by Grimm
Sorry if this subject has been dealt with before, however i have been searching for a while to a solution to this problem with no luck
...
This is the first system i have attempted to setup Slackware with SATA so im a little confused as to what to do next.
...
All suggestions greatly appreciated.

Grimm.
EDIT:
Try my web site.. "Here"

And yes this issue has been answered and re-answered a dozen times. So instead of retyping all of it out maybe just look and see if your answer is on my site.. if not feel free to write me with your issues.

If you are really desperate I have and image (CD) available that has the kernel already patched for sata (ICH5 r). It works. I use it.. the only catch is it is for 10.0 not 10.1 .. so if this bothers you, I am not sure what to tell you other then what was mentioned. I was going to install 10.1 but my test computer is downso I have4 no way of even checking the newest distro. I was going to try and do the same thing for 10.1 (I am not even sure if he included 'full' sata support this time.) Anyway...later, and let me know.

Last edited by bonecrusher; 04-24-2011 at 11:34 PM.
 
Old 06-05-2005, 04:09 PM   #4
lemmy_kilmister
LQ Newbie
 
Registered: Sep 2003
Posts: 14

Rep: Reputation: 0
Hi all,

I had the same problem with an ICH5R chipset and SATA on Slackware.

Following Bonecrusher's idea (thank you!) I prepared a custom Slackware 10.1 install CD with Pat's kernel 2.6 from testing. There is no need to recompile anything. I wrote a mini-HOWTO about all that. Have a look here . You may find it usefull.

Regards
Lemmy

Last edited by lemmy_kilmister; 06-05-2005 at 04:11 PM.
 
Old 06-06-2005, 03:51 AM   #5
Grimm
LQ Newbie
 
Registered: Jun 2005
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
Hi all,

Thanks for your rapid response in replying to my post.

Having doing some serious reading, and spent a few hrs playing with BIOS settings I have managed to get Slackware 10.1 installed using the 2.4.29 kernel provided.

In the end I think the problem was basically a combination of BIOS SATA drive setup and hdd boot order. I have now complied the latest stable kernel (2.6.11.11 at time of post) which seems to have better support for my controller however the stock sata.i that comes with 10.1 will run the ICH5 chipset fine.

Thanks again,

Grimm.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ICH5 SATA on Mandrake 10.1/2005 taylortbb Linux - Hardware 5 10-03-2005 05:09 PM
Ich5 & Sata simon_w Slackware - Installation 14 01-08-2005 11:49 AM
ICH5 SATA in 2.4.x drigz Linux - Hardware 14 06-27-2004 11:36 AM
ABIT IC7-G ICH5 SATA RAID 0 & Suse 9 thenjduke Linux - Hardware 1 10-28-2003 04:41 PM
ICH5, SATA and Kernel 2.4.22 timetwister Linux - Hardware 1 09-14-2003 06:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration