-   Slackware (
-   -   slackpkg upgrade-all is not working in slackware64-current (

foobarz 08-13-2012 11:26 AM

slackpkg upgrade-all is not working in slackware64-current
I have a local mirror of slackware64-current. After syncing it to the lastest changes and running slackpkg update, I have tried to use slackpkg upgrade-all. I get the "upgrade" dialog with a package entry at the top that is "[*] ." like a package called ".". Following that "." package, I get either no other packages, or a random list of packages to upgrade. If I cancel and run slackpkg upgrade-all again, then I get different lists of packages almost everytime, but package "." is always there at the top.

I have manually upgraded pkgtools and slackpkg to the versions in -current to make sure they are the most recent, but this problem is what I get.

slackpkg installed is slackpkg-2.82.0-noarch-6
pkgtools installed is pkgtools-14.0-noarch-1

I even tried to upgrade to gawk-4.0.1, but it made no difference, so I upgraded back to slackware's 3.1.8.

Can anyone help?

foobarz 08-13-2012 01:55 PM

This problem was caused by grep-2.13; downgrading to grep-2.12 solved this problem on ZFSonLinux as rootfs.

grep-2.13 has a bug in certain situations involving sparse files. It can affect ZFSonLinux, NFS, BtrFS and filesystems that make usage of sparse files in certain ways.

When the bug happens, slackpkg fails to list packages properly, compiling kernel modules will fail, and other malfunctions can happen in scripts that call grep.

I've e-mailed Pat about this, so have to wait to see what happens. According to some mail list threads on grep development, they want to release a new grep version very soon to fix this bug; it looks like the grep development version has the bug fix already.

All times are GMT -5. The time now is 06:22 AM.