-   Slackware (
-   -   slackpkg upgrade-all: highlight a package, not showing "currently installed version" (

GrapefruiTgirl 04-03-2010 10:43 PM

slackpkg upgrade-all: highlight a package, not showing "currently installed version"
Seems to me I encountered this before, and mentioned it in a thread somewhere/sometime but now I cannot remember what that thread was. I'm not sure that the last time, I wasn't imagining things... :scratch:

Anyhow, I'm pretty sure, after 3+ years of using slackpkg, that it *usually* shows an informational line at the bottom of the console/terminal, such that, when using "upgrade-all", you can see on the status line the currently installed version of the package you've got highlighted. And using that information, you can see whether or not you're actually upgrading to a newer version, or an older version, of the package.

I am not seeing any such information line now. Someone tell me that it *is* supposed to be there!? Or has it 'gone away', or was it never there??? :)

I'm running mostly -current64 at this moment ('mostly' == all but Xorg & Xorg-mouse|keyboard), and slackpkg shows its version as 2.80.2 (same version as last time I asked about this :/). Everything is working great otherwise... It's just, I'm sure there is usually a line there telling the currently installed version.

I ran slackpkg in Eterm, xterm, and rxvt to make sure it wasn't a particular terminal.

Thanks :confused:

damgar 04-03-2010 11:20 PM

Thanks! I never noticed it, but yes you are correct, at the bottom of the screen the currently installed package is shown when highlighting a proposed "upgrade".

P.S. There is some wierdness going on with the current updates. The packages seem to have made the mirrors, but for many of the mirrors the the changelogs do not reflect the changes. I had to switch to the tds mirrors to get the right changelog+packages.

GrapefruiTgirl 04-03-2010 11:21 PM

:p Glad you see it! I still don't :/ lol..

damgar 04-03-2010 11:25 PM

Have you tried killing X and running it?

GrapefruiTgirl 04-03-2010 11:48 PM

Hmm, no I haven't tried that.. But I cannot see what influence that might have on things? I'll try slackpkg from a VT and see how that goes.

As for the changelog situation -- thanks for mentioning that; I have been wondering, since I *thought* that there had been some changes lately. I'm currently using osuosl but may try another mirror or two.
EDIT #2: @ damgar, thanks again for that-- I just changed mirrors and have all sorts of fun things to upgrade again :)


EDIT #1: Just tried slackpkg in a VT -- same thing, no information line at the bottom :scratch: but it'll have to wait till next time I log out, to try with X not running.. Never know, I've already found one thing that doesn't work right when X is running (mc in a VT is screwed when X is running) so who knows..

XGizzmo 04-04-2010 09:35 AM

That is just odd, It also works here with an up to date -current. The only things I can see that may be causing it are: dialog somehow broken, some kind of UTF issue, or /bin/sh symlinked to a incompatible shell. If you can run slackpkg upgrade-all and open a second console and copy the dialog.tmp file out of /tmp/slackpkg-<somehash> (not 100% sure on the name and path) and post it online.

GrapefruiTgirl 04-04-2010 10:08 AM

Interestingly, after updating freshly from another mirror and installing some stuff, it now works correctly :scratch: but I have no idea why. I'm going to have to keep watch on this and see if I can figure out when/why it doesn't work, and what then makes it work correctly again. I am not sure if simply updating from the other mirror fixed it, or installing/upgrading something fixed it (forgot to pay attention at that point :/ ).


sahko 04-04-2010 10:38 AM


Originally Posted by XGizzmo (Post 3923747)
/bin/sh symlinked to a incompatible shell

Sasha, do you still have dash linked to /bin/sh?

edit: Nevermind, you seem to have solved it.

GrapefruiTgirl 04-04-2010 10:38 AM

sahko, nope, not for quite some time now -- slackpkg doesn't work At ALL with that setup.

niels.horn 04-04-2010 01:02 PM

Slackpkg doesn't show the current version of the package if there are many packages to upgrade (like at March 1st, when we had a whole bunch of updates).

This is set somewhere in the code of Slackpkg, probably to speed up things or something. :)
Things will upgrade normally though, and you can make smaller selections by using "slackpkg upgrade kernel" etc...

GrapefruiTgirl 04-04-2010 01:06 PM

neils -- thanks for that information.

But it doesn't seem to jive with what I was seeing: for example, before I actually changed mirrors and GOT a new selection of stuff that needed to be upgraded, I had only three things in my "slackpkg upgrade-all" menu, which I had been opting not to update, for a couple weeks now. I would think that, if what you say applies, then having only 3 items in the list, I would have the information line at the bottom.

Any further thought in this direction are welcome! Thanks.

niels.horn 04-04-2010 01:14 PM

GrapefruiTgirl: Yes... That's what happens in my case at least.

I have some packages (like cups) that I did not upgrade yet so they always show up. And now, with only three packages in "upgrade-all", I see the "currently installed" line.

I'm running the 2.81beta version of Slackpkg (available on its site), that is faster too. Have you tried it?


GrapefruiTgirl 04-04-2010 01:20 PM

Hmm.. Great niels, thanks; maybe I am just seeing 'normal' behavior, but I only occasionally notice that the informational line is missing :scratch: and it sets me off :p

As for 2.81beta of slackpkg.. something tells me that I *did* have it running at one point, but evidently for some reason I've reverted back to 2.80.2 -- and I think I know why: probably after my first totally screwed upgrade to -current, having used my installation DVD and whatever else to repair the damage, I reinstalled the previous version along with everything else that was restored to the previous version. I'll look into that again.

I think I'm satisfied enough to [SOLVED] this thread (if I discover anything that changes that, I'll un-SOLVED it); and thanks again for that info about the info line not showing when there's a large amount of pending upgrades. I didn't know that.


niels.horn 04-04-2010 05:21 PM

Just an update...
The function that causes the "currently installed" line not to show up is in /usr/libexec/slackpkg/functions.d/

if [ $(wc -c $TMPDIR/dialog.tmp | cut -f1 -d\ ) -ge 40000 ]; then
        mv $TMPDIR/dialog.tmp $TMPDIR/dialog2.tmp
        awk '{ NF=3 ; print $0 }' $TMPDIR/dialog2.tmp > $TMPDIR/dialog.tmp

I changed the original value from 19500 to 40000 and now the line with the currently installed version shows up even with the large upgrade of May 1st.

It works fine on a recently modern system (~2 years old). It might be slower on older systems, or systems with less memory...

GrapefruiTgirl 04-04-2010 06:48 PM

That's handy to know, niels.
Something to keep in mind for personal use (I don't think I'll have a memory problem..), and which I may just do when I get around to hacking at slackpkg a bit to see if I can de-Bashism it. (I looked briefly one day some time ago, with that in mind, and decided it could definitely wait for some other time! ;))

[slightly OT]
Anyhow, I love slackpkg, but it could use a turbo-boost and a few hacks (someone else posted a thread a few months or so ago, about making slackpkg faster I believe.. If I'm remembering right.... I must look that up as well.)
[/slightly OT]

Thanks again,

All times are GMT -5. The time now is 12:32 PM.