-   Slackware (
-   -   Slackpkg - Selected wrong release (

Suncoast 04-19-2009 01:47 PM

Slackpkg - Selected wrong release
I just found slackpkg on 11.0. I inadvertently selected a "current" mirror rather than an 11.0 mirror. Now I get an error message stating I have a broken /var/log/packages ..... And the options are to blacklist or remove. Remove seems to bring up a page that makes me concerned it will uninstall the packages? What is the best way to remove the 12.x entries from my 11.0 (current) system?


(I'll be posting another message about why I'm running 11.)

lumak 04-19-2009 02:00 PM

I would think you would want to remove the slackpkg you installed and grab the version from the 'extras' directory of your install source. If you have not slackpkg as root or clicked on anything to 'fix' what it's telling you, then you should be OK with this option.


su -c 'removepkg slackpkg'
Sorry, I don't know what CD the /extras are on.

Suncoast 04-19-2009 04:33 PM

The actual packages were not installed. Near as I can tell, they were simply added to the list of available packages. So Slackpkg is complaining.

I will give the remove / install a go. Thank you for your reply.


bgeddy 04-19-2009 05:57 PM

Another idea but I've not tried this so...

Slackpkg keeps it's copies of filelists etc in /var/lib/slackpkg so you could try deleting all them and running "slackpkg update" to reinstate them. I would have thought running "slackpkg update" alone would have fixed this but I presume you have tried that.

Suncoast 04-19-2009 06:10 PM

That nailed it. Thanks!

All times are GMT -5. The time now is 03:40 AM.