-   Slackware (
-   -   slackpkg says no pkgs to update after installing 14.0, but there are pkgs in /patches (

integrale16 02-26-2013 01:20 PM

slackpkg says no pkgs to update after installing 14.0, but there are pkgs in /patches

I have a problem with slackpkg.
After doing a fresh full install of Slackware64 14.0, I tried to install all security- and bugfix-packages from /patches using slackpkg.
So, I first uncommented a mirror in the mirrors file. (Alienbobs
Then I issued the commands:

slackpkg update gpg
slackpkg update
slackpkg upgrade-all

Although there are packages in the patches folder which are installed in an older version on my system, slackpkg gives me the following output.

Checking local integrity... DONE
Looking for packages to upgrade. Please wait... DONE

No packages match the pattern for upgrade. Try:

        /usr/sbin/slackpkg install|reinstall

I also tried another mirror, but got the same output.

Can anyone help me with this, please?


chess 02-26-2013 01:41 PM

Are you sure you uncommented a mirror for your version and $ARCH? I have seen people accidentally uncomment a mirror for -current or for slackware when they meant to use one for slackware64.

integrale16 02-26-2013 01:55 PM

I think so.
This is the line which is uncommented at the moment.
In the mirrors file are only mirrors for Slackware64-14.0 and -current.

integrale16 02-26-2013 02:20 PM

Uninstalling with removepkg and manually removing remaining files of the slackpkg package and installing it newly with installpkg did it.

Now it works.

But my current question is, should I suspect the whole installation as corrupted now and install it completely new, since I haven't done any configuration, until now?
Or is there another (faster) way to validate the installation?

Didier Spaier 02-26-2013 02:44 PM

I understand that you did a fresh install but didn't remove the remains of an older version in the same root partition, that you didn't reformat.

If I am correct, I'd suggest you save all you want to keep from from your former installation then re-install, reformatting the root partition in the process, just to save yourself the hassle of checking all old files.

Well, that's what I'd do but maybe others disagree.

integrale16 02-26-2013 03:48 PM

No, on the disk was only a Win7 installation. And my goal is to create a dual boot system. I'm using Slackware64 13.37 at the moment on another machine, which I want to substitute with this new system and Slackware64 14.0 (the windows partition I need for school).

Currently I suspect that something went wrong when creating the install USB drive.
I decided now to do the installation again most likely from another boot media.

But thank you for your suggestion.

All times are GMT -5. The time now is 07:24 PM.