-   Slackware (
-   -   slackpkg insists on NOT upgrading me to slackware64-current. What am I missing? (

GrapefruiTgirl 03-04-2010 11:42 AM

slackpkg insists on NOT upgrading me to slackware64-current. What am I missing?
Many of you probably know, I've been using Slackware, and slackpkg, for about 3+ years now. I don't recall having this particular problem before, and I remain stumped as to why it is so. I've been poking at this problem for several days now, and am still missing what is probably a small stupid thing causing me this grief, and nobody else seems to have had this problem: I can't seem to upgrade to -current :scratch:


I went from Slackware-11.0 to Slackware64-current back before 13.0-64 was officially released. I initially did this by using Robby's rsync-mirror script to create myself a -current DVD and installed fresh from that DVD.

After that, I used slackpkg to keep my -current installation up to date.

Once 13.0/64 became officially released, I changed my slackpkg mirrors file to point at a 13.0 stable mirror, and all has, AFAICT, been fine since then.

Present Day:

So now, as we know there are lots of fun new changes and stuff in Slackware64-current as of early March 2010.
I would like to switch back to -current

I've got my /etc/slackpkg/mirrors file pointed at:
Here's my slackpkg.conf file:

root@reactor: cat /etc/slackpkg/slackpkg.conf | sed '/^#\|^$/d'
PRIORITY=( patches %PKGMAIN extra testing pasture )

So, with the above settings, "slackpkg update" appears to work fine.
Here's the top bit of the ChangeLog.txt file that I get when I update slackpkg:

root@reactor: cat /var/lib/slackpkg/ChangeLog.txt
Tue Mar  2 19:07:31 UTC 2010
a/aaa_elflibs-13.013-x86_64-3.txz:  Rebuilt.
a/coreutils-8.4-x86_64-2.txz:  Rebuilt.
  Use --without-gmp, at least for now.  We don't want utilities in /bin
  requiring a library in /usr/lib{,64} that may not be available.
l/gtk+2-2.18.7-x86_64-2.txz:  Rebuilt.
l/libpng-1.4.1-x86_64-2.txz:  Rebuilt.
  Now with less rat.
xap/xchat-2.8.6-x86_64-5.txz:  Rebuilt.
Mon Mar  1 22:43:53 UTC 2010
Hey folks, we have a whole bunch of updates!  Huge thanks to Robby Workman,
Eric Hameleers, and Piter Punk for all the help.  :-)
a/aaa_elflibs-13.013-x86_64-2.txz:  Rebuilt.
a/acpid-2.0.2-x86_64-1.txz:  Upgraded.
a/bash-4.1.002-x86_64-1.txz:  Upgraded.
a/coreutils-8.4-x86_64-1.txz:  Upgraded.
a/cups-1.4.2-x86_64-1.txz:  Upgraded.

Looks correct, yes? Nice new stuff in there, dated March 2010..

FWIW, here's me /etc/slackware-version file:

root@reactor: cat /etc/slackware-version

Now, if I run "slackpkg upgrade-all" right now, I am offered bash-completion-1.1-noarch-1.txz and slacktrack-2.07-x86_64-1.txz -- that's it!
If I run "slackpkg install-new" I'm told there's nothing new to install:

No packages match the pattern for install. Try:

        slackpkg upgrade|reinstall

So.. What gives here? It's GOTTA be something ridiculous, silly, stupid, whatever. I don't care :) you can even laugh at how dense I've been when the problem comes to light, that's cool :cool: but someone pLeAsE tell me what I'm missing!?

Big Thanks!

disturbed1 03-04-2010 12:49 PM

In slackpkg.conf comment PKGMAIN=slackware. Slackpkg can figure this out automatically for you.
In Slackware64 the package main is slackware64, not slackware ;)

Double check blacklist as well.

GrapefruiTgirl 03-04-2010 12:52 PM


Freaking EGADS!! :banghead:

Thank you disturbed1!!

Commenting out PKGMAIN did the trick!

Sasha :)

disturbed1 03-04-2010 12:58 PM

Can I laugh now?

vdemuth 03-04-2010 12:58 PM

To late

GrapefruiTgirl 03-04-2010 01:01 PM

@ disturbed -- YES, laugh to your hearts content :)

@ vdemuth -- thank you for the suggestion! I had tried better than half a dozen mirrors already, with the same effect (which given the problem we now know, is obvious why it had the same result) but given that the ChangeLog was current, I feel it was pretty safe to assume that the rest of the mirror would be current too (or close to it).

disturbed1 hit it directly -- I had the wrong PKGMAIN setting :)

Thanks you guys!

All times are GMT -5. The time now is 06:30 PM.