-   Slackware (
-   -   Slackpkg going backwards trying to rerun updates in current? (

damgar 04-01-2010 09:06 PM

Slackpkg going backwards trying to rerun updates in current?
I'm confused. Everything seemed to upgrade yesterday when I did the

slackpkg upgrade-all
using OSU. But things got a little goofy so I figured maybe I did an incomplete upgrade. Trying yesterday and today, If I try to go through the process of updating again I get a list of packages to upgrade, but they aren't the ones from yesterday? For instance kernel 2.6.33 instead of Does anybody have any clue what that's about? I've changed mirrors twice, with the same results.

I've never tried to re-run the update so I don't know if this is correct behavior or what.

dive 04-01-2010 09:30 PM

May be that the mirrors you tried were slow to update.

damgar 04-01-2010 10:00 PM

I just figured it out....kinda. Yesterday for some reason the packages all updated fine even though CHANGELOG.TXT on those mirrors was from 3/16. Afterwards my packages were different from CHANGELOG.TXT on those mirrors so slackpkg tried to update to the packages listed in the changelog, whether it would have given errors or updated to the newer versions of the packages I can't say. Ultimately I went to the mirrors list at, and browsed through them until I found one that had the new CHANGELOG.TXT (all the previous mirrors that I looked at had the current packages, but the old changelog) I then edited slackpkg/mirrors to that mirror (tds) and ran

slackpkg update
slackpkg upgrade-all

and I was told that everything was up to date. I went ahead and updated to BOB's new kde 4.4.2 packages and so far all is going well. The goofiness seems to have gone away. Konqueror will be the ultimate test!

All times are GMT -5. The time now is 12:18 AM.