LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-07-2011, 04:10 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545
slackpkg creates /.gnupg (in the root of the file system)


Based on a thread in this forum I created a short script to run slackpkg to check for updates and send me an email. The script performs no package updates, just checks whether there are updates.

Code:
/usr/sbin/slackpkg update -batch=on -checkgpg=off 1>/dev/null
UPDATES=`/usr/sbin/slackpkg check-updates -batch=on -checkgpg=off`
NUM_UPDATES=`echo $UPDATES | grep -v "No news" | grep -v "^$" | wc -l`

if [ $NUM_UPDATES -gt 0 ]; then
  echo -e $UPDATES | mail -s "Slackware Package Updates Available" root@localhost
fi
I run that script in rc.local.

Nothing fancy, but slackpkg always creates a /.gnupg directory. Actually, gnupg is creating the directory, but slackpkg uses that program.

I don't mind the directory being created in /root/.gnupg, but I do mind having the directory created in the root of the file system.

As you an see, I pass the -checkgpg=off parameter to slackpkg, but to no avail.

This happens on 12.2, 13.1, and Current.

All I want is a notification. I prefer to manually update packages. Is there a correct way to use slackpkg to not create that directory in the root of the file tree?

Hopefully I'm missing something obvious.

Thanks again.
 
Old 04-07-2011, 04:19 PM   #2
Darth Vader
Senior Member
 
Registered: May 2008
Location: Romania
Distribution: DARKSTAR Linux 2008.1
Posts: 2,727

Rep: Reputation: 1238Reputation: 1238Reputation: 1238Reputation: 1238Reputation: 1238Reputation: 1238Reputation: 1238Reputation: 1238Reputation: 1238
Quote:
Originally Posted by Woodsman View Post
Based on a thread in this forum I created a short script to run slackpkg to check for updates and send me an email. The script performs no package updates, just checks whether there are updates.

Code:
/usr/sbin/slackpkg update -batch=on -checkgpg=off 1>/dev/null
UPDATES=`/usr/sbin/slackpkg check-updates -batch=on -checkgpg=off`
NUM_UPDATES=`echo $UPDATES | grep -v "No news" | grep -v "^$" | wc -l`

if [ $NUM_UPDATES -gt 0 ]; then
  echo -e $UPDATES | mail -s "Slackware Package Updates Available" root@localhost
fi
I run that script in rc.local.

Nothing fancy, but slackpkg always creates a /.gnupg directory. Actually, gnupg is creating the directory, but slackpkg uses that program.

I don't mind the directory being created in /root/.gnupg, but I do mind having the directory created in the root of the file system.

As you an see, I pass the -checkgpg=off parameter to slackpkg, but to no avail.

This happens on 12.2, 13.1, and Current.

All I want is a notification. I prefer to manually update packages. Is there a correct way to use slackpkg to not create that directory in the root of the file tree?

Hopefully I'm missing something obvious.

Thanks again.
A Quick&Dirty method used by me for a similar problem in connection with AlienBOB's KDE-4-6.1 build (/.config and /.kde directories while using KDM):

HOME=/root

before the guilty sequence. In fact, these runlevel scripts run as root with $HOME=/ . Then, there is nothing wrong.

Last edited by Darth Vader; 04-07-2011 at 04:25 PM.
 
1 members found this post helpful.
Old 04-07-2011, 04:42 PM   #3
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Quote:
Originally Posted by Darth Vader View Post
A Quick&Dirty method used by me for a similar problem in connection with AlienBOB's KDE-4-6.1 build (/.config and /.kde directories while using KDM)
This is not a problem only with KDE 4.6, it happens with KDE in general every time you get the authorisation dialogue to do anything as root. It has always happened to me from 4.3-4.5 i built it and used it.
BTW since i have specifically asked AlienBOB if he builds his packages inside chroots, when i first witnessed it and he replied affirmatively, that is not the answer to the problem either.
 
Old 04-07-2011, 06:18 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545
Looks the HOME=/root trick will suffice.

Thanks.

I've seen this behavior quite a bit through the years. I suspect many people have garbage in / and are unaware. I check regularly and when I see something like that I start looking for the culprit.

The similar problems associated with KDE4 were discussed in another thread here. I recall somebody stating the problem was fixed. The problem existed a long time from KDE3.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i cannot copy a file to a folder in file system with my root account realbezo Linux - Newbie 4 03-03-2009 10:45 PM
cannot find .gnupg in root Eileen Linux - Software 5 11-24-2008 12:47 PM
LXer: Piracy creates jobs, FOSS creates opportunities LXer Syndicated Linux News 0 11-02-2006 11:33 AM
Mounting windows xp file system, creates mnt point, however, cant read files in share cmd0a0 Linux - Networking 10 04-16-2005 12:28 AM
Boot Error: Root file system /dev/root adtomar Linux - Networking 0 12-27-2004 10:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration