Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 11-07-2011, 10:18 PM   #1
rob adornato
LQ Newbie
Registered: Nov 2011
Posts: 3

Rep: Reputation: Disabled
Slackbuild of MiniTube 1.5 & 1.6 repeats same video on x86 Slackware 13.37

I've looked through the forums and I'm hoping for some advice on what I can do next.

I've compiled MiniTube 1.5 from the Slackbuild at It worked except the videos repeat until I manual choose the next one.

The same occurs now that I upgraded to Minitube 1.6, by updating the version number on the Slackbuild.

The following is what appears when I run minitube from the terminal. The package doesn't appear to have any flags to make it more verbose.

GtkStyle was unable to detect the current GTK+ theme.
QAbstractItemModel::endInsertRows: Invalid index ( 1 , 0 ) in model ListModel(0x81c4218)
Found format 18
Playing "/tmp/minitube-259908416-kitchen"


Any recommendations for commands I can run to get a better idea of what's going wrong is appreciated.

My searches on the minitube site turned up a complaint of the same problem, mentions some stuff about the older 1.4 version not working with Xine, and recommending VLC. How does one switch backends on Slackware?

Old 11-09-2011, 06:55 AM   #2
Senior Member
Registered: Dec 2003
Posts: 3,161
Blog Entries: 4

Rep: Reputation: 136Reputation: 136
If you mean change the sound system in KDE, go to system settings in the KDE menu, double click on multimedia in the hardware section, and go to backend tab. Choose the appropriate backend. Or you can simply search for Phonon in the KDE start menu (the new style).

Last edited by vharishankar; 11-09-2011 at 06:57 AM.
1 members found this post helpful.
Old 11-10-2011, 06:33 AM   #3
rob adornato
LQ Newbie
Registered: Nov 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
Smile Solved by switch to gstreamer back-end

Just to finish this off, it now works.

The default phonon Xine-backend is not tested by Flavio, Minitube's creator. On the Minitube forum, he quickly answered my question and suggested trying the gstreamer-backend.

To get gstreamer working, briefly: using the Slackbuilds at, I built ffmpeg with most of its options enabled (also all previously built) then I built gstreamer’s ffmpeg, bad and ugly plugins.

Probably more than just Minitube needs, but my Slack machine is my "learn and have fun" machine.

After that go to KDE’s System Settings —> Multimedia –> Phonon -> Backend > gstreamer, as per vharishankar's reply.

And now it works.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
GNOME SlackBuild 2.30 for x86 and x86_64 released fidesratio Slackware 57 10-29-2010 01:41 PM
LXer: Minitube 1.2 Beta Released, Adds Video Downloads, Gnome Multimedia Keys Support LXer Syndicated Linux News 0 09-19-2010 02:40 AM
Slackware 13.0 x86 & x86_64 - trouble with xkb layout theget Slackware 4 09-14-2009 09:33 PM
Slackware-Current x64 & x86 + Nvidia SqdnGuns Slackware 7 05-24-2009 10:34 AM
Slackware 12 & Xorg Video Problem QuePID Slackware 6 01-06-2008 11:46 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:54 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration