-   Slackware (
-   -   Slackbuild error {HELP} (

-Fay- 03-02-2012 12:50 PM

Slackbuild error {HELP}
Hey everyone im trying to build a slackbuild for gtk-chthemes, ive downloaded the source and the slackbuild from

and ive made "gtk-chtheme.SlackBuild" executable, but when i run

i get this

./gtk-chtheme.SlackBuild: Permission denied
here is the output of ls-l for the build directory


-rw-r--r-- 1 1016 users  281 May 27  2010 README
-rw-r--r-- 1 1016 users  398 Apr 15  2011 gtk-chtheme-0.3.1-new-api.patch
-rw-r--r-- 1 fay  users 18205 Jul 15  2010 gtk-chtheme-0.3.1.tar.bz2
-rw-r--r-- 1 1016 users  2873 Apr 15  2011 gtk-chtheme.SlackBuild
-rw-r--r-- 1 1016 users  327 Apr 15  2011
-rw-r--r-- 1 fay  users  2618 Apr 27  2011 gtk-chtheme.tar.gz
-rw-r--r-- 1 1016 users  824 May 27  2010 slack-desc

All of this is run as root. Any ideas/fixes to this?

BroX 03-02-2012 12:56 PM

According to ls -l, the file is not executable:

-rw-r--r-- 1 1016 users  2873 Apr 15  2011 gtk-chtheme.SlackBuild
Try again to make gtk-chtheme.SlackBuild executable as follows:

chmod +x gtk-chtheme.SlackBuild

-Fay- 03-02-2012 01:01 PM

i already did that sorry should have made that clear, but i ran it again and still got


bash: ./gtk-chtheme.SlackBuild: Permission denied

Konphine 03-02-2012 01:59 PM

Are you running the SlackBuild script as a regular user? Try switching to root to see if it works afterwards.

-Fay- 03-02-2012 02:13 PM

no im running as su

ive been scrolling through the slackbuild to see if anything would cause this but im fairly stumped, theres nothing in there that would cause this

btw is it possible that running chmod -x is not working? i ran it as


chmod -v -x gtk-chtheme.SlackBuild
and it gave me

mode of `gtk-chtheme.SlackBuild' retained as 0200 (-w-------)

Daedra 03-02-2012 02:16 PM

Well just to be thorough, are you sure you did "chmod +x gtk-chtheme.Slackbuild" because in your above post you did "chmod -x"

-Fay- 03-02-2012 02:26 PM

my good sir you are very correct, im on a new laptop and am not used to this keyboard, indeed i used - not + thankyou very much

All times are GMT -5. The time now is 05:05 PM.