-   Slackware (
-   -   Slack9 Locks Loading firewire mod on inital boot (

SCarGo 07-11-2003 08:22 PM

Slack9 Locks Loading firewire mod on inital boot
Here is my question I am trying to get Slackware 9 installed on my Laptop everything goes fine with the inital install then when I get the


Prompt I hit enter it goes thorough loading everything and when it gets to loading:

ochi1394_0: OCHI-1394 1.1 (PCI): IRQ =[10] MMIO=[d00000000-d00007ff] Max Packet=[2048]

It just hangs and does not continue loading. Is there a command if any for me to put into the Boot: prompt to disable the firewire mod so that at least I can get in to the system to disable it for good?

Thanks in Advance

quietguy47 07-13-2003 11:05 AM

If you have the 4 disc set for Slack, you can use disc 2 as a rescue disk. If you don't have the 4 disc set, you can d/l knoppix and use it as the rescue disk.
Instead of removing the module(#rmmod) you could change the irq(#setserial) that it is trying to access. #cat /proc/interrupts will show you which irq's are in use and by which device.

Rodrin 07-13-2003 10:27 PM

Well since it would be difficult to rescue a system that has not yet been installed, I would suggest trying a parameter to stop firewire support from loading. Try the nousb option first. It might work since firewire depends on an ohci module. If it does not then try the noprobe option (then try both). If you use noprobe, you may have to load some modules you need manually with modprobe or insmod after you boot. It is entirely possible that a properly installed system will not hang, but load firewire support properly. If not you may have to also add nousb or noprobe to your Linux boot options in lilo.

SCarGo 07-13-2003 11:30 PM

I will give that a try tomarrow and let you know how it turns out. thanks guys for the advice

All times are GMT -5. The time now is 04:49 AM.