-   Slackware (
-   -   Slack64-current: X questions, Ext4 question (

GrapefruiTgirl 07-21-2009 06:48 AM

Slack64-current: X questions, Ext4 question
This Thread is where I *was* going to post but I decided my post was getting too broad and didn't want to throw that thread out of whack..

While I haven't had *exactly* the same problems as the above posters, I do have an 'issue' or two with X that may warrant a report: There's no transparency available on the desktop, (and RANDR does not work.). Compositing *seems* to work, but I really don't know if it is (how would I know without using eye-candy?)

I am using multiple monitors with Xinerama, so take that into account when considering this, as it is 99% likely that the Xinerama is inhibiting the RANDR though I am not certain, but as for transparency (and composite?), I have always had transparency on the desktop; I use it for Xterm windows.

Till 64-current came out, I've always used Slackware 11 (still am actually much of the time) with the nVidia driver (binary) and KDE and/or XFCE desktop.

Current setup: 64-current, nvidia-185.18.14_x86-64, MSI nVidia motherboard, dual PCI-E cards, dual LCD monitors.

Also note-- I haven't been using Slackpkg to keep this current; instead I am just rsync'ing the latest changes every day or two and manually updating. I haven't noted any problems with leftover files or similar issues with upgrading packages, but then I haven't been closely watching for that either.


1 -- should I have/need/want composite if I don't use any Compiz stuff? How to tell if it's working?
2 -- I'd like RANDR to work if possible; can it be done with Xinerama?
(The xorg log tells me that both the RANDR and Composite extensions are loaded)
3 - it
P.S. - I am still using an xorg.conf file with the server-layout, device, screen sections in it for the multiple monitors to work; without xorg.conf, my mouse/keyboard worked, but the 2 monitors did not. I added a couple lines to xorg.conf to prevent HAL from grabbing my input devices.
3) Ext4 Filesystem: are you using it? Are you finding it slow as hell? Or is it just me/something else making it look slow? Moving files/large blocks of data, and deleting files, seems really slow. I have been toying with the idea of a reinstall onto Ext2 for a comparison. What do you think?

Keep up the good work!


PS - also note, I have not yet rsynced today, so if something has changed that nay affect my post, please let me know. I'll re-sync today.

Bruce Hill 07-21-2009 07:35 AM

One question ... did you reinstall the Nvidia driver after upgrading X.Org?

If not, amongst other things, you lose acceleration.

kodon 07-21-2009 07:44 AM

xdpyinfo will let you know if the extensions are loaded

Didier Spaier 07-21-2009 08:22 AM


Originally Posted by GrapefruiTgirl (Post 3615050)
3) Ext4 Filesystem: are you using it? Are you finding it slow as hell? Or is it just me/something else making it look slow? Moving files/large blocks of data, and deleting files, seems really slow. I have been toying with the idea of a reinstall onto Ext2 for a comparison. What do you think?

Hi Sasha,

I bought a new laptop a few days ago (Lenovo ThinkPad T61 with a 5400 RPM SATA HDD) and installed slackware64-current onto an ext4 file system. I can't see real difference for now with my old laptop (7200 RPM HDD with Reiserfs file system).

Anyhow to make a comparison I would format a small partition using ext2 (for instance) instead of reinstalling.

Did you try to tune your HDD with hdparm ?

brianL 07-21-2009 08:25 AM

I haven't noticed any speed difference between ext3 and ext4.

GrapefruiTgirl 07-21-2009 08:41 AM

Hi, thanks to all who have replied so quick!

Bruce - yes, I reinstall the nvidia driver whenever there's any question, i.e. any upgrade, downgrade, kernel change etc.

Kodon - thank you, I didn't know of that command. I will check and post the output soon.

Didier, Merci -- thanks for your comparison/estimate of your situation. I have HDPARM running for error checking etc., but have not for quite a while actually set anything on any of my drives. I determined a while back that anything I was setting was getting set already automatically by the drive/BIOS/kernel already.
As for formatting a small part of the drive, I find it hard to believe but I am running out of 'spare' room on the drive :P so I was figuring since it's more a 'testing' install anyhow, I may just wipe it and reinstall; this way I don't need another partition (there are already like 12 partitions on this drive).

Brian - thanks to you too for your comparison there.

I just rsynced the latest changes so I will go check/reinstall the nvidia driver and check the output from 'xdpyinfo'


Ilgar 07-21-2009 09:01 AM

I too am using ext4, and it's working fine. It feels a bit faster but this may be due to the fact that I was using a totally encrypted disk layout before, whereas now I'm encrypting only the /home, swap and /tmp partitions.

GrapefruiTgirl 07-21-2009 09:02 AM

OK, below is the output from my current running setup. I added the following to xorg.conf:

(tried) In the server flags section:

Option "xrandr" "true"

and (tried) at the end of the file:

Section "Extensions"
Option "Composite" "Enable"
Option "Xrandr" "Enable"

But nothing changed. Xdpyinfo shows the exact same thing.

I have another issue too but will start another thread on it.



bash-3.1$ xdpyinfo
name of display:    :0.0
version number:    11.0
vendor string:    The X.Org Foundation
vendor release number:    10602000   
X.Org version: 1.6.2                 
maximum request size:  16777212 bytes
motion buffer size:  256             
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst                     
number of supported pixmap formats:    7           
supported pixmap formats:                         
    depth 1, bits_per_pixel 1, scanline_pad 32     
    depth 4, bits_per_pixel 8, scanline_pad 32     
    depth 8, bits_per_pixel 8, scanline_pad 32     
    depth 15, bits_per_pixel 16, scanline_pad 32   
    depth 16, bits_per_pixel 16, scanline_pad 32   
    depth 24, bits_per_pixel 32, scanline_pad 32   
    depth 32, bits_per_pixel 32, scanline_pad 32   
keycode range:    minimum 8, maximum 255           
focus:  window 0x1e004ba, revert to PointerRoot   
number of extensions:    23                       
    Generic Event Extension                       
default screen number:    0                                                           
number of screens:    1                                                               
screen #0:                                                                             
  print screen:    no                                                                 
  dimensions:    3280x1200 pixels (868x346 millimeters)                               
  resolution:    96x88 dots per inch                                                   
  depths (7):    24, 1, 4, 8, 15, 16, 32                                               
  root window id:    0x329                                                             
  depth of root window:    24 planes                                                   
  number of colormaps:    minimum 1, maximum 1

GrapefruiTgirl 07-21-2009 09:05 AM

I just noticed that when I try the 'xrandr' option in the 'Extensions' section at the bottom of the file, the X server hangs and won't start :/

All times are GMT -5. The time now is 10:53 PM.