-   Slackware (
-   -   Slack64 -current, KDE4, and intermittent DNS outages (

Crashbox 08-16-2009 02:20 PM

Slack64 -current, KDE4, and intermittent DNS outages
I'm a veteran slacker who just decided to make the jump to Slack64 and now I am experiencing intermittent DNS outages. The weird part is that the outages don't appear until after I'm in KDE. What I mean is: I boot to a prompt, log in, and I can ping anything and everything with no trouble, but once I start KDE, then the fun starts. It works, then it doesn't, then it works, then it doesn't.

I'm thinking it's an issue with KDE, but since this is my first foray into KDE4 I'm having some difficulty troubleshooting (finding the various config panels, etc.)

Some background:

- the machine is connected to a standard Linksys router by ethernet cable
- I know the hardware works (it was fine yesterday with an aging install of Slack 12.1)
- I know my internet connection is working (I have no connection issues from every other machine in the house)

I can provide other details as needed. Any help is appreciated.

Qury 08-16-2009 02:29 PM

based on what you have written it would be hard to identify the problem.
However you might try to disable the ipv6 module..

Crashbox 08-16-2009 04:07 PM

thanks, that's not a bad idea. i typically leave ipv6 out altogether when i compile my kernel, but i haven't done that yet. i'm still booting huge.s

modprob 08-16-2009 10:08 PM

i have experienced the same problem with my system. I suspect, in my case, it has something to do with DNS prefetching in Firefox or Chrome. Firefox 3.5 comes with DNS prefetching built-in.

Try disabling the prefetching. To do so in FF 3.5, add the configuration variable network.dns.disablePrefetch with the boolean value TRUE.

I still have the problem in private browsing though ...

If you find a better solution, let us know.

rob.rice 08-16-2009 11:15 PM

it could be in the hardware some where I have 2 ether net cards that over heat after a large download and quit working
so I added a fan to the tower blowing fresh air right on them no problems ever sense

Crashbox 08-18-2009 07:20 AM

still fighting.....
Well, I disabled the IPv6 kernel module and I turned off DNS Prefetch in Firefox, but it's still happening. It'll work great for a while and then every page I try to load will time-out.

At one point last night, I was pinging yahoo successfully at the same time that FF was timing-out every page I tried to load, including But other times, I wasn't able to connect to any page with FF or ping the world. And at other times, everything worked perfectly.

To reiterate, I know my home network is in working order (my other machines have no trouble) and I know my hardware is solid (it worked perfectly just before the jump Slack64). I agree it sounds like it could be an overheating issue, but I really doubt it, even under heavy load, the temp inside the case doesn't get above 47degC.

I realized last night that I was trying to use my FF user profile from my FF 3.0 install (I maintain my /home between upgrades and fresh installs). Perhaps that the issue. I think my next step will be to load up FF with a clean profile (no extensions or anything) and see what happens.

I'm also going to compile my own kernel. This is something I would do anyway, so we'll see if it helps.

I'm open to any other suggestions. Also, since I am new to KDE4, can someone tell me if KDE4 has any advanced network controls/features built in, and if so, where would I find the config files (or tools). The basic network config options in the main system config don't have much to them.

Qury 08-18-2009 09:52 AM

Now that you have disabled the ipv6 kernel module, try to disable ipv6 in firefox as well.

about:config -> network.dns.disableIPv6 -> true

Crashbox 08-18-2009 11:11 AM


Originally Posted by Qury (Post 3648033)
Now that you have disabled the ipv6 kernel module, try to disable ipv6 in firefox as well.

about:config -> network.dns.disableIPv6 -> true

yep, did that too...thanks.

modprob 08-18-2009 01:27 PM

It doesn't seem to be a widespread issue. It may have something todo with a specific hardware.
I've been experiencing, at a lesser level, the same problem. I have a Gigabyte DS4H board, Phenom 9550 and 4Gig memory running Slackware64 current.

I use xfce4 exclusively, so i don't think the issue is in KDE.

Crashbox 08-21-2009 07:53 PM

well, I owe rob.rice an apology...turns out it was a heat problem. moved my NIC away from my video card and all is well. Thanks for the help.

All times are GMT -5. The time now is 08:13 AM.