LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-12-2019, 02:30 PM   #1
skubik
Member
 
Registered: May 2003
Location: A dark corner in Canada
Distribution: Slackware 13.37 / Slackware64 14.x
Posts: 119

Rep: Reputation: 17
Slack64 14.2 & Compiz 0.8.14 on XFCE. Cannot change theme


I've been wrestling with this for 3 days now. I feel like I'm missing something but can't figure out how to fix it.

I've recently installed Slack64 14.2 and have had no problems getting X or xfce up and running. I downloaded the appropriate Slackbuilds for Compiz 0.8.14; installed them and had little problem getting compiz to run and setup things like wobbly windows & such. It all seems to be working well.

But, I can't change the window decorator theme, in either Emerald or using the GTK window decorator. Emerald seems glitchy so I'm okay with using the GTK window decorator. I've used fusion-icon to select the GTK window decorator and have confirmed the command is set in ccsm under Window Decoration to 'gtk-window-decorator --replace'.

I realize there is no immediate tool to change GTK themes with xfce. I saw a gnome-tweaks tool suggested at one point, but it seems like quite a hassle to get it onto Slackware.

I've seen some posts online mentioning using gsettings or dconf-settings. I've explored both these options; used gsettings to check and change the 'theme' key in org.gnome.desktop.wm.preferences to 'Ambiance dark' (the theme I'm attempting to change to).
And I've used dconf-settings to change the value of the 'gtk-theme' key in org.gnome.desktop.interface to 'Ambiance dark'.

Despite both these changes, I continue getting a light, uh, 'default' GTK theme that is definitely NOT the theme I've installed.

I've attempted to install the downloaded theme (Ambiance dark) to my ~/.theme/ directory as well as at /usr/share/themes/; doesn't make a difference.

In ccsm under Preferences, the Backend is set to 'Flat-file Configuration Backend', and that is my only option; gconf or dconf aren't listed at all.
I've looked at the config file at ~/.config/compiz/compizfusion/Default.ini, and I thought I could try adding the theme here, except I'm not sure what values to use.

I came across another posting online suggesting adding --metacity-theme to the gtk-window-decorator command, but when I look at gtk-window-decorator's help output, it doesn't list --metacity-theme as being an option.
I've tried adding it despite this, but it makes no difference.

I came across a posting online suggesting I export my Profile and re-Import it. I've tried that too, but no dice.

It's worth mentioning that I've had the same problem with the Emerald window decorator too. It displays a 'default' red-titlebar theme and it doesn't matter which theme I click on in the Emerald theme manager, nothing changes (if anything, it breaks things more; max/min/close buttons won't display at all).
I've also had issues getting changes in the Emerald Settings tab in the Emerald Theme Manager to save; ie: changing Titlebar double-click action doesn't save ot change the behavior at all.

If I could figure out the GTK thing, I'd be happy; I've never had good experiences with Emerald, so I don't expect that to start now. I'm ok without it.

Can anyone help point me in the right direction of what I might be doing wrong, if anything? Should I install an earlier version of compiz like 0.8.10?

I'd really appreciate any assistance.

Thanks!
 
Old 06-13-2019, 12:44 AM   #2
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,575

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
I have had this same problem before too. On my main machine Compiz respects my current metacity theme, but on other machines it does not. Using the --metacity-theme fixes the problem. I am not sure why it is not listed as an available flag under the gtk-window-decorator help but it does work, are you sure you spelled the name of your metacity theme correctly? However I should also mention I have only done this using Mate. I don't use XFce

Also I maintain the compiz set over at SBo. I am not able to upgrade to the newest version of because of compiz-0.8 that comes with Slackware 14.2. Here is a link to the slackbuilds for the newest version if you want to try them out (0.8.16).
https://www.dropbox.com/s/ccltq64v3o...to.tar.gz?dl=0

If you decided to try them all you have to do is run ./install.sh and the script will build and install the whole set. Howver if you are using protobuf, you will need to uninstall that BEFORE you run the install.sh, because I switched to protobuf3 with this release and protobuf can't coexist with protobuf3

Last edited by Daedra; 06-13-2019 at 12:50 AM.
 
Old 06-13-2019, 12:54 AM   #3
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,575

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
I am going to install compiz into a Slackware 14.2 virtual machine and see if I can recreate your problem.
 
Old 06-13-2019, 01:40 AM   #4
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,575

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
Alright I was able to get Ambiance Dark working with compiz. Compiz can be difficult sometimes, but here are the steps I used to make it work.

1) install the compiz packages
2) install Ambiance Dark to /usr/share/themes/
3) Set your theme in XFce appearance settings.
4) Launch ccsm and enable Move, Resize Window, Window Decorations
5) Launch fusion-icon, this should launch compiz.
6) right click on the fusion icon in the system tray and change the "select window decorator" to gtk
7) in the window decorator settings of ccsm change "gtk-window-decorator --replace" to "gtk-window-decorator --replace --metacity-theme Ambiance\ Dark"
8) unselect "enable window decorations" this should disable all window decorations if compiz is running.
9) right click the fusion icon in the system tray and select "Reload Window Manager" which will restart compiz
10) Reselect "enable window decoration" in cssm window decorations settings and your metacity theme should be correct now.


You can ignore using fusion-icon if you want and just the commands "compiz --replace" and "gtk-window-decorator --replace --metacity-theme Ambiance\ Dark" from the command line if fusion-icon gives you trouble. Soemtimes it will override settings, so if it doesn't work try using the command line. I tried both ways and it works fine.

Basically you have to kill compiz then set "gtk-window-decorator --replace --metacity-theme Ambiance\ Dark" then restart compiz for it to take effect.

attached is a screenshot, I do believe that is the right metacity theme
Attached Thumbnails
Click image for larger version

Name:	ambiancedark.png
Views:	22
Size:	236.8 KB
ID:	30740  

Last edited by Daedra; 06-13-2019 at 01:52 AM.
 
Old 06-14-2019, 08:43 PM   #5
skubik
Member
 
Registered: May 2003
Location: A dark corner in Canada
Distribution: Slackware 13.37 / Slackware64 14.x
Posts: 119

Original Poster
Rep: Reputation: 17
Thanks for your response & your efforts to try and replicate my issue. Unfortunately, despite following your instructions step by step, I ended up with the same result. I deleted my .compiz/ and .config/compiz/ directories beforehand to make sure I didn't have any rogue settings screwing things up, but still got the same result as before.

I did try running fusion-icon from a terminal and got this output:
Code:
* Detected Session: xfce
* Searching for installed applications...
* Intel detected, exporting: INTEL_BATCH=1
* Using the GTK+ Interface
* Namespace AppIndicator not available
... Trying another interface
* Using the Qt Interface
* Decorator "gtk-window-decorator --replace --metacity-theme Ambiance\ Dark" is invalid.
* Setting decorator to Emerald ("emerald --replace")
* Starting Compiz
... executing: compiz ccp --replace --sm-disable --ignore-desktop-hints
compiz (core) - Fatal: No GLXFBConfig for depth 0

Launching fallback window manager
...which kicked me back to xfwm4.

I don't get it.

What version of compiz did you install on your VM? 0.8.14 or the 0.8.16 you linked to?

I don't suppose the theme I downloaded is bad, although when I extracted it, the directory was 'Ambiance dark', not 'Ambiance Dark'
I tried the lowercase 'd' in 'dark' in ccsm's window decorator command box but it made no difference.

I'm stumped.

I've attached a screenshot of the light/white theme I'm getting.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2019-06-14_19-02-57.jpg
Views:	6
Size:	121.5 KB
ID:	30743  
 
Old 06-14-2019, 09:34 PM   #6
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,575

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
Quote:
Originally Posted by skubik View Post
Thanks for your response & your efforts to try and replicate my issue. Unfortunately, despite following your instructions step by step, I ended up with the same result. I deleted my .compiz/ and .config/compiz/ directories beforehand to make sure I didn't have any rogue settings screwing things up, but still got the same result as before.

I did try running fusion-icon from a terminal and got this output:
Code:
* Detected Session: xfce
* Searching for installed applications...
* Intel detected, exporting: INTEL_BATCH=1
* Using the GTK+ Interface
* Namespace AppIndicator not available
... Trying another interface
* Using the Qt Interface
* Decorator "gtk-window-decorator --replace --metacity-theme Ambiance\ Dark" is invalid.
* Setting decorator to Emerald ("emerald --replace")
* Starting Compiz
... executing: compiz ccp --replace --sm-disable --ignore-desktop-hints
compiz (core) - Fatal: No GLXFBConfig for depth 0

Launching fallback window manager
...which kicked me back to xfwm4.

I don't get it.

What version of compiz did you install on your VM? 0.8.14 or the 0.8.16 you linked to?

I don't suppose the theme I downloaded is bad, although when I extracted it, the directory was 'Ambiance dark', not 'Ambiance Dark'
I tried the lowercase 'd' in 'dark' in ccsm's window decorator command box but it made no difference.

I'm stumped.

I've attached a screenshot of the light/white theme I'm getting.
I am running 0.8.16. I also tested it on my bare metal machine, No VM. That Particular theme gave me problems, but I had no trouble changing my metacity theme using the --metacity-theme option, sorry its not working for you. You can always try the compiz-reloaded IRC channel. the devs are usually willing to help over there.
 
Old 06-14-2019, 10:14 PM   #7
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,575

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
Not sure if it will help, but I made a new user on my machine and recorded all the steps I did to get a dark theme working with the metacity theme. I did not use Ambianace Dark, because that theme has problems with 14.2, so I used another similar one called Equilux. If if you want to watch it here is the link, it is only 5:30 long start to finish to get everything working. You will notice I used an older version of the theme, that is because that is the last version that works with gtk-3.18 that comes with 14.2

https://www.dropbox.com/s/4htg6aed7y...acity.mkv?dl=0
 
Old 06-15-2019, 11:33 PM   #8
skubik
Member
 
Registered: May 2003
Location: A dark corner in Canada
Distribution: Slackware 13.37 / Slackware64 14.x
Posts: 119

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Daedra View Post
I did not use Ambianace Dark, because that theme has problems with 14.2, so I used another similar one called Equilux.
I feel like this is part of what might be stumping me. I downloaded another version of 'Ambiance Dark' from gnome-look.org (I think) whereas the version I've been using I downloaded from xfce-look.org. As I mentioned before, the theme from xfce-look extracted to 'Ambiance dark' whereas the theme from gnome-look extracted to 'Ambiance Dark' and had much more content than the previous version.

That being said, I've also tried downloading a different theme and had the same results.

So, I re-read some of your previous posts in the threat and realized that you were using MATE, not xfce. So, since compiz apparently supports MATE, I decided to try installing MATE to see if I get different results.

I downloaded scripts for the MATE Slackbuilds and got everything installed.
I started up X and MATE is definitely installed and running. I tinkered with it a bit to get familiar with it (it's been a while since the Gnome2 days).

Then I fired up fusion-icon, changed to the GTK Window Decorator, selected a theme from System > Preferences > Look and Feel > Appearance where I noticed some of my themes installed. I selected a theme that came with MATE (I assume; I didn't install it)
Then I went into ccsm to check the window decorator command and verified that it was set to gtk-window-decorator; then I appended the '--metacity-theme Ambiance\ Dark' to it (I still want that theme to work, ultimately).

Then I reloaded compiz from fusion-icon and....

... same problem as I had in xfce.

At least now the window decorations seem to be picking up the color scheme, but the titlebar & max/min/close buttons are still some default for compiz.
I've attached a screenshot.

I also updated to compiz 0.8.16 via the script you provided earlier in the thread.

I just don't get it.

I REALLY want to continue using compiz and figure out this problem, but I'm also losing patience.

Where else should I be looking or trying? Thoughts?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2019-06-15_22-17-39.png
Views:	8
Size:	223.7 KB
ID:	30747  
 
Old 06-15-2019, 11:49 PM   #9
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,575

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
if you look at the video I posted above, I do everything in XFce. Compiz works fine in XFce and Mate. I do everything from the command line, I don't use fusion-icon at all. I wish I could be more help, but I am not sure why you are having the problems you're having. Up until this post I had never used compiz with XFce, but as you can see in the video it gave me no problems.
 
Old 06-16-2019, 04:42 PM   #10
skubik
Member
 
Registered: May 2003
Location: A dark corner in Canada
Distribution: Slackware 13.37 / Slackware64 14.x
Posts: 119

Original Poster
Rep: Reputation: 17
So, I went back and watched your installation video and noticed a few things I hadn't done; the Qt4 Config & installing gtk-chtheme, specifically.
I wiped my entire user account clean to start from scratch (aside from a complete reformat/reinstall) and followed the video step by step; even installing the same version of the Equilux as you did on the video.

Despite all that, I still end up with the same result as soon as I get compiz running.

I kinda refuse to give up on this and at this point the only thing I can think of that might be causing problems is differences in packages/libraries.

Did you install and updates beyond a stock 14.2 install? I've updated a few via slackpkg, including gcc, glibc, and gtk+2.
I wonder if slight incompatibilities might be screwing things up?

If not, then I suppose I'll concede defeat on this issue; chalk it up to some strange anomaly in the universe. :/
 
Old 06-16-2019, 07:33 PM   #11
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,575

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
Quote:
Originally Posted by skubik View Post
So, I went back and watched your installation video and noticed a few things I hadn't done; the Qt4 Config & installing gtk-chtheme, specifically.
I wiped my entire user account clean to start from scratch (aside from a complete reformat/reinstall) and followed the video step by step; even installing the same version of the Equilux as you did on the video.

Despite all that, I still end up with the same result as soon as I get compiz running.

I kinda refuse to give up on this and at this point the only thing I can think of that might be causing problems is differences in packages/libraries.

Did you install and updates beyond a stock 14.2 install? I've updated a few via slackpkg, including gcc, glibc, and gtk+2.
I wonder if slight incompatibilities might be screwing things up?

If not, then I suppose I'll concede defeat on this issue; chalk it up to some strange anomaly in the universe. :/
I only upgraded the official patches for 14.2, I have a few customization but nothing major. You said you rebuilt the compiz set with my builds linked above? If you could, go to the compiz directory and recompile just the compiz core package and post the output over at pastebin and send me the link, I'd like to take a look at the build and see if I can find anything there.
 
  


Reply

Tags
compiz, emerald, gtk, slackware, theme


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xfce, Xfce-winter theme & firefox problem. g4ry Slackware 3 12-22-2012 11:29 AM
slack64-1337 gnome & compiz lesechang Slackware 11 05-08-2011 03:19 AM
LXer: Atolm GTK Theme + Clarity Icon Theme = Perfect for Dark Theme Fans LXer Syndicated Linux News 0 02-26-2011 11:50 PM
openoffice force default theme / no theme | dark theme fix H_TeXMeX_H LinuxQuestions.org Member Success Stories 1 03-08-2010 12:56 PM
Gotta love those ٱٱٱٱٱٱٱ&# iLLuSionZ Linux - General 5 11-18-2003 07:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration