-   Slackware (
-   -   Slack13x64 - GTK+ widget crash, nvidia libGL, QtCurve & updating (

Galib 03-06-2010 01:26 AM

Slack13x64 - GTK+ widget crash, nvidia libGL, QtCurve & updating
I've got Slackware 13 x64 installed along with my video card drivers (NVIDIA 8000 M). I am relatively new to linux, but picked up slackware so I can get a good understanding, so please bare with me :)

Although my video card works, I have two questions. My video card installer asked if I wanted to install NVIDIA's 32-bit compatibility OpenGL libs and I said yes. At the end of the installation, I got a warning saying

WARNING: Unable to perform the runtime configuration check for library '" (' /usr/lib/'); assuming successful installation
What does that mean?

One problem I am having is that when I go to System Settings > Appearance > then pick GTK+ for widget instead of Oxygen, my display crashes and I am no longer able to startx. I have to

rm -r .kde
to reset it and startx again.

I have been reading about QTCurve working wonders for making Firefox and other GTK programs not look like garbage and was wondering how I would go about getting it properly running, from installation to configuration. I managed to install QtCurve from SlackBuilds, but my display refused to start saying that I couldn't startx due to GTK_ENGINE and Qt running at the same time.

Also, what is your preferred method for upgrading your system? I used

slackpkg update
slackpkg upgrade -all

I used a mirror for Slackware 13 x64 current , but it didn't upgrade all the files that were supposed to be upgraded. At the end I got a list of the files that were "not found". Would it help changing to a different mirror?

I am willing to reinstall and start all over again if needed. ---

EDIT: After upgrading and then restarting, KMixer along with some other things are not appearing in the taskbar anymore. I've decided to reinstall, so I'll have a fresh install of Slackware13 x64 to work with.

Thanks again everyone.

Cheesesteak 03-06-2010 02:36 AM

Slackware64 is pure 64-bit "out of the box," meaning it does not include 32-bit libraries nor will it run 32-bit programs. Installing the 32-bit compatibility libraries with the Nvidia installer is unnecessary, as they won't do you any good unless you plan to convert your system to multilib (capable of running 32-bit and 64-bit). The warning form the Nvidia installer more or less tells you that you're missing 32-bit libraries... You can provide 32-bit support by converting your system to multilib.

There is _a lot_ happening right now with -current, so I wouldn't recommend it to a Slackware newbie or someone who relies on their OS to be rock-solid... that's what stable is for. If you're really curious, then I suggest you use AlienBOB's mirror-slackware-current script, which will create an up-to-date mirror of -current and create CD or DVD images, so you can install -current just as you would a stable release.


Also, what is your preferred method for upgrading your system? I used
slackpkg update
slackpkg upgrade -all

'slackpkg upgrade -all' doesn't work. It should be upgrade-all (without a space).
And since you had upgraded to -current, you forgot 'slackpkg install-new' before upgrade-all. You missed a new package or two for KDE when you skipped that step. But even before that, you should have upgraded your glibc packages manually before upgrading the rest of the system...

Galib 03-06-2010 03:15 AM

Thank you for your response, I just finished reading the Slack book thoroughly from start to finish. (I had just skimmed it before)

Since I got a clean install, I am going to get wicd and my nvidia drivers going, that I know for sure I can do without screwing something up.

Any word on why x crashes on me and I am unable to startx after selecting GTK+ for the widgets under Style?

Galib 03-06-2010 12:32 PM

I've managed to change the font in firefox but still with ugly borders and menus. I changed the font by

touch .gtkrc-2.0
pico .gtkrc-2.0

inside of .gtkrc-2.0 I wrote in gtk-font-name = "Lucidia Sans 8" This provided smaller text in the tool bars and buttons but not in message boxes like the one I am typing in now.

When I ran xfsettingsd, it made the boxes look much better, but the font was once again freakishly big. I understand that it is using the xfce settings for messing with GTK correct? Is there a way for me to edit the font of that? Or, is there just a way for me to edit the theme on a clean install of slackx64? I tried installing QtCurve-Gtk2 from and during installation is said that

error: CPU you selected does not support x86-64 instruction set

All times are GMT -5. The time now is 08:59 PM.