-   Slackware (
-   -   Slack12 + XFCE-mixer troubles (

NiKkO_o 02-25-2008 06:14 PM

Slack12 + XFCE-mixer troubles
Hi here,

It's been a while since I didn't use Linux, and recently I decided to try it again. As before I get a Slackware, the latest one, and I'm using XFCE. Everything works fine, except the xfce4-mixer.

I did configure alsa, with alsamixer and alsactl store. Sound is working fine, but xfce4-mixer doesn't keep settings. I saw this problem in an old thread here (2004) and I even tried the trick (about unmuting sound in alsamixer, as if it was blocking xfce4-mixer to save settings.)

So, I can set the various sliders, thoses settings won't change until I close my session. But if I restart, I'll have to set them again. In addition, I can't set the output mode to 6ch. When I do so, if I close the xfce4-mixer window and open it again, this setting will be set to 2ch. Profiles don't work either. (neither ? either ? Sorry about my english)

All programs are those installed with Slackware 12. None of them were recompiled (maybe I have to recompile xfce4-mixer, now I think about it).

As I didn't see any recent post about this (maybe am I blind) I was wondering if I was the only one having this problem or if there was an alternative solution to control alsa with xfce.

Thanks a lot.

heldley 03-27-2009 08:18 AM

I got similar problem just now.
Install slackware 12.2 and everything works fine.
But after upgrade XFCE to 4.6 (also together with other updates), I faced the icons missing issue.
I ever tried to reinstall XFCE4 package. But no luck
I think there maybe some personal settings or global settings are not updated accordingly. But i don't where they are.
Still hard working on it.

If anyone could provide any clue about it, it will be highly appreciated...

thx a lot

heldley 03-27-2009 09:08 AM

Hey, just get a workaround here:
In general, reinstall hicolor-icon-theme package

It said "The /usr/share/icons/hicolor/index.theme file is somehow getting corrupted". Re-generate the cache will be fine.
Try it.


All times are GMT -5. The time now is 11:34 AM.