-   Slackware (
-   -   slack12, computer hang when accessing floppy drive (

maximum 09-20-2007 01:29 PM

slack12, computer hang when accessing floppy drive
Hi.. i'm having a very annoying problem with my linux machine, recently i just found out that my computer always hang when i accessing my floppy drive (it's a 3,5" Sony floppy drive), my computer always hang when i mount my floppy disk through KDE, or any X Window, even it hang when i mounted it manually without X (using runlevel 3). I install slack12 and ubuntu feisty in my computer and the same problem occur on both distro,.

My floppy drive can be used normally in windows, so i really dont know what is the problem. So please help me.. i'm stuck

Thank You

gnashley 09-20-2007 01:33 PM

I would suspect that udev is creating the wrong type of device file for the floppy. You may need to alter the udev rules being used to create the device file.

maximum 09-20-2007 01:51 PM

Thank you for your reply, but how to change the udev rules? i never done that before..

I forgot to add, my computer also hang when accessing floppy drive on slack 9.1! but just like i said before the floppy drive works well on windows.

Thank's again

dracolich 09-20-2007 03:17 PM

Assuming the disk is not 1.38MB of bad sectors, after inserting the disk, don't mount it but instead check dmesg to see which device it's being attached to. Then run ls -l on that device. For example if it's /dev/fd0 (which it likely is) you would type

ls -l /dev/fdo
Look for the first letter to the left of the permissions. It should be a b to indicate a block device. I've had some issues in the past when my floppy disk or flash disk would be detected as character (c) instead of block (b) and would cause a hang when trying to mount it.

In a distro that used udev it's not too difficult to write a custom rule to force a device to use the block subsystem.

maximum 09-21-2007 01:11 AM

Thank's for your reply, i have check the permission as you suggested., and there are nothing
wrong about it. A few moments ago i gave it another try.. i try to mount the floppy drive again
and rarely linux would mount my floppy and i can perform task (add, copy, delete) using the
floppy drive.. and then i restart my computer and it hang again when i try to mount floppy.

Just for checking i tried to access my floppy disk using ubuntu feisty live-cd, and
using the live cd i had no problem accesing my floppy drive, so.. this problem only occur if
i tried to access my floppy drive from an installed linux (my slack12 and ubuntu feisty are both
installed in my harddisk).

i've tried dmesg to see any annomalies but i dont see anything strange.. man.. i'm really

Do you have any suggestion..??

Thank's again.

All times are GMT -5. The time now is 09:35 PM.