LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-05-2011, 11:35 PM   #1
TheCrow33
Member
 
Registered: Aug 2009
Posts: 81

Rep: Reputation: 8
Slack keeps putting my display to sleep!


I've got two installs of slack 64 13.1 on two different boxes (one runs an nvidia driver, and the other runs the radeon driver), both are GnomeSlackBuilds. On both machines I have gone to "system" -> "preferences" -> "power management" and made sure it is set to never put the display to sleep. Neither is running the XScreenSaver Daemon, and will ask me to start it if I go to "system" -> "preferences" -> "screensaver".

On the NVIDIA box the display will never actually go to sleep, but the screen will go black after a while. On the radeon box, the display goes to sleep somewhere between 10 - 30 minutes (roughly) of inactivity. This one's driving me nuts, I want to be able to watch a movie without shaking the mouse every half hour. Any ideas?
 
Old 01-05-2011, 11:55 PM   #2
Gavin Harper
Member
 
Registered: Feb 2010
Location: Finland
Distribution: Slackware
Posts: 169

Rep: Reputation: 24
Create a file: noblank.sh

Code:
#!/bin/bash

xset s noblank
xset s off
xset s noexpose
xset s 0 0
Move the script to /usr/bin/ or a place of your choosing.

I personally autostart it but you can also just run it if/when you need it.

Works on this end.
 
Old 01-06-2011, 12:28 AM   #3
TheCrow33
Member
 
Registered: Aug 2009
Posts: 81

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by Gavin Harper View Post
Create a file: noblank.sh

Code:
#!/bin/bash

xset s noblank
xset s off
xset s noexpose
xset s 0 0
Move the script to /usr/bin/ or a place of your choosing.

I personally autostart it but you can also just run it if/when you need it.

Works on this end.
That does the trick, thanks
 
1 members found this post helpful.
Old 01-06-2011, 10:00 AM   #4
interndan
Member
 
Registered: Aug 2004
Location: near Marion, Ill
Distribution: Slackware 14.2 64bit on Desktop Slackwarearm on Raspberry PI v1b
Posts: 358

Rep: Reputation: 31
If I put this script in rc.local would that autostart it?
 
Old 01-06-2011, 02:55 PM   #5
Gavin Harper
Member
 
Registered: Feb 2010
Location: Finland
Distribution: Slackware
Posts: 169

Rep: Reputation: 24
Quote:
Originally Posted by interndan View Post
If I put this script in rc.local would that autostart it?
I always start it if/when I start a GUI.
 
Old 01-07-2011, 10:22 AM   #6
interndan
Member
 
Registered: Aug 2004
Location: near Marion, Ill
Distribution: Slackware 14.2 64bit on Desktop Slackwarearm on Raspberry PI v1b
Posts: 358

Rep: Reputation: 31
Ok, how do you autostart it?

Thanks for help.

Edit:
I need to automate it so it runs for any user who logs in and starts x

Last edited by interndan; 01-07-2011 at 03:21 PM.
 
Old 01-08-2011, 08:13 AM   #7
dh2k
Member
 
Registered: Jan 2006
Distribution: Slackware 13.0 (KDE 3.5.10 from 12.2; Xfce 4.6; Fluxbox); Slackware 13.1 (KDE 4.5)
Posts: 211

Rep: Reputation: 52
Quote:
Originally Posted by interndan View Post
Ok, how do you autostart it?

Thanks for help.

Edit:
I need to automate it so it runs for any user who logs in and starts x

Depending on desktop environment:
Copy or move (or link) the executable script to users autostart directory:
XFCE -- ~/.config/autostart/
KDE -- ~/.kde/Autostart/

For fluxbox, edit the file:
~/.fluxbox/startup
to include the (/path/to/script)

Also consider updating /etc/skel/ as root with above

Last edited by dh2k; 01-08-2011 at 04:56 PM.
 
1 members found this post helpful.
Old 01-08-2011, 11:20 AM   #8
staus
Member
 
Registered: Apr 2004
Posts: 102

Rep: Reputation: 5
I'm running 64 bit current with blackbox, and the above xset file didn't help one bit.
Any idea how I can stop the screen blanking?
 
Old 01-08-2011, 11:43 AM   #9
Intel_
Member
 
Registered: Mar 2009
Location: Bulgaria
Distribution: Slackware
Posts: 103
Blog Entries: 5

Rep: Reputation: 20
Don't work to me. After moving the file to /usr/bin I start it as root by typing the path to the file. (xfce)
 
Old 01-08-2011, 12:41 PM   #10
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
The problem I have with this solution is that it's a script to override some setting that is causing the OP's problem. I'd rather find the actual setting and adjust it. Just my two cents.
 
Old 01-08-2011, 06:19 PM   #11
jrecortel
Member
 
Registered: Sep 2008
Location: Philippines
Distribution: slackware, FreeBSD
Posts: 123

Rep: Reputation: 19
put in /etc/rc.d/rc.local:

Code:
/bin/setterm -blank 0 -powersave off -powerdown 0
 
Old 01-09-2011, 12:25 AM   #12
Gavin Harper
Member
 
Registered: Feb 2010
Location: Finland
Distribution: Slackware
Posts: 169

Rep: Reputation: 24
Quote:
Originally Posted by Intel_ View Post
Don't work to me. After moving the file to /usr/bin I start it as root by typing the path to the file. (xfce)
Try executing it as the user that has the screen session open.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I get tcpdump to display the port and not the service name? ex: its putting abefroman Linux - Security 2 07-06-2012 03:40 AM
can't login network server through ssh after putting main computer to sleep truthe Linux - Networking 5 07-26-2009 01:41 AM
Putting harddisk to sleep... and keeping it sleepy crispy_chunks Linux - Hardware 5 01-09-2009 02:33 AM
Putting monitor to sleep cothrige Linux - Newbie 3 03-10-2004 10:07 AM
Putting my computer to sleep computergirl Linux - Hardware 26 09-28-2003 09:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration