LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Slack is slacking...again... (https://www.linuxquestions.org/questions/slackware-14/slack-is-slacking-again-127618/)

Brother Michael 12-20-2003 02:40 PM

Slack is slacking...again...
 
Alright I've taken some deep breaths I am cool and collected now...

Problems:

Logitech USB Wheel Mouse, the wheel isn't working, IF I configure the XF86Config, X crashes.

CD-RW isn't supported...WHY?! Every other distro I have used has picked it up, Red Hat, Fedora Core, SUSE Live-Eval...

Web pags load slowly.

Screen Resolution, the screen is too big. The most I can change it to is 1024x768

Folks, I'm tired. I have been working on this for non-stop now for 4 days. I have spent the past 4 days that I have been off from school, doing nothing but trying to get a damn distro to work correctly. Now, I understand that Linux is a fickle OS. and you have to put in to get out of it what you want. But this is getting ridiculous. In the past 4 days I have formatted my computer more times that I can/care to remember. I can't take this anymore. I choose to go with Slackware, because I read reviews here by people stating things like "it just works," "it's fast," and "a true to Linux OS than Red Hat, Mandrake, SUSE" And becuase I saw a lot of people have been running Neverwinter Nights on Slack Desktops than any other.

All I am asking for is for the thing to work. Not solve world hunger, just work.

Mike

gargamel 12-20-2003 03:38 PM

All I can say is:

There are a number of threads running here discussing the advantages and disadvantages of distributions like Slackware and Linux from Scratch compared to distributions like SuSE.
What you read about Slackware, that it is fast and efficient, is all true, and also that it just works --- normally! What you experience is, unfortunately, the downside of this type of distributions: You have to do quite a few things by hand, like patch your kernel in order to support your hardware. In distros like SuSE the vendor has already done this for you, which is reason, why the price for these distros is sometimes well justified.

For now, I suggest you do one of things:
1. Check if your kernel really supports your hardware. Patch it, if necessary. If you find this difficult, describe precisely your hardware on some new thread and ask the people here for help. You can be sure, that the people here will try their best to help you.
2. If you still want to give Slackware a chance, you might try VectorLinux. You can "upgrade" it at any time to full Slackware system, as far as I know (haven't tried it myself). It might have a more suitable hardware detection and better auto-configuration than Slackware itself.
3. If nothing helps or you are just stuffed, you might really be better off with another distribution.

BTW, I am using SuSE, Slackware and Knoppix. I also tried Red Hat, Debian and Mandrake, but I just liked the first three better. They are totally different in concept and I use them for different purposes on different hardware. None of them is perfect, but all work reliable in their specific domain, SuSE being the most versatile distribution, running out of the box on the most hardware --- at least on what's available in Europe.

Good luck!

Brother Michael 12-20-2003 03:48 PM

I have cooled off even more now, I looked at how my SuSE Live Eval set up the XF86Config file, and have seen now first hand where things need to go to get the wheel to work (thanks suse).

As for the CD-RW umm...I guess for now if there is some reason why I need to use it I will simply boot up into my Windows Partition and use Nero.

The web pages I just can't understand...I have dsl, and I have set-up the networking?? could it be a freak accident?

++EDIT++ Seriously here, a CD version of Linux is running Konquer faster...very odd.

Resolution...I'll live until I know what I am doing and can figure out how to edit the thing.

All in all I think I will give Slackware another install and see how it goes from there. If still nothing I am going to give SUSE a try. After Xmas I will be investing in a larger hard drive and I will probably install both SUSE and Slackware, as I have had a lot of success with them (hey Slack at least id'd my Windows Partition so I know it works)

I was impressed with the load time, and the fact that even KDE loaded really really quick.

Sorry about venting steam, just been frustrating this week with this not working, and my lack of knowledge on how to fix it.

Mike

DaOne 12-20-2003 03:55 PM

Mike...hang in there. I know the learning and trial and error can be frustrating. Once you get the little things worked out, you WILL be glad you chose Slackware...it is by far, hands down, the best IMO.

As for the CD-RW...what do you mean by "does not work"? Is this an IDE drive? Do you have scsi emulation enabled? What kernel version/Slackware version are we dealing with here? This will help us to help you.

Brother Michael 12-20-2003 03:58 PM

I have Slack 9.1 and I choose to use the default Kernal. I think the installer said that it was A?

And by not working, I mean it isn't even recognized. It is not in the /mnt directory.

Mike

DaOne 12-20-2003 04:08 PM

Ok...did you add the append entry during installation for the burner when prompted? Like, append="hdc=ide-scsi". If not, add this to /etc/lilo.conf.

Here is a snip from mine...

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
append="hdc=ide-scsi"

Replace hdc with your drive...a,b,c,etc...

Also, cd roms are not automatically mounted. They may be present in fstab, but they are not just mounted automaticlly.

Once the above is added to lilo.conf, the device will change to /dev/sr0. Mount like this...

mount -t iso9660 /dev/sr0 /mnt/cdrom...or... if you have 2 cdroms, make a directory in /mnt...

mkdir /mnt/cdrw...

and mount it there.

Brother Michael 12-20-2003 04:20 PM

Ok, no I didnt add the append, I am not used to that. I thought it was for SCSI. oops. Modify the Lilo Conf eh? alright I think I can do that. Problem is I don't know which drive letter my CD-RW is.

Oh and yes I do have 2 CD drives.

I knew that devices aren't mounted automatically, I worded that wrong. what I meant was that it wasn't there at all.

Mike

DaOne 12-20-2003 04:23 PM

Remember to run lilo after you edit it...

/sbin/lilo

This will update lilo for the changes. As far as the letter, the first device on IDE1 is a, the 2nd is b, then on IDE2 is c, and d respectively.

Brother Michael 12-20-2003 04:29 PM

my current cdrom goes like this when click on link to device

/dev/cdrom

I remember when I had Fedora Core installed there was a /dev/cdrom and /dev/cdrom1

is that what I would put in my lilo.conf?

append="/dev/cdrom1"

Mike

DaOne 12-20-2003 04:34 PM

No...is the burner on the same IDE channel as the cdrom? Is it slave, master, etc.?

Brother Michael 12-20-2003 04:42 PM

Success! Mouse Scroll bar works thanks guys!

Alright, umm...crap...ok inside the machine, the CD/DVD-Rom and the CD-Burner are linked they are both slaves. The CD/DVD-Rom is bootable. The Burner is not.

does that help?

Mike

Brother Michael 12-20-2003 04:45 PM

wait i get it. hd(x) is my hard drive -smacks himself- IDE is my cd-burner -smacks again-

ok so my file would look like this

append="hda=ide-cdrom1"

Mike

++EDIT++ To clear things up even more...The CD/DVD-Rom works. It mounts fine, and it is availble in the list of devices that I can select from in KDE when I made a link to a device.

DaOne 12-20-2003 04:48 PM

Try this...you obvioulsy used the DVD ROM for installation. So what is the output of this...

ls -hal /dev | grep cdrom

At the end of the line it will give you something like...

cdrom -> /dev/???

Let's start there.

Brother Michael 12-20-2003 04:53 PM

root@shrike:~# ls -hal /dev | grep cdrom
lrwxrwxrwx 1 root root 8 Dec 20 09:29 cdrom -> /dev/hdc
root@shrike:~#

DaOne 12-20-2003 04:56 PM

Ok...IF< keyword...if...the burner is a slave on the first IDE controller then it will be /dev/hdb. If it is the slave on the second controller, it will be /dev/hdd. If your cdrom is hdc, then it is the master on the second controller...so...if the burner is a slave on the same cable, it will be hdd. If the burner is on the same cable as the first hard drive, it would be hdb...make sense?


All times are GMT -5. The time now is 11:55 PM.