LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-06-2009, 07:16 PM   #31
jrecortel
Member
 
Registered: Sep 2008
Location: Philippines
Distribution: slackware, FreeBSD
Posts: 123

Rep: Reputation: 19

Quote:
Originally Posted by thezoid View Post
That's what I needed.....thanks....what is the fstab entry to automount all ntfs and usb drives?
here's my entry for my ntfs in fstab:
Code:
/dev/<drive>   /windows   ntfs-3g   umask=022   1   0
Quote:
Also, i'm running startx at login...how can I login graphically automatically...thanks...it's been a long while !!
make some changes in your inittab

Last edited by jrecortel; 04-06-2009 at 07:25 PM.
 
Old 04-07-2009, 01:32 AM   #32
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 480Reputation: 480Reputation: 480Reputation: 480Reputation: 480
Quote:
Slack installed, Xfce up, how to enable wireless intel 3965?
this thread really changed
 
Old 04-07-2009, 01:39 AM   #33
joutlancpa
Member
 
Registered: Apr 2009
Location: Orlando, FL
Distribution: Scientific Linux 6 x64
Posts: 211

Original Poster
Blog Entries: 1

Rep: Reputation: 31
here's one that's got me stumped...trying to edit /etc/fstab:

bash-3.1# mousepad /etc/fstab
No protocol specified

(mousepad:3691): Gtk-WARNING **: cannot open display: :0.0
bash-3.1#

mousepad will come up as user, the above error was as root...this just started happening. I've been pretty careful about changing things.

look familiar?
 
Old 04-08-2009, 11:07 AM   #34
janhe
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 14.2, slackware 13.1
Posts: 371

Rep: Reputation: 54
Quote:
Originally Posted by thezoid View Post
here's one that's got me stumped...trying to edit /etc/fstab:

bash-3.1# mousepad /etc/fstab
No protocol specified

(mousepad:3691): Gtk-WARNING **: cannot open display: :0.0
bash-3.1#

mousepad will come up as user, the above error was as root...this just started happening. I've been pretty careful about changing things.

look familiar?
You get that error because you launch the application as root, and you started X, the graphical environment, as another user.

X only accepts programs from the user that owns the session. Root didn't start that X session, so root has no buisiness opening mousepad.
 
Old 04-08-2009, 02:15 PM   #35
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590
thezoid: please use one main topic per thread. Separating topics not only helps you by getting each thread the attention it deserves but also helps others who seek for a similar solution. Thanks for understanding.
 
Old 04-08-2009, 03:25 PM   #36
joutlancpa
Member
 
Registered: Apr 2009
Location: Orlando, FL
Distribution: Scientific Linux 6 x64
Posts: 211

Original Poster
Blog Entries: 1

Rep: Reputation: 31
Quote:
Originally Posted by unSpawn View Post
thezoid: please use one main topic per thread. Separating topics not only helps you by getting each thread the attention it deserves but also helps others who seek for a similar solution. Thanks for understanding.
To both of you above: Yep and YEP.

I thought about the searching after I let this thread wander...
 
Old 07-18-2009, 10:05 AM   #37
theacerguy
Member
 
Registered: Jan 2009
Location: on my pc!
Distribution: openSUSE 11.2 opensolaris 2009.06
Posts: 218
Blog Entries: 7

Rep: Reputation: 32
Quote:
Originally Posted by joutlancpa View Post
ok guys...I cd'd into the directory where the wicd tar file is, logged in as root, run pkgtool and selected the first option to install the packages in that directory, hit enter, and it quickly goes right back to the command prompt without installing anything. Do I need to untar this first? what am I doing wrong....I can't find file roller on the system either...lol thanks !!

EDIT: I've rebooted and tried to run wicd, and nada....I'm very familiar with Wicd as it's my netmanager of choice...thx ! Also, I need the network manager because I move my laptop around to different wireless clouds often
the same thing happes to me so i use installpkg
 
Old 07-21-2009, 08:16 AM   #38
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 480Reputation: 480Reputation: 480Reputation: 480Reputation: 480
ok for wired net you will make sure the /etc/rc.d/rc.inent1.conf has the Looks like this for auto dhcp
Quote:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""
this would have been done earlier if you would have configured your net at install.
this can be done at any time by assuming root and typing netconfig .

Or you could type as root packge tools and then select run scripts then choose netconfig.
as far as wifi goes. One make sure device is recognized. type "lspci". make sure the driver is loaded "lsmod" make sure sure you have the firmware loaded for that device (broadcom, and other wifi chips need third party firmware.)
ok now type "dmesg" and make sure the device is been loaded into the kernel with out error.

after all that passes. your wired net device should be eth0 because we did that during netconfig or we manually edited it to [QUOTE]OK for wired net you will make sure the /etc/rc.d/rc.inent1.conf looks like this for auto dhcp
Quote:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes" <----------this
DHCP_HOSTNAME[0]=""
now if you do not need to use a pass phrase to connect open router. your wifi device will be eth1.
Quote:
ifconfig eth1 up
then dhcpcd
Note if you have a wired connection connected this will conflict.
But that is why you install wicd and tell it to use which device.
I find that making sure the hard wire is disconnected from my computer while using wifi keeps me from having any problem.
so if this is a laptop then you should be fine.

Last edited by Drakeo; 07-21-2009 at 08:22 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to enable intel pro wireless networking madhu.ravs Linux - Newbie 1 12-04-2008 07:16 AM
Linksys Wireless network card installed. Problem is how to enable slackedone Linux - Wireless Networking 6 11-29-2007 08:37 AM
intel 3945 wireless configure on slack 11 mustafa Slackware 5 05-28-2007 11:35 AM
slack 10.0 intel PRO/Wireless LAN 2100 pgrimes Linux - Wireless Networking 1 10-06-2004 11:40 AM
Just installed Slack 9 need wireless help termite Linux - Laptop and Netbook 1 09-27-2003 09:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration