-   Slackware (
-   -   Slack 9.1/scsi2.s/dual pentium pro (

BooDaaBoy 01-20-2004 05:33 PM

Slack 9.1/scsi2.s/dual pentium pro

Well, I need help with my Slackware setup. I have a Compaq Proliant 2500, Dual Pentium Pro 200mhz, 384mb ram, 256kb cache, SmartSCSI (ncr53c8xx), (3) 4gb fast-wide, etc... I am currently on my 6th attempt at re-compiling the kernel for this system. The initial install I used the scsi2.s kernel from the install and everything is detected including the Netelligent NIC 10/100. Which is really cool but without the other processor. Now I have followed the steps on this board, steps from the slackware site, and along site found from google. Each are slightly different but the best instructions and success was from here. But I still have problems and need some help.

With my last attempt things went really good but I am not seeing the NIC and have seen 'can't locate module' for agpgart and ide-scsi. I did not check to see if the 2nd CPU was initialized cause I was in a hurry today to get home. So I will check that tomorrow. I suspect its not working though. I was gonna hold off on asking the forum but I got good news today from my new supervisor that I can implement Linux. So I have to get things right now.

Any ways, I am off to another meeting and will check in later. Oh yeah, I installed the everything but X stuff since its gonna be a slack server. My goal is to make it into a 'LAMP' configuration for use as a forum system and maybe a chat system. I am hoping Slack can do this without much trouble. Again, thanks for your time.


Tinkster 01-20-2004 08:51 PM

Hi, and welcome to LQ and the slacker's forum :)

Hard to tell from your post, really.... I'd suggest that
you split your .config and post the chunks here ...


Noryungi 01-21-2004 11:28 AM


With my last attempt things went really good but I am not seeing the NIC
You may need to activate the proper module in the file /etc/rc.d/rc.modules

I know that for my NIC (very old 'puter), I often need to activae the NIC in this file, just look for the correct Brand/Model # and remove the comment character ('#') before the name of the module.


have seen 'can't locate module' for agpgart and ide-scsi.
That should not be good, then! (see below for more explanations) :D


I did not check to see if the 2nd CPU was initialized cause I was in a hurry today to get home.
To check for modules problems/CPU information, make sure you check the 'dmesg' outpuit as root. It reports everything that happened since the system was started. If you see two CPUs in dmesg, this means the system has been correctly configured of SMP. Same for modules.


My goal is to make it into a 'LAMP' configuration for use as a forum system and maybe a chat system. I am hoping Slack can do this without much trouble.
That should be no problem. Just make sure PHP is installed correctly and you are all set!

Hope this helps! :D

BooDaaBoy 01-22-2004 07:20 PM

Thanks Tinkster and Noryungi for your replies. I couldn't get the .config file here. So I ended up doing a clean install once again today. I got tied up with my job the day after I posted. I had three printers die and two workstations go belly up. So I have been hopping since then and late today started over. But took care to go over the process. I think I know what I was doing wrong. I was running make mrproper in the steps. When I looked at the Makefile and searched for this. I realized my .config was getting whack. This time I didn't do it. And took my time with make menuconfig. Then make dep, make clean, make bzImage. Which by then it was time go home. Hopefully tomorrow by mid morning I can post my results. Thanks again.

BooDaaBoy 01-29-2004 07:21 AM

Hello Listers,

Well, I have given up on trying to re-compile the kernel for now. I am having lots of trouble with than what I have time for right now. I have gone as far as re-building the server itself with smartstart because I tried Debian again. It was causing my second cpu to fail after the install of Debian/bf24. At least with Slack I don't have this problem so I am make do with what I can right now.

I am having difficulty with getting PHP to acknowledge its working though. I found on the forum that PHP installs by default. I checked that with pkgtool and yes the LAMP requirements are there. But I can't get phpinfo() to show that its successful. I have checked the httpd.conf, mod_php.conf, mod_ssl.conf for proper settings. It appears to be fine from all the notes in the files. But I can't get my test script to run. I am not certain about the default permissions for the /var/www/htdocs. So I am asking again for suggestions once again. I have exhausted my thoughts for now. Thanks in advance.


Misel 01-29-2004 10:56 AM

As far as I know you have to uncomment the line

`Include /etc/apache/mod_php.conf`(should be line 1068... nearly at the end) and then you should be set.



and put it into a file with the ending .php, put in somewhere in /var/www/htdocs and call it with a browser over http://localhost/yourfile.php .

The ending .php is important because the standard slackware apache config doesn't recognize html-pages with PHP content (except maybe with a <script type="php">-tag ).

You probably know all that already but maybe you missed one little step. If it doesn't help ... what does /var/log/apache/error.log say?

BooDaaBoy 01-29-2004 09:01 PM

Hello again,

Well, I think I am gonna give up on Slackware for now. I just can't get it right. I don't think I was making huge changes to the system. I can move around fairly good. I just can't get php to run. Now I get 403 messages when trying to get to the test script or the manual directory that I could get to before. I had changed permissions once then back once it didn't work. From that point forward I can't do much with it. I don't want to re-install Slackware for the 10th time again. I can do it with my eyes' closed now.

I ended up trying alot of things I've seen here in the forum to get LAMP to work. I have found that editing the lines in httpd.conf to enable mod_php and mod_ssl. Apachectl configtest complained that the mods were already added and was skippng my changes.

Now for the life of me I can't find any evidence that show s the mods being loaded via a conf file in etc/apache other than the ones that should but no includes are called in httpd.conf. My guess the binary pkg compiled them in hard but I don't know. I am pretty confused. So I am gonna pull the second CPU and use debian because thats' what I know best right now. Cause I gotta get a box going sooner than later now.

Thanks to those that replied and tried to help.

All times are GMT -5. The time now is 10:51 PM.