LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-07-2004, 04:28 AM   #1
Mr.Kex
Member
 
Registered: Jan 2004
Location: Belguim
Distribution: Slackware 9.1
Posts: 63

Rep: Reputation: 15
Slack 9.1 problems


Hi, I've installed slack 9.1 but I have some problems:

- I can't find my CDROM's

- I can't configure my sound

- I can't activate/configure my mousewheel..

Sorry to sound like a
 
Old 03-07-2004, 04:30 AM   #2
Mr.Kex
Member
 
Registered: Jan 2004
Location: Belguim
Distribution: Slackware 9.1
Posts: 63

Original Poster
Rep: Reputation: 15
And another problem is that I am using KDE and when I log out, then I've got to turn the computer off manually, can i do it with a command? Which one?
 
Old 03-07-2004, 07:18 AM   #3
polgas
LQ Newbie
 
Registered: Sep 2003
Distribution: Slackware
Posts: 26

Rep: Reputation: 15
Quote:
- I can't find my CDROM's
check your /etc/fstab file. if your CDROM is there, just right click on the desktop and create a link for your cdrom. of couse you have to specify the correct path (ie /mnt/cdrom).

Quote:
- I can't configure my sound
run alsaconfig in console as root.

Quote:
- I can't activate/configure my mousewheel..
is your mouse connected via USB or PS/2? if it is connected via USB make sure your hotplug is running and your mouse is detected. you have to edit your /etc/XF11Config file. i am at work now. i'll try to post my XF11Config file later.

Quote:
And another problem is that I am using KDE and when I log out, then I've got to turn the computer off manually, can i do it with a command? Which one?
do you go back to the console when you log out? anyways, you can run "halt" in a console as root whethere still inside X or not and it will shut down your PC.
 
Old 03-07-2004, 07:22 AM   #4
George666
Member
 
Registered: Nov 2003
Distribution: Slackware
Posts: 63

Rep: Reputation: 15
- Sound : alsaconf
- Mouse Wheel :
in /etc/X11/XF86Config

Under "Section InputDevice"

Option "Protocol" "IMPS/2" # you most likely have PS/2
Option "ZAxisMapping" "4 5" # this needs to be on to

- Turning the power off : APM
open /etc/rc.d/rc.modules and add the line /sbin/modprobe apm
Then run modprobe apm to load the apm module into the kernel
 
Old 03-07-2004, 07:23 AM   #5
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
To activate your mousewheel, check the file /etc/X11/XFConfig, and find the settings for your mouse.

The following must be included (if not, use the same format as the other lines to add them before the "End Section" line. If you must edit the file, you must do so as root-- a normal user cannot edit this file):

Option "Protocol" "IMPS/2" (this tells Linux that the mouse has a wheel)
Option "ZAxisMapping" "4 5" (this tells Linux to activate the wheel)

-------------------------------------------------------------------

Slackware does not automount CD-ROM drives; you will have to mount them yourself, or set them to automount in /etc/fstab, the file that configures the mounting of drives during the boot process. You can also look at /etc/fstab to see if your CD-ROM drives are listed, what device names they are using, and where the mount points are.

If they are listed, you can try the command "mount /mnt/cdrom" (assuming that /mnt/cdrom is listed in /etc/fstab as a mount point for one of the drives, if another mount point is used, substitute the correct one) in a root terminal (in case you don't know, that means 1) open a terminal; 2) type "su" (without the quotes) and hit Enter; 3) type in the root password. You should see the prompt change from a "$" (which indicates a user) to a "#" which indicates root. All commands typed in this terminal will be considered as coming from root until you type "exit" to end the root access or close the terminal window).

If the CD-rom does not mount using that command, please post the error, and we'll go further (but there will be a couple of questions more you'll need to answer for us in that case).

--------------------------------------------------------------------------

You can't configure your sound? What kind of sound card is it? What are you trying to configure?

If the problem is simply that you cannot hear any sound, you can try KMix, the Gnome Mixer Applet (assuming you installed KDE and/or GNOME and are using one or the other of them), or type "aumix" in a terminal to unmute the sound, which is muted by default.

If you are getting error messages, please post what they are and what you are trying to do when you receive them.

Hope this helps.
 
Old 03-07-2004, 07:35 AM   #6
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31
Hi,

To not have to shut the computer down manually, you have to activate APM. Uncomment the line containing /sbin/modprobe apm in /etc/rc.d/rc.modules. To activate the APM now, just issue modprobe apm as root.

To activate your mouse wheel, you'll have to make a small change in your /etc/X11/XF86Config(-4). Find the Section "InputDevice" which deals with the mouse, and add the line
Code:
    Option "ZAxisMapping" "4 5"
You might also have to change the Protocol line to
Code:
    Option "Protocol" "IMPS/2"
My configuration for the mouse is
Code:
Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/psaux"
    Option "ZAxisMapping" "4 5"
EndSection
About your cd-roms: what does your /etc/fstab contain? Are your cd-roms mentioned there? Also, do they have a valid mount point? If for instance, you want to mount a cd-rom at /mnt/cdrom, then you have to create that directory as well; mkdir /mnt/cdrom.

Sound: what do you mean when you say that you can't configure your sound? If you just mean that there is no sound, it is in many cases muted right after install. Run for instance aumix (or maybe alsamixer if you're using ALSA) and set the volume to something other than zero

HTH

Last edited by Bebo; 03-07-2004 at 07:38 AM.
 
Old 03-07-2004, 07:36 AM   #7
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 31
God damn, FOUR answers at the same time!
 
Old 03-07-2004, 08:51 AM   #8
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
Use kdm if u want shutdown option from the kde logout menu
 
Old 03-07-2004, 09:13 AM   #9
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48
Re: Slack 9.1 problems

Quote:
Originally posted by Mr.Kex


- I can't find my CDROM's

look in the /dev/ directory and make sure that
/dev/cdrom is a symlink to /dev/hdc
 
Old 03-07-2004, 11:56 AM   #10
Mr.Kex
Member
 
Registered: Jan 2004
Location: Belguim
Distribution: Slackware 9.1
Posts: 63

Original Poster
Rep: Reputation: 15
/ect/fstab

/dev/hda2 swap swap defaults 0 0
/dev/hda1 / reiserfs defaults 1 1
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

What now?

*** *** *** *** ***

Alsaconfig?

root@downtown:~# su -

"I shot an arrow into the air, and it stuck."
-- Graffito in Los Angeles

root@downtown:~# alsaconfig
-su: alsaconfig: command not found
root@downtown:~#


*** *** *** *** ***

And my mouse is PS2, work fine, but I can't use the wheel
--- --- --- --- ---
 
Old 03-07-2004, 12:53 PM   #11
Mr.Kex
Member
 
Registered: Jan 2004
Location: Belguim
Distribution: Slackware 9.1
Posts: 63

Original Poster
Rep: Reputation: 15
And how to change desktop, my startx default is GNOME, what if I want KDE?
 
Old 03-07-2004, 03:29 PM   #12
Ninja Cow
Member
 
Registered: May 2003
Location: Pensacola, Florida
Distribution: Debian, Slackware, Amigo, Ubuntu
Posts: 221

Rep: Reputation: 30
Quote:
Originally posted by Mr.Kex
And how to change desktop, my startx default is GNOME, what if I want KDE?
Run xwmconfig and select from the list.
 
Old 03-07-2004, 05:06 PM   #13
Mr.Kex
Member
 
Registered: Jan 2004
Location: Belguim
Distribution: Slackware 9.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Ninja Cow
Run xwmconfig and select from the list.
THX
 
Old 03-07-2004, 05:07 PM   #14
Mr.Kex
Member
 
Registered: Jan 2004
Location: Belguim
Distribution: Slackware 9.1
Posts: 63

Original Poster
Rep: Reputation: 15
Okay, my sound card is working (it was just alsaconf)

But now my mouse and cdrom's
 
Old 03-07-2004, 10:46 PM   #15
Ninja Cow
Member
 
Registered: May 2003
Location: Pensacola, Florida
Distribution: Debian, Slackware, Amigo, Ubuntu
Posts: 221

Rep: Reputation: 30
Quote:
Originally posted by Mr.Kex
Okay, my sound card is working (it was just alsaconf)

But now my mouse and cdrom's
Run mouseconfig.

Select your mouse.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Slack 10 brokenflea Slackware 3 09-07-2004 11:55 PM
Few installation problems on slack 10 merlin371 Slackware 10 08-02-2004 02:57 AM
A few problems with Slack 10.0 Smile005 Slackware 10 06-30-2004 07:55 PM
slack 9.1 wireless problems ming0 Linux - Hardware 4 11-08-2003 01:14 AM
a few problems in slack 8.1 Jingles Slackware 10 09-27-2002 11:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration