LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   slack 9.1 - kernel panic on bootup? (https://www.linuxquestions.org/questions/slackware-14/slack-9-1-kernel-panic-on-bootup-117589/)

rogue_jedi 11-18-2003 08:43 PM

slack 9.1 - kernel panic on bootup?
 
i just got the slack 9.1 disks (switched to slack from redhat 9) and with the default kernel & everything it gets a kernel panic on boot, saying it has an 'init' error. i tried adding init=/dev/hda7 (my / partition in linux) but it still failed.

i have an a7n8x dlx(sata controller disabled), a 9000Pro 64mb, a seagate 120gb (non-sata), ps2 keyboard/usb mouse, onboard everything else (using the 3com lan) the only options i'm passing the kernel are hdd=ide-scsi (my cdburner) rh9 worked so i don't think it's hardware (though it may be a compatibility issue with slack)

i'm a quasi-newbie (kinda know my way around rh, but new to slack) so be nice:)

thanks.

Rodrin 11-19-2003 12:03 PM

Can you be more specific about the error? That it's an init error is a start, but not really enough to go on. This is on first boot following installation, correct?

rogue_jedi 11-19-2003 06:41 PM

i fixed the problem. lilo was looking at /dev/hda1 and not /dev/hda7 (/boot rather than /) so i booted off the cd and changed it. told you i was a slackware n00b;)

new problem: sound/nvidia nic? it says i need gcc2 & i have a gcc3 kernel. i know there is a way around this but it's been a while. any ideas?

thanks tho.

edit: /me idiot. browsed the forums, saw a possible solution, tried it & it worked. (run alsaconf...:o)

nic might still be a problem & i'd like the agp drivers. is that kernel level (rebuild kernel) or driver level (find a driver)?
thanx

rogue_jedi 11-21-2003 07:13 PM

please disregard this thread. i'm being an idiot. i fixed all the problems i was having, so it works alright now. kbye


All times are GMT -5. The time now is 09:39 AM.