-   Slackware (
-   -   Slack 9.1:kernel not remembering loaded modules. (

abhay 12-12-2003 07:57 AM

Slack 9.1:kernel not remembering loaded modules.
i just installed 2.6.0-test11 by using a guide i found on internet.
now the problem is that everything works fine but the sound. it is an onboard i810 which works fine with the default kernel but not with the new one.
i did compile the sound modules and i can load them by doing

modprobe snd-intel8x0
modprobe snd-pcm-oss
modprobe snd-mixer-oss
modprobe snd-seq-oss

after this sound works. i tried it by doing this

cat sound file > /dev/dsp
mpg123 somemp3

even lsmod shows all the loaded modules but the problem is that the kernel does not remember it after a reboot as when i do lsmod i get just ntfs as result.
can some one please help me and tell me as to how should i go ahead and make kernel remember these loaded modules after a reboot.
thanx for reading.

samwwwblack 12-12-2003 08:15 AM

Have you added the modules to rc.modules? This is probably the problem, as modprobe is only temporary;

as root,

#cd /etc/rc.d

(Highlight the rc.modules entry and press F4)


/sbin/modprobe snd-intel8x0
/sbin/modprobe snd-pcm-oss
/sbin/modprobe snd-mixer-oss
/sbin/modprobe snd-seq-oss

in the sound support section

Hope this solves your problem,

Best Regards,

Sam Black

abhay 12-12-2003 09:34 AM

damn i m moron...
thanx a lot pal as that worked but the thing i don't understand is that when i did modprobe ntfs then it remembered the module but not the sound ones. any ideas as to why that happened?
thanx once again...cheers...

samwwwblack 12-12-2003 09:43 AM


Your guess is as good as mine to that one, unless hotpluggin/other rc.d scripts picked it up - I stick to editing the files rather than rely on programs to do it for me, as it sounds a lot like another OS we're all trying to get away from. ;)

Best Regards,

Sam Black

All times are GMT -5. The time now is 03:46 PM.