-   Slackware (
-   -   Slack 8.1 Zipslack 9.1 compiling 2.6.0 (

o0sketchdude0o 01-03-2004 06:59 AM

Slack 8.1 Zipslack 9.1 compiling 2.6.0
This is kind of from left field, I know, but I've been trying to compile the 2.6.0 kernel on zipslack.

Following the newby instructions posted here has been a big help, since this is the first time I've ever tried to compile a custom kernal.

Anyway, the compile goes fine, but booting the new kernel causes a kernel panic error:

Warning: unable to open initial console
Kernel panic: No init found
Try passing init= option to kernel

Besides that, the frame buffer appears to be off. When it boots, a white bar appears across the screen, and then the penguin appears on the left, and after a second or two the screen appears normally.

Well, I was just using Zipslack as a test installation anyway. I run slack 8.1 on a native partition for my main linux setup.

Just for the hell of it, I copied over the 2.6.0 kernel to my native linux partition, and the damn thing boots right up! The frame buffer still does the same thing, and it crashes when I try to startx, but everything else runs fine. I do get this error right before the login prompt:

gpm: oops() invoked from gpm.c(977)

Anyway this is all new to me. I would appreciate if anyone has any info on how the slack developers are able to get support for the umsdos filesystem compiled into their kernels. I tried applying patches and even edited the /usr/src/linux/.config manually, but to no avail.

gnashley 01-03-2004 12:16 PM

I forget, but isn't there an option for umsdos file system support in kernel configuration? You should avoid manually editing the .config file as this can cause problems. the problem with gpm can be fixed by editing scripts under /etc/rc.d- that's where the gpm mouse server gets started. If the package is not installed and the script calls for it, it will return an error.
You could study the config options for the Zipslack kernel, also for clues on what you need to include. You'll find the .config file on the mirrors under kernels/Zipslack

o0sketchdude0o 01-03-2004 04:10 PM

Ok, thanks. I was assuming the default Zipslack kernel was bare.i, and using that .config file as a reference for my first few compiles.

I can confirm that the bare.i kernel for 2.4.22 was compiled with the


set in the .config file.

I was unable to find a umsdos option under menuconfig for 2.6.0- I even spent close to an hour enabling and disabling all the various filesystem options to see if umsdos is dependent on another filesystem or block device option. I also went through the make config question & answers on my second compile, with no umsdos option showing up.

The frustrating thing is, the
directory is right there in the kernel source tree, with a Makefile. That's why I manually added the option to my .config on this last compile. I watched really close while it compiled to see if make would complain about it, but it seems to have just ignored it, and no umsdos object files appeared anywhere.

I'm sure I have missed something really obvious here.

josath 01-06-2004 07:28 PM

umsdos not compatible with kernel 2.6
hello, as of right now, umsdos is not compatible with kernel 2.6.0. It apparently needs some major code rewriting as it was a bit of a hack and will not work with the way 2.6 handles inodes or something like that. Not too many people are working on this, so don't expect it to work any time soon.

see the following kernel archive posts for more info:

gnashley 01-07-2004 04:32 PM

I suspected that might be the case, since the umsdos files system is not much used. i hope that something similar is done so that linux will run from NTFS, not for me, but for those who are running those horrid XP thingies!

All times are GMT -5. The time now is 06:54 PM.