-   Slackware (
-   -   slack 64 14 and HP Laserjet P1102 with foomatic (

gauchao 05-15-2013 11:40 AM

slack 64 14 and HP Laserjet P1102 with foomatic
I have a box running slackware 64 14 with cups 1.5 and a usb printer HP LaserJet P1102. I have installed foomatic foo2zjs (as described elsewhere, which by the way works fine for another machines with slack 13.X, cups 1.4 and hp laserjet p1005). The problem is: after a job is sent to printer, the printer appears to be paused and refuses to print any other job. I have googled it and have found similar threads, but no satisfactory solutions provided. Does anybody have a similar problem? Thank you for any help!

torimus 05-15-2013 04:37 PM

Although I don't experience described behavior (different printer model) I would start at reading logs in /var/log/cups, error_log first and try to identify the issue.
You may also try to temporary change the LogLevel from warn to debug to get much more output and details in above mentioned logs. Do not forget to restart cups daemon, of course.


gauchao 05-15-2013 05:59 PM

Thank you, TC.

/var/log/cups/error_log has some lines like this:

E ["date and time"] Missing <Job #> directive on line "xx"!

Nothing else.

zakame 05-16-2013 01:15 AM

Did you install it through CUPS only, or through HPLIP?

torimus 05-16-2013 04:21 AM


Originally Posted by gauchao (Post 4952062)
Thank you, TC.

/var/log/cups/error_log has some lines like this:

E ["date and time"] Missing <Job #> directive on line "xx"!

Nothing else.

Did you enabled debugging output ? What about access_log ?

tronayne 05-16-2013 06:26 AM

HPLIP was upgraded a day or two ago to version hplip-3.13.5; it cures some ills.

You can download the source from (or start at and click on the link to the above at the bottom of the page, "Advanced users may wish to download the HPLIP tar package. (Download Tarball Digital Certificate) What's this?" or, maybe, get it from current (not sure about that one).

Once you've got the source, use the HPLIP SlackBuild from the distribution source CD/DVD to build the package then upgradepkg hplip-3.13.5-x86_64-1.txz.

Might go a long way toward fixing glitches.

Hope this helps some.

gauchao 05-16-2013 11:24 AM

I did install the printer through CUPS. Actually I am used to remove HPLIPS to install these HP LaserJets - it only works without HPLIPS, but I will try to upgrade the package and give it a try, thank you.

TC, I havenīt changed to debug mode. I am away from my desk now. As soon as I get there I will follow your suggestion and post the output lines here. Thank you

gauchao 05-25-2013 06:12 AM

Solved. After applying the last kernel patch to 3.2.45 the problem was solved. Thank you for everything.

All times are GMT -5. The time now is 03:15 AM.