-   Slackware (
-   -   slack 14 - tv card (

markomarko 04-12-2013 06:28 PM

slack 14 - tv card
Could you please help me to setup my tv card, because i'm clueless.
I tried to search through "", but i't too complicated for me (i stuck at "" (recognising my card) :-/

I have clean slack 14 installation, with default huge kernel (3.2.29).

I didn't installed any new driver.

As far as i know i have some Intex tv card.

And i have analog tv (throug cable).

This is "saa" output:

[ 8.299604] saa7130/34: v4l2 driver version 0, 2, 17 loaded
[ 8.303327] saa7134 0000:04:05.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[ 8.306983] saa7130[0]: found at 0000:04:05.0, rev: 1, irq: 20, latency: 64, mmio: 0xfe8ffc00
[ 8.310679] saa7134: Board is currently unknown. You might try to use the card=<nr>
[ 8.310679] saa7134: insmod option to specify which board do you have, but this is
[ 8.310680] saa7134: somewhat risky, as might damage your card. It is better to ask
[ 8.310681] saa7134: for support at


[ 8.775126] saa7130[0]: subsystem: 1131:0000, board: UNKNOWN/GENERIC [card=0,autodetected]
[ 8.777117] saa7130[0]: board init: gpio is c04000
[ 8.880214] saa7130[0]: Huh, no eeprom present (err=-5)?
[ 8.882547] saa7130[0]: registered device video0 [v4l2]
[ 8.884830] saa7130[0]: registered device vbi0

and this is "lspci -vnn" output:

04:05.0 Multimedia controller [0480]: Philips Semiconductors SAA7130 Video Broadcast Decoder [1131:7130] (rev 01)
Subsystem: Philips Semiconductors SAA7130-based TV tuner card [1131:0000]
Flags: bus master, medium devsel, latency 64, IRQ 20
Memory at fe8ffc00 (32-bit, non-prefetchable) [size=1K]
Capabilities: [40] Power Management version 1
Kernel driver in use: saa7134

So, could someone guide me through installation?
Also, i don't know which application to use for watching tv.

Than you in advance!

allend 04-12-2013 10:08 PM

Your device appears to be the same as here.
Try, as root, 'modprobe saa7134 card=3 tuner=55'.
If this works, you can do:
'echo "modprobe saa7134 card=3 tuner=55" > /etc/modprobe.d/tvcard.conf' to save the settings permanently.

You can watch TV using mplayer. Post #2 here may give some ideas on using options.

markomarko 04-14-2013 08:36 AM

Thank you allend, now i'm a bit closer to have a tvcard working:-)
I did as you said "rmmod saa7134 && modprobe saa7134 card=3 tuner=55" and installed tvtime.

Now, i can see only one channel (and without sound) when i change "video source" to "Composite2"
But in that case, i can't scan channels.

If i change "video source" to "television", it shows blue screen with "No Frequency" and "No signal" messages. But now i have option "Channel managament" with option "Scan channels for signal". Unfortunately, nothing happens.

I'm from Serbia (Southeastern Europe) so i set up "television standard" to "PAL" and "audio standard" to "PAL-BG".

What i have to do now?

Thanks :-)

allend 04-14-2013 11:49 AM

For tuning, try 'tuner=54' rather than 'tuner=55'. My Serbian is non-existent, but the Google translation of this page suggests that is a better setting.

For sound, you could try 'modprobe saa1734-alsa' and see whether you have a sound source in alsamixer.

markomarko 04-14-2013 06:34 PM

Excellent! I did it! :-)

After you told me to change tuner to 54 instead of 55 and gave me that serbian forum (there's nothing relevant on it) i started googling for "tvtime one chanell card tuner setup" or something like that.
I found where jeevas.v posted solution:
"options saa7134 card=121"

I tried it and it worked :-)

After that i only had to enable sound, so i unmuted rear mic in my alsamixer (because i connected tvcard output with rear mic) and now everything works!

Now i only have to enable remote control. I saw that it has something with lirc, but i'll try that tomorrow, because it's 1.30am in Serbia :-)

Once again thank you allend :-)

allend 04-15-2013 07:07 AM

I am impressed that you got this working despite my misguidance :-). My google fu failed me, as I did not come across the link you gave.

All times are GMT -5. The time now is 09:30 PM.