LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-21-2019, 03:11 PM   #1
chud1950
LQ Newbie
 
Registered: Jan 2008
Posts: 27

Rep: Reputation: 1
Slack 14.1 host, vbox 6.02 fails to start any guests


Today I noticed that VirtualBox wouldn't start any of my guest VM's. I don't remember the exact error, but it suggested installing the latest version, which I did, 6.02 from the Oracle site. As I recall it was working a couple weeks ago.

Anyway, this is what I get when I try to start a VM guest:
Quote:
The virtual machine 'Win7-Ultimate-32bit' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {5047460a-265d-4538-b23e-ddba5fb84976}
I verified that I'm still a member of vboxusers.
Quote:
bash-4.2$ id
uid=1000(username) gid=100(users) groups=100(users),17(audio),18(video),19(cdrom),83(plugdev),999(vboxusers)
I rebuilt the vbox module using vboxdrv setup.

The modules seem to be loaded:
Quote:
root@hostname:~# lsmod | grep -i vbox
vboxpci 16249 0
vboxnetadp 19028 0
vboxnetflt 19970 0
vboxdrv 389073 3 vboxnetadp,vboxnetflt,vboxpci
This is what I see vbox related in log files:
Quote:
messages:
Jan 21 13:02:37 hostname vboxdrv.sh: Starting VirtualBox services.
Jan 21 13:02:37 hostname kernel: [ 39.027027] vboxdrv: TSC mode is Invariant, tentative frequency 3392266878 Hz
Jan 21 13:02:38 hostname kernel: [ 39.763247] vboxpci: IOMMU not found (not registered)
Jan 21 13:02:38 hostname vboxdrv.sh: VirtualBox services started.

syslog:
Jan 21 13:02:37 hostname kernel: [ 39.259859] VBoxNetFlt: Successfully started.
Jan 21 13:02:38 hostname kernel: [ 39.538582] VBoxNetAdp: Successfully started.
Jan 21 13:02:38 hostname kernel: [ 39.749591] VBoxPciLinuxInit
Nothing alarming in vbox-install.log or vbox-setup.log:
Quote:
root@hostname:/var/log# cat vbox-install.log

VirtualBox 6.0.0 r127566 installer, built 2018-12-18T12:40:58Z.

Testing system setup...
Installing VirtualBox to /opt/VirtualBox

vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: Starting VirtualBox services.
Installation successful
root@hostname:/var/log# cat vbox-setup.log
Building the main VirtualBox module.
Building the net filter module.
Building the net adaptor module.
Building the PCI pass-through module.
I also tried the 6.0.0 installer from Oracle, but same result. I haven't tried any of the older versions. I think the version I had was 4.2.something.

Can anyone help me troubleshoot this further?
Thanks.
 
Old 01-21-2019, 04:00 PM   #2
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,082

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
Hi chud1950,

I had similar issues this weekend ... In my case it had to do with the kernel version and the versions of the different vbox packages.

Solution for me was :
  • linux kernel version 4.20.3
  • Virtualbox, Virtualbox Host Modules, Virtualbox Oracle Extensions and Virtualbox Guest ISO all at 6.02

... wrong combinations led to not being able to start *any* guests on that host.

CAVEAT: Shared folders is now non-functional ... I am hoping this gets resolved in upcoming kernel and/or Virtualbox updates ...

Hope you find your solution - Cheers.
 
Old 01-22-2019, 08:50 AM   #3
chud1950
LQ Newbie
 
Registered: Jan 2008
Posts: 27

Original Poster
Rep: Reputation: 1
Thanks.

I wonder why it broke in the first place. As I recall it was fine a couple weeks ago. I did some updates via slackpkg in the meantime; xscreensaver, irssi, glibc-zoneinfo, and zsh. But I wouldn't expect any of those to break vbox guests.

I'll probably try one of the slackbuilds today.
 
Old 01-22-2019, 11:03 AM   #4
chud1950
LQ Newbie
 
Registered: Jan 2008
Posts: 27

Original Poster
Rep: Reputation: 1
I was able to get vbox 5.2.24 from Oracle to start my guests.
However, the client wouldn't start at first. Again I forgot the exact error, but it was something about dlopen() failed from /opt/VirtualBox/VBoxRT.so, which was the same error I got before I upgraded to 6.0.2.

According to the Oracle forum this error is sometimes caused by bad directory permissions. So I noticed that my /opt directory was owned by myuserid:group. After I changed it to root:root the 5.2.4 client started and I was able to start guests.

Also I noticed that /etc and /usr was owned by myuserid:users. I don't remember ever changing those either.

So this is solved. But I wonder how those owners ever got changed.
 
Old 01-22-2019, 12:11 PM   #5
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,785

Rep: Reputation: Disabled
it could be that you assembled/converted as user some package and then installed it in the system as root, overwriting those directories with the ones with wrong permissions.
 
Old 01-22-2019, 01:34 PM   #6
chud1950
LQ Newbie
 
Registered: Jan 2008
Posts: 27

Original Poster
Rep: Reputation: 1
Quote:
it could be that you assembled/converted as user some package and then installed it in the system as root, overwriting those directories with the ones with wrong permissions.
It was probably something like that.

Btw: I tried the 6.0.2 installer from Oracle, and it installed and runs guests now, with the /opt owner set to root:root.

I may go back to 5.2.24, the 6.0 version seems a little beta. But at least the 6.0.2 client runs and starts guests.

Quote:
CAVEAT: Shared folders is now non-functional ... I am hoping this gets resolved in upcoming kernel and/or Virtualbox updates
I was able to create a shared folder in a 6.0.2 Win7 32bit guest. My client host is Slack 14.1 64bit with 3.10.107 SMP kernel. Network shares via SMB/CIFS work as well.

Thanks for the responses. This is solved.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome Display Manager Fails to Start After VBox Install Problem harley51 Fedora - Installation 1 11-30-2016 06:40 PM
[SOLVED] Problem after upgrade VBox 4.3 to Vbox 5.0 satimis Linux - Virtualization and Cloud 8 02-18-2016 11:57 AM
[SOLVED] Choppy audio playback in any VirtualBox Guests. Host = Centos 6.5. readmore Linux - Software 1 01-31-2014 10:39 PM
[SOLVED] vbox 4.0.2 - guest sabayon5.4 on win7 - mnt local gentoo from vbox sabayon? shinystuffrox Linux - Virtualization and Cloud 1 03-04-2011 01:10 AM
Upgrading VBox 2.0.2 on Fedora 9 to VBox 2.0.6 fcquayso Linux - Newbie 2 12-10-2008 04:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration