LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-13-2008, 07:31 AM   #1
svar
Member
 
Registered: Jul 2003
Posts: 360

Rep: Reputation: 30
Slack 12 ADSL ethernet Setup


I am looking to get ADSL(via ethernet, not USB) with slack 12.
Is there a howto or list of what kind of setup I need to make?
 
Old 03-13-2008, 08:16 AM   #2
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
It's usually as simple as running 'netconfig' as root.
 
Old 03-13-2008, 09:50 AM   #3
/y0shi
Member
 
Registered: Jan 2006
Location: berlin, germany
Distribution: slackware 12.0
Posts: 58

Rep: Reputation: 17
Quote:
Originally Posted by H_TeXMeX_H View Post
It's usually as simple as running 'netconfig' as root.
I think it is important to know how exactly you want to connect. I heard nothing about routers, so it is possible that svar meant ppp over ethernet (pppoe). In that case you have a direct connection between the box and a DSL modem. So running netconfig is not required but running
Code:
# pppoe-setup
This will guide you through a dialog, after that run
Code:
# pppoe-start
You can write the last command into your rc.local in order to get a connection at startup.

If you are more the GUI kind a guy you could install tkpppoe - its not included, but also enables normal users to start and stop connections (if this is wanted).
 
Old 03-13-2008, 01:51 PM   #4
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Yeah, there was no mention of a router or much of anything.

To the original poster, please post a bit more info, I mean you're leaving us here with nothing to go on, and then expect miracles. Please post more info.
 
Old 03-16-2008, 07:00 PM   #5
svar
Member
 
Registered: Jul 2003
Posts: 360

Original Poster
Rep: Reputation: 30
Thanks for the help, and sorry for the confusion. y0shi was correct, I mean pppoe.
I got an error though on install pppoE client-
"oh dear I don't see the file /etc/ppp/pppoe.conf

So where do I get this-slackbuilds or somewhere in the slack 12 cds?
 
Old 03-16-2008, 07:39 PM   #6
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
The file should be there as it's included with rp-pppoe package. Try reinstalling it from your CDs or get it from a mirror: http://mirror.switch.ch/ftp/mirror/s...3.8-i486-2.tgz
If you really need the sources and Slackbuild: http://mirror.switch.ch/ftp/mirror/s...ce/n/rp-pppoe/
 
Old 03-21-2008, 04:12 AM   #7
svar
Member
 
Registered: Jul 2003
Posts: 360

Original Poster
Rep: Reputation: 30
Thanks. So installpkg s...3.8-i486-2.tgz should do?
 
Old 03-21-2008, 04:59 PM   #8
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,366

Rep: Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835
Download the file linked above to your hard drive, cd to the directory that you downloaded it to and type the following:
Code:
# installpkg rp-pppoe-3.8-i486-2.tgz
 
Old 04-05-2008, 01:33 PM   #9
svar
Member
 
Registered: Jul 2003
Posts: 360

Original Poster
Rep: Reputation: 30
ok, got it installed fine. The only question is do I also need to set up eth0(ifconfig...)?

I get

:/etc# pppoe-start
................TIMED OUT
root@darkstar:/etc# pppoe-status
pppoe-status: Link is down (can't read pppoe PID file /var/run/pppoe.conf-pppoe.pid.pppoe)
root@darkstar:/etc# ping 192.168.1.1
connect: Network is unreachable


/etc# pppoe-setup
Welcome to the Roaring Penguin PPPoE client setup. First, I will run
some checks on your system to make sure the PPPoE client is installed
properly...

Looks good! Now, please enter some information:

USER NAME

>>> Enter your PPPoE user name (default abcd): xxxxx

INTERFACE

>>> Enter the Ethernet interface connected to the DSL modem
For Solaris, this is likely to be something like /dev/hme0.
For Linux, it will be ethn, where 'n' is a number.
(default eth0):

Do you want the link to come up on demand, or stay up continuously?
If you want it to come up on demand, enter the idle time in seconds
after which the link should be dropped. If you want the link to
stay up permanently, enter 'no' (two letters, lower-case.)
NOTE: Demand-activated links do not interact well with dynamic IP
addresses. You may have some problems with demand-activated links.
>>> Enter the demand value (default no):

DNS

Please enter the IP address of your ISP's primary DNS server.
If your ISP claims that 'the server will provide DNS addresses',
enter 'server' (all lower-case) here.
If you just press enter, I will assume you know what you are
doing and not modify your DNS setup.
>>> Enter the DNS information here:

PASSWORD

>>> Please enter your PPPoE password:
>>> Please re-enter your PPPoE password:

FIREWALLING

Please choose the firewall rules to use. Note that these rules are
very basic. You are strongly encouraged to use a more sophisticated
firewall setup; however, these will provide basic security. If you
are running any servers on your machine, you must choose 'NONE' and
set up firewalling yourself. Otherwise, the firewall rules will deny
access to all standard servers like Web, e-mail, ftp, etc. If you
are using SSH, the rules will block outgoing SSH connections which
allocate a privileged source port.

The firewall choices are:
0 - NONE: This script will not set any firewall rules. You are responsible
for ensuring the security of your machine. You are STRONGLY
recommended to use some kind of firewall rules.
1 - STANDALONE: Appropriate for a basic stand-alone web-surfing workstation
2 - MASQUERADE: Appropriate for a machine acting as an Internet gateway
for a LAN
>>> Choose a type of firewall (0-2): 1

** Summary of what you entered **

Ethernet Interface: eth0
User name: xxxx
Activate-on-demand: No
DNS: Do not adjust
Firewalling: STANDALONE

>>> Accept these settings and adjust configuration files (y/n)? y
Adjusting /etc/ppp/pppoe.conf
Adjusting /etc/ppp/pap-secrets and /etc/ppp/chap-secrets
(But first backing it up to /etc/ppp/pap-secrets-bak)
(But first backing it up to /etc/ppp/chap-secrets-bak)



Congratulations, it should be all set up!

Type 'pppoe-start' to bring up your PPPoE link and 'pppoe-stop' to bring
it down. Type 'pppoe-status' to see the link status.
root@darkstar:/etc# pppoe-start
................TIMED OUT
root@darkstar:/etc# pppoe-status
pppoe-status: Link is down (can't read pppoe PID file /var/run/pppoe.conf-pppoe.pid.pppoe)
root@darkstar:/etc# ping 192.168.1.1
connect: Network is unreachable
root@darkstar:/etc#
 
Old 04-11-2008, 05:07 AM   #10
/y0shi
Member
 
Registered: Jan 2006
Location: berlin, germany
Distribution: slackware 12.0
Posts: 58

Rep: Reputation: 17
Quote:
Originally Posted by svar View Post
DNS

Please enter the IP address of your ISP's primary DNS server.
If your ISP claims that 'the server will provide DNS addresses',
enter 'server' (all lower-case) here.
If you just press enter, I will assume you know what you are
doing and not modify your DNS setup.
>>> Enter the DNS information here:

PASSWORD

>>> Please enter your PPPoE password:
>>> Please re-enter your PPPoE password:

FIREWALLING

Please choose the firewall rules to use. Note that these rules are
very basic. You are strongly encouraged to use a more sophisticated
firewall setup; however, these will provide basic security. If you
are running any servers on your machine, you must choose 'NONE' and
set up firewalling yourself. Otherwise, the firewall rules will deny
access to all standard servers like Web, e-mail, ftp, etc. If you
are using SSH, the rules will block outgoing SSH connections which
allocate a privileged source port.

The firewall choices are:
0 - NONE: This script will not set any firewall rules. You are responsible
for ensuring the security of your machine. You are STRONGLY
recommended to use some kind of firewall rules.
1 - STANDALONE: Appropriate for a basic stand-alone web-surfing workstation
2 - MASQUERADE: Appropriate for a machine acting as an Internet gateway
for a LAN
>>> Choose a type of firewall (0-2): 1

** Summary of what you entered **

Ethernet Interface: eth0
User name: xxxx
Activate-on-demand: No
DNS: Do not adjust
Firewalling: STANDALONE

>>> Accept these settings and adjust configuration files (y/n)? y
Adjusting /etc/ppp/pppoe.conf
Adjusting /etc/ppp/pap-secrets and /etc/ppp/chap-secrets
(But first backing it up to /etc/ppp/pap-secrets-bak)
(But first backing it up to /etc/ppp/chap-secrets-bak)



Congratulations, it should be all set up!

Type 'pppoe-start' to bring up your PPPoE link and 'pppoe-stop' to bring
it down. Type 'pppoe-status' to see the link status.
root@darkstar:/etc# pppoe-start
................TIMED OUT
root@darkstar:/etc# pppoe-status
pppoe-status: Link is down (can't read pppoe PID file /var/run/pppoe.conf-pppoe.pid.pppoe)
root@darkstar:/etc# ping 192.168.1.1
connect: Network is unreachable
root@darkstar:/etc#
You just typed enter at the DNS section your probably should have typed the word "server" there (If you just press enter, I will assume you know what you are doing and not modify your DNS setup).

I'm not sure weather thats the only thing, but I also use NONE as the firewall option and than use my own - you could try that too ...
 
Old 04-11-2008, 05:23 AM   #11
svar
Member
 
Registered: Jul 2003
Posts: 360

Original Poster
Rep: Reputation: 30
Hmm... I did setup eth0 by giving an IP, netmask and broadcast.
These are the same as in a ubuntu boot in the same machine(which works)
With the settings(but without pppoe-start) I can get to the ISP site (192.168.1.1) where you enter the parameters for the modem(baudtek) and enter setting fine. This is the same I can do with Ubuntu. The only difference is that with Ubuntu I have internet (e.g. www.google.com) while in the slack I do not.
I also need to look perhaps at the MTU setting, or just correct the server thing in pppoe?
 
Old 04-11-2008, 05:38 AM   #12
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Do you have a sane '/etc/resolv.conf' ?
 
Old 04-11-2008, 10:38 AM   #13
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,630

Rep: Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529
I suggest that you have a look at the contents of /etc/ppp/resolv.conf
It should have lines like:
Quote:
nameserver xxx.yyy.zzz.aaa
nameserver xxx.yyy.zzz.bbb
where xxx.yyy.zzz.aaa and xxx.yyy.zzz.bbb are the primary and secondary DNS server IP addresses from your ISP.

I do not like the firewall-standalone that is supplied with pppoe. The default policy on the input chain is to accept everything, and then the script appends rules to:
Deny TCP and UDP packets to privileged ports,
Deny TCP connection attempts,
Deny ICMP echo-requests, (i.e. 'ping')
This is secure, but I prefer the reverse logic of a default policy on the input chain of dropping everything and then appending rules to explicitly allow traffic that you want. I think this is easier to change if want to allow certain types of inbound traffic.

What to do about the firewall is up to you. If you want a firewall that runs when Slackware is started, then place an rc.firewall script in /etc/rc.d/ and make it executable. Set the firewall option to NONE in pppoe-setup.

If you want the firewall to start only when your pppoe connection comes up, then you can use a firewall supplied in /etc/ppp/ as specified in pppoe-setup. Or, you can create a symbolic link /etc/ppp/ip-pre-up that points to the firewall script you want to run and set the firewall option to NONE in pppoe-setup.
 
Old 04-12-2008, 09:01 AM   #14
svar
Member
 
Registered: Jul 2003
Posts: 360

Original Poster
Rep: Reputation: 30
Yes, /etc/ppp/resolv.conf has the ISP DNS
nameserver 195.170.0.1

there is no secondary DNS though. Still I get the same behavior
 
Old 04-12-2008, 10:00 AM   #15
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,630

Rep: Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529
Do you have a default gateway setting in your /etc/rc.d/rc.inet1.conf?
Check your routing table with '/sbin/route -n'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adsl-setup or adsl-start not found as user! bnchakraborty Linux - Newbie 2 01-18-2008 10:23 PM
Manual setup of adsl with ethernet chronoss Mandriva 5 10-07-2005 05:39 PM
Need help with ethernet setup in Gentoo( During setup proccess) MimiMimi Linux - Distributions 2 07-19-2004 01:34 PM
prblms with ADSL setup. no luck after adsl-setup and netconfig Blue_muppet Slackware 2 07-18-2004 01:20 AM
ADSL Routers Setup- Microsom Deskporte router 100 and Planet ADSL modem router mabonline Linux - Hardware 1 02-27-2004 05:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration