LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-24-2009, 05:50 PM   #1
ash1ar
LQ Newbie
 
Registered: Dec 2007
Location: Harrisburg, Pa
Distribution: Slackware 12.2
Posts: 12

Rep: Reputation: 0
Red face Slack 12.2 mouse trap whack...


For some reason, each time I boot up from a shutdown, I must login as root and run: modprobe psmouse

Has anyone else had this issue? I'm having it on two machines with two different mice (one laser ps/2, the other a plain jane ps/2)?

Is there a solution, or do I just need to add this command to a startup script? If I need to add it to the startup, would someone please be so kind as to remind me where the script is, because it's been awhile and I've forgotten.
 
Old 07-24-2009, 06:44 PM   #2
xflow7
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 158

Rep: Reputation: 21
Can't tell from your post whether you have to modprobe psmouse because it's not loaded automatically at all when you boot, or because it needs to be re-initialized.

Regarding the latter, Slackware defaults to loading psmouse with the "proto=imps" option because of certain KVM problems if psmouse is started with its default ("proto=any"). However, this occasionally can cause things not to work (for example the synaptics touchpad module doesn't work with proto=imps).

Try editing /etc/modprobe.d/psmouse and changing "proto=imps" to "proto=any" and see what happens.
 
Old 07-24-2009, 09:12 PM   #3
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,199

Rep: Reputation: 290Reputation: 290Reputation: 290
The modprobe commands are in /etc/rc.d/rc.modules-`uname -r`
 
Old 07-25-2009, 07:51 AM   #4
ash1ar
LQ Newbie
 
Registered: Dec 2007
Location: Harrisburg, Pa
Distribution: Slackware 12.2
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by xflow7 View Post
Can't tell from your post whether you have to modprobe psmouse because it's not loaded automatically at all when you boot, or because it needs to be re-initialized.
"proto=any" and see what happens.
THanks for the suggestion. The issue is it does not seem to be loading at all when I start up. I was aware of the /etc/modprobe.d/psmouse situation and via another users suggestion I commented out the proto option entirely and reloaded psmouse. This worked at the time, and continues to, however even with the proto option commented out i still have to login as root after start up and reload the psmouse.

I did try un-commenting the proto option and substituting the imps option with any, gave a power down and power up, and I still have the same result.

In other news, which may or may not be related, when I get to the slackware splash screen at boot up my keyboard has all three lights on, but is unresponsive. I have to unplug and plug it back in to get it to work. Only then can I hit enter and proceed. I was going to do a search for that issue later, but thought I'd mention it in case there is a relationship between the two issues.
 
Old 07-25-2009, 07:58 AM   #5
ash1ar
LQ Newbie
 
Registered: Dec 2007
Location: Harrisburg, Pa
Distribution: Slackware 12.2
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by dive View Post
The modprobe commands are in /etc/rc.d/rc.modules-`uname -r`
Dive, thank you for the info. I ran that command with the following result:

/etc/rc.d> rc.modules -'uname -r'
Module dependencies up to date (no new kernel modules found).
FATAL: Error inserting pcspkr (/lib/modules/2.6.27.7-smp/kernel/drivers/input/misc/pcspkr.ko): Operation not permitted
FATAL: Module capability not found.
 
Old 07-25-2009, 08:35 AM   #6
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,019
Blog Entries: 1

Rep: Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364
Hi,

You could be experiencing the following;

Quote:
excerpt from 'CHANGES_AND_HINTS.TXT';

On many systems, the xf86-input-synaptics driver requires the psmouse kernel
kernel module be loaded without any special options. This poses a problem on a
default Slackware installation, as /etc/modprobe.d/psmouse causes the psmouse
module to load with the imps protocol. This is easily fixed though :-)
First, edit /etc/modprobe.d/psmouse so that it looks like this (note
that we're simply commenting out the last line):
# PS/2 mouse support:
# The default options when the psmouse module is loaded will completely
# break the mouse if you change consoles with several models of KVM
# switches. Therefore, we'll have it use the imps protocol here, which
# is a more basic protocol that is less likely to cause problems with
# the mouse. If you'd rather use the kernel default options, just
# comment out the line below. If you'd rather choose your own options,
# then edit the line below as desired.
#options psmouse proto=imps
Next, unload and reload the psmouse module (do this as root):
modprobe -r psmouse
modprobe psmouse
 
Old 07-25-2009, 10:02 AM   #7
ash1ar
LQ Newbie
 
Registered: Dec 2007
Location: Harrisburg, Pa
Distribution: Slackware 12.2
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
Hi,

You could be experiencing the following;
Indeed, but I shouldn't have to run the modprobe psmouse command every time I start up. That's the situation.
 
Old 07-25-2009, 10:31 AM   #8
conundrum07
LQ Newbie
 
Registered: Jan 2008
Distribution: Slackware
Posts: 13

Rep: Reputation: 0
You can add the modprobe command to your rc.local script if you want it to be loaded when you boot the system.
 
Old 07-25-2009, 12:52 PM   #9
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
Quote:
FATAL: Error inserting pcspkr (/lib/modules/2.6.27.7-smp/kernel/drivers/input/misc/pcspkr.ko): Operation not permitted
FATAL: Module capability not found.
Did you rebuild your kernel, or are you using a custom one? This error is kinda funky for a stock Slack kernel. Are you running the 2.6.27.2-smp kernel?
 
Old 07-25-2009, 02:12 PM   #10
ash1ar
LQ Newbie
 
Registered: Dec 2007
Location: Harrisburg, Pa
Distribution: Slackware 12.2
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by manwichmakesameal View Post
Did you rebuild your kernel, or are you using a custom one? This error is kinda funky for a stock Slack kernel. Are you running the 2.6.27.2-smp kernel?
I had Slack 12 before hand, then reinstalled with 12.2/upgraded. I just used the default hugesmp kernel that was recommended when I installed.
 
Old 07-25-2009, 03:02 PM   #11
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
Quote:
I had Slack 12 before hand, then reinstalled with 12.2/upgraded.
I'm not sure what you mean there. Did you format and do a fresh install, or did you just upgrade? Try using the generic kernel, and make an initrd. There is /boot/README.initrd that you should take a look at.
 
Old 07-26-2009, 12:46 AM   #12
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,906

Rep: Reputation: Disabled
It sounds like the psmouse module is blacklisted, which implies that the system was upgraded from 12.0 to 12.2 (as the OP later stated), and that the OP needs to read http://slackware.osuosl.org/slackwar..._AND_HINTS.TXT
 
Old 08-10-2009, 05:28 PM   #13
ash1ar
LQ Newbie
 
Registered: Dec 2007
Location: Harrisburg, Pa
Distribution: Slackware 12.2
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rworkman View Post
It sounds like the psmouse module is blacklisted, which implies that the system was upgraded from 12.0 to 12.2 (as the OP later stated), and that the OP needs to read http://slackware.osuosl.org/slackwar..._AND_HINTS.TXT
Bingo. You were absolutely correct sir. You're a gentleman and a scholar.
 
  


Reply

Tags
blacklist, mouse, psmouse, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to send snmp trap & recieve trap in C program minil Programming 3 07-10-2010 09:22 AM
Kernel trap (Fatal trap 12) m!k@EL *BSD 4 09-05-2007 11:58 PM
How do I whack stuff I don't want? lectraplayer VectorLinux 3 02-28-2006 01:46 PM
Videos, RGB out of whack PhuckFonix Linux - General 2 09-04-2004 05:31 AM
Resolution out of whack! stonehurstX11 Linux - Laptop and Netbook 0 01-22-2004 09:55 PM


All times are GMT -5. The time now is 01:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration