LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-15-2006, 10:38 PM   #1
mnemonix
LQ Newbie
 
Registered: Dec 2006
Posts: 4

Rep: Reputation: 0
Slack 11 : Doesn't detect USB devices & can't shutdown ??


Recently, I installed Slackware 11, and then found 2 problems.

1. It doesn't detect my USB devices (external HD,memory card reader,etc)
2. Every time I try to shutdown, it always stuck at 'Power down',
unless I hit the power button.

Any suggestion ?
Thanks in advance
 
Old 12-16-2006, 02:40 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,343

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
You might try to install kernel 2.6.x
That will solve most of your problems with hardware detection and also ACPI problems
 
Old 12-16-2006, 02:47 AM   #3
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Welcome to LQ!

Why do you say "It doesn't detect my USB devices (external HD,memory card reader,etc)"? How are you trying to detect them? Sorry, but you have one post and we have no clue as to your Linux knowledge.

From a terminal/konsole as root type "lsusb" and post the output here.

To make the computer turn off, you need some form of power management. The easiest thing to do is open a terminal, login as root, and in the file "/etc/rc.d/rc.modules" uncomment (remove the # in front of)
Code:
#/sbin/modprobe apm
If you're not familiar with Linux, use pico to edit that file; as it's more intuitive than other editors. Once you are logged in as root type "pico /etc/rc.d/rc.modules" without the quotes and then instructions are at the bottom of the screen.

Next you will need to edit "/etc/lilo.conf" and add
Code:
append ="apm=power-off"
after the line which reads
Code:
# Start LILO global section
After making changes to /etc/lilo.conf you must run "lilo" as root to write the changes.
 
Old 12-16-2006, 07:52 PM   #4
dosnlinux
Member
 
Registered: Mar 2005
Distribution: slackware 11, arch 2007.08
Posts: 154

Rep: Reputation: 30
If your using a kernel with ACPI you may need to add acpi=noirq to lilo.conf. If you get a lot of stuff about conflicting IRQs and an error on shutdown this might be your problem.
 
Old 12-17-2006, 03:54 AM   #5
mnemonix
LQ Newbie
 
Registered: Dec 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Bruce Hill
Welcome to LQ!

Why do you say "It doesn't detect my USB devices (external HD,memory card reader,etc)"? How are you trying to detect them? Sorry, but you have one post and we have no clue as to your Linux knowledge.

From a terminal/konsole as root type "lsusb" and post the output here.

To make the computer turn off, you need some form of power management. The easiest thing to do is open a terminal, login as root, and in the file "/etc/rc.d/rc.modules" uncomment (remove the # in front of)
Code:
#/sbin/modprobe apm
If you're not familiar with Linux, use pico to edit that file; as it's more intuitive than other editors. Once you are logged in as root type "pico /etc/rc.d/rc.modules" without the quotes and then instructions are at the bottom of the screen.

Next you will need to edit "/etc/lilo.conf" and add
Code:
append ="apm=power-off"
after the line which reads
Code:
# Start LILO global section
After making changes to /etc/lilo.conf you must run "lilo" as root to write the changes.
Sorry, I mean automounting.
I don't see something new at /dev/mnt
 
Old 12-17-2006, 04:36 AM   #6
M$ISBS
Member
 
Registered: Aug 2003
Posts: 818

Rep: Reputation: 30
When it says power down, thats when you hit the power button. there is a way to make it shut down auto, but that requires editing a config file somewhere........... ?????
 
Old 12-17-2006, 04:40 AM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by M$ISBS
When it says power down, thats when you hit the power button. there is a way to make it shut down auto, but that requires editing a config file somewhere........... ?????
See Bruce's post..
 
Old 12-17-2006, 06:04 AM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Originally posted by mnemonix
Quote:
Sorry, I mean automounting.
I don't see something new at /dev/mnt
Slackware by default does not do automounting. You have to recompile
the kernel, etc. for that. I am able to plug in a USB device and have
Konqueror mount it and open it's location simply by clicking on the
Removable Device icon under Storage Media, but that is not the same as
automounting.

Until you figure out automounting, you can put this in /etc/fstab:
Code:
/dev/sdb1        /usb1            vfat        noauto,users,rw,umask=1000  0  0
/dev/sdc1        /usb2            vfat        noauto,users,rw,umask=1000  0  0
(substitute /dev/sdb1 and /dev/sdc1 for your first two devices)
for your USB devices. You also need to create the /usb1 and /usb2 mount
points, then change the owner to your normal user by issuing:
Code:
chown mingdao.users /usb1
(substitute your username for mingdao)
and change the permissions to your liking. I use:
Code:
chmod 757 /usb1
because I'm the only one using this box, and I want full read/write
perms on my devices.

This Quick and Dirty Guide to Linux File Permissions in LQ's Linux Tutorials is very good.

And afaik Slackware doesn't use /dev/mnt:
Code:
mingdao@silas:~$ mount /usb1
mingdao@silas:~$ ls -lh /dev/mnt
/bin/ls: /dev/mnt: No such file or directory
It doesn't on my boxen.

Last edited by Bruce Hill; 12-17-2006 at 06:07 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE 9.3 - USB Diapeared & Non-Root users can shutdown system nuro305 Suse/Novell 9 04-14-2006 02:27 PM
Can't detect usb devices?? CM019 Debian 5 06-09-2005 01:43 PM
Integrating firewire & USB devices snowman156 Slackware 1 09-22-2004 10:30 PM
Can Hotplug detect USB devices in a certain order? SAM_site Linux - General 0 07-10-2004 07:27 AM
usb devices & red hat dlee Linux - General 4 10-27-2003 10:16 AM


All times are GMT -5. The time now is 09:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration