-   Slackware (
-   -   Slack 10 Install fails - kernel errors (

cxobert 08-05-2004 02:11 PM

Slack 10 Install fails - kernel errors
Here's my problem - I can't get Slackware to install without errors on one of my machines.

The description that follows is from Slackware 10, but 9.0 and 9.1 also failed to install on this machine.

Both of my machines are about a year old, from the same vendor, same hardware configuration, with fast processors, plenty of memory and large hard drives.

One one of my machines, Slackware installs fine. (I have configuration tweaks to do, but Hey, this is Slackware...)

On my problem machine, I get kernel errors flashing by during install (the screen goes black, briefly lists the fatal kernel error, then resumes), and one or more packages will get fatal error while installing. Sometimes it completes with missing packages and one or more components not set up right, sometimes it stops altogether with a segmentation fault, and hangs.

All of the packages are readable from the CD, and on one of the almost-there installs, I could add failed packages with installpkg without error, so the CD is okay.

I am using the default bare.i kernel.

This is a 2 drive, multi-partition setup, and I am trying to put Slackware into its own partition.

I have tried 2 different partitions.

I have tried slow format with error checking.

I have tried running fsck on one of the partitions before the install, and it comes up clean.

I have tried installing from packages copied to a different partition of my hard drive. Same symptoms.

This same machine is successfully and happily running Windows2000, Mandrake9.1 and MEPIS, each of which installed without incident. They coexist nicely thanks to LILO.

On my one machine where the install went okay, I really like Slackware. I am fairly new to Linux (about a year), and I am learning more running Slack then any other distro I've looked at. So, I would like to get this to work.

Anyone have any suggestions?


Charlie Obert
Minneapolis, Minnesota, USA
(Like Molly Ivins says - too damn cold.)

Cedrik 08-05-2004 02:58 PM

I would think the setup program has problem with your cdrom drive, I would consider a try to a network install with the help of the other machine running slackware and the docs from the install CD.

cxobert 08-09-2004 03:34 PM

Thanks for the response
Thanks for the suggestion.

I managed to get a workable install, by loading the packages onto another partition on the same machine, and then installing only needed packages from the hard drive instead of the cdrom. I still got kernel errrors, and 2 packages failed to load, but the installation completed anyway. I managed to get the failed packages to install after the new system booted up.

So, I'm up and running, and wrestling with getting the d*&!@#d sound card to work.

Thanks again,


All times are GMT -5. The time now is 09:37 PM.