LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-13-2004, 05:37 AM   #1
kule
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 87

Rep: Reputation: 16
slack 10 DPMS... very confusing


I installed a clean install of Slack 10 (I had 9.1) and everything was great except one thing. I'm using KDE and I like my monitor to turn off after 10 min. In 9.1 I configured that in "Display Power Control" in KDE Control Center and added a dpms line in xorg.conf (XF86Config) in the monitor section and that did the trick for me. But in Slack 10 my monitor turns of every 10 min, it doesn't matter if there is any activity, the screen just turns off and if I move my mouse at the moment when it turns off, it just flashes one time. So i added more lines in my xorg.conf:
Code:
Option "Blank Time"   "0"	# Blank the screen in 10 minutes (Fake)
Option "Standby Time" "0"	# Turn off screen in 20 minutes (DPMS)
Option "Suspend Time" "0"	# Full hibernation in 30 minutes (DPMS)
Option "Off Time"     "10"	# Turn off DPMS monitor (DPMS)
in the ServerLayout section, but when I login as root and run xset q it tells me dpms is enabled but the off time is not 600s (10min), but 36000s, but if I login as a regular user xset q tells me that off time is 600, but DPMS is diable. I tried everything this must be a xorg bug or something like that. Abd another thing, if I comment out the dpms line in xorg.cong when I enable dpms in xset and run xset dpms force off the monitor doesn't turn off it just displays a gray screen whith a big X in the middle.

Last edited by kule; 07-13-2004 at 05:39 AM.
 
Old 07-13-2004, 05:24 PM   #2
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
Read very carefully how you have the values set...

You have everything but the off time set to 0... I have a distinct feeling this is the root of your problem. Delete or comment out those lines, and leave only the off time setting for 10 minutes, and you should be good to go.

I think what's happening, is that the monitor doesn't turn off until the off time has passed -- then all the other times of "0" minutes register. That one blink is your "0" minute setting kicking in.

Linux does just what you tell it to

--Shade
 
Old 07-16-2004, 08:40 AM   #3
kule
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 87

Original Poster
Rep: Reputation: 16
That did't help; DPMS was enable if I login as a root, but disabled if I login as a regular user.
After that I commented out all these line axcept DPMS and configured Display Power Control in KDE to turn the monitor off, after 10min. The screen randomly flashe (sometimes after 10min and sometime after an hour) while I'm working in KDE. I don't think this has to do with this, but my terminal blanking is:

setterm -powersave powerdown -powerdown 15
 
Old 07-16-2004, 10:28 AM   #4
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,552

Rep: Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872
Post your kernel version number that may help us to see the context, also do you use acpi or apm ?
 
Old 07-16-2004, 11:41 AM   #5
kule
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 87

Original Poster
Rep: Reputation: 16
Sorry I forgot that.

Kernel version 2.6.7 (custom compile) and I'm using ACPI.
 
Old 07-16-2004, 02:43 PM   #6
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,552

Rep: Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872
Do you have udev feature enabled, hotplug ? And at Section "Monitor" (the one with HorizSync and VertRefresh settings), do you have :
Option "dpms"
?
 
Old 07-17-2004, 06:13 AM   #7
kule
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 87

Original Poster
Rep: Reputation: 16
Hotplug is enabled and this si a part of my xorg.conf:

Code:
Section "Monitor"
	Identifier	"Samsung957DF"
	HorizSync	30-96
	VertRefresh	85-160
	VendorName	"Samsung"
	ModelName	"957DF"
	ModeLine	"1280x1024@85Hz" 157.5 1280 1344 1504 1728 1024 1025 1028 1072  +HSync +VSync
	ModeLine	"1024x768@85Hz" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
	Option		"DPMS"
EndSection
I don't know what udev is, but I have a proces called udevd (must be 'udev deamon'). What is udev?

These are results from "xset q":

Code:
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  auto repeat delay:  250    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffdfffdfe5ef
                        ffffffffffffffff
                        ffffffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  20/10    threshold:  4
Screen Saver:
  prefer blanking:  no    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  /usr/X11R6/lib/X11/fonts/misc,/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/Speedo,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/TTF,/usr/X11R6/lib/X11/fonts/cyrillic,/opt/kde/share/fonts,/usr/local/share/fonts/TTF,/opt/kde/share/fonts
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 600
  DPMS is Enabled
  Monitor is On
Font cache:
  hi-mark (KB): 5120  low-mark (KB): 3840  balance (%): 70
File paths:
  Config file:  /etc/X11/xorg.conf
  Modules path: /usr/X11R6/lib/modules
  Log file:     /var/log/Xorg.0.log
I don't know what this means Bug Mode: compatibility mode is disabled.

Last edited by kule; 07-17-2004 at 07:22 AM.
 
Old 07-17-2004, 09:38 AM   #8
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,552

Rep: Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872
Did you try just right-click on desktop and then desktop parameters > screensaver to adjust settings ?
 
Old 07-18-2004, 09:29 AM   #9
kule
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 87

Original Poster
Rep: Reputation: 16
Well, there you can just adjust screensaver options, there are no options for turning the monitor off.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dpms not enabling... jkassemi Linux - Software 1 12-02-2005 06:30 PM
DPMS Question s4006576 Slackware 6 02-22-2005 02:00 PM
dpms / screen shuddering celejar Linux - Software 0 11-10-2004 10:54 PM
DPMS Not Working On My ProSavage ianeverett Linux - Hardware 1 09-20-2004 02:55 PM
Gnome keeps disabling dpms kidicarus Linux - Software 0 08-18-2004 03:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration