-   Slackware (
-   -   slack 10 +alsa (

kosmos 01-20-2005 01:04 PM

slack 10 +alsa
everything is ok xmms plays music mpg321 also , but when i launch quake1 i get : snddma_init failed /dev/dsp broken pipe.

jimdaworm 01-28-2005 01:40 PM

Just as no one else has answered yet, I will give it a wild stab in the dark :eek: is there somthing else using the device?? What window manager are you using? Have you tried using somthing really simple like fluxbox... to see if you get the same error??

kosmos 02-02-2005 01:18 PM

i'm using console and svgalib.

egag 02-02-2005 01:29 PM

do you have a /dev/dsp ?
( kernel 2.6.10 gives prob's on that )


paulicat 02-02-2005 02:21 PM

Another stab, are you part of the "audio" group?

jimdaworm 02-02-2005 02:42 PM



__J 02-02-2005 02:47 PM

low level library that accesses graphic hardware without X

(kosmos) see:

down toward the bottom

jimdaworm 02-02-2005 03:31 PM

Ok I could have guessed that! Thanks for the info

kosmos 02-03-2005 03:51 AM

yes i have /dev/dsp that points to /dev/dsp0 , i'm using kernel 2.4.29 also tryed 2.6.10 with same result, and yes i am part of the "audio" group.

About the links : i have oss emulation that comes with alsa , and also did likie said in ink you gave : echo "binary 0 0 direct".... , with no effects. Only think i managed to to was switching symbolic links , i made /dev/dsp to point /dev/adsp0 and that gave mi sound in quake3, quake1 still broken pipe.

I'm out of ideas now, googled for one week , but i know it CAN be done, once i put into modules.conf everything i found turned on oss emulation and than i had sound , nut my hd crashed and i din't recover my cfg files.

kosmos 02-04-2005 08:11 AM


Originally posted by jimdaworm
Whats ?
are you joking ?

jimdaworm 02-04-2005 07:33 PM

Actually I wasn´t. Should I have been?:confused:

All times are GMT -5. The time now is 12:42 PM.