-   Slackware (
-   -   Slack 10.1 K2.6.10 ALSA (

light_QQ 02-08-2005 07:36 PM

Slack 10.1 K2.6.10 ALSA
Hi there fellow Slackers.

I spent an entire night upgrading to Slack 10.1, and using the kernel 2.6.10 that came on the second CD (I did a make menuconfig on my old .config).

All seems to work ok, but I have some ALSA weirdness. First of all, ALSA Works! I can play Mp3's listen to sound...use alsamixer however ...

If I login as root, and do a 'startx' (with no .gn* / .gc* folders) - I get a OAFIDD:GNOME_MixerApplet error. Now if i login as 'light' my normal user (I did a home directory transplant so all my gnome settings were saved over) the volume control thing is there, but changing the volume has no effect and right click -> properties returns :

ERROR : Sorry, no mixer elements and or devices found


I've tried altering the permissions of /dev/dsp etc so I don't think its that. My Alsa support is all built into the kernel (so no modules at all). Alsaconf does not detect my soundcard for some reason ?


If I can just sort out this problem I'll be a happy bunny and will be able to continue configruing my machine, but this is really bugging me and I just can't seem to get to the route of it.

Light :confused:

ruidh 02-08-2005 09:36 PM

FWIW, I have the same problem with Slack 10.0 and kernel 2.6.7. Sound does work and I can adjust volume levels with alsamixer. The Gnome panel applet reports no mixer elements and/or devices found. But there does exist a /dev/mixer simlinked to /dev/sound/mixer. Permissions are appropriate so that the user should be able to set the volume. Indeed, I can set the volume with alsamixer.

killerbob 02-08-2005 11:34 PM

Forgive my ignorance, but was the 2.6.10 kernel on the 2nd CD a precompiled kernel, or was it a source that you compiled on your own? I'm running 10.1 with 2.6.10, but I took the 2.6.10 source off my fileserver and compiled it from scratch. I'm probably not running the same sound card as you are, but FWIW, it seems to be working fine for me. I compiled ALSA in the kernel, with sequencer support, and module support for OSS.

It sounds to me like the ALSA driver that's compiled into the 2.6.10 doesn't have the right mixer for your sound card. What card do you have? And do the volume mixers in other DE's/WM's work properly? (XFCE has its own volume mixer, as does KDE)

Have you tried removing the ALSA packages, and recompiling 1.0.8 from

light_QQ 02-09-2005 05:14 AM

The 2.6.10 kernel is actually a package on the 2nd CD (no idea why), but it seemed to build and run within /usr/src/linux-2.6.10/
I think this is a gnome problem, but I'm not sure.. I tried aux/amux? which is a different mixer and that worked fine. Alsamixer works fine, and XMMS / MP3's play fine. OSS support as modules.. why not inbuilt support - isn't that something that will be constantly used ?

Haven't tried recompiling alsa - though as far as I'm concerned this is a gnome problem...

killerbob 02-09-2005 10:24 AM

It might not be a gnome problem, is the thing. Just because alsamixer works doesn't mean you're going to have sound. You might have all channels muted in alsamixer, or you might have a bad driver in alsa. My desktop computer has an SB Live! 24-bit, and I'm too lazy to get sound working, because it's dualbooting in Windows and I use Win for gaming on the weekends. However, alsamixer claims it should be working properly. In my case, that's an alsa problem, even though alsamixer "works".

The only way to be certain that it's a gnome problem is to try a different mixer in a different DE. If gnome is running, it could mess up your results. GDM lets you choose which DE to use for this session, so you might want to set the default runlevel to 4 for this experiment.

As for OSS, theoretically you won't need it at all under most circumstances. My mother's computer was the only one I ever saw that actually required OSS support: her soundcard is a C-Media 8738. (As an aside, she didn't even notice that I had installed Linux/KDE, except to thank me for adding more games, and ask what I did to stop it from crashing....) When I compiled the 1.0.8 alsa driver, it gakked, telling me to enable OSS in the kernel.

light_QQ 02-09-2005 10:38 AM

What we were referring to was OSS compatibility, not OSS. People keep getting these confused. Alsa has some OSS back compatibility code which allows old OSS stuff to use new ALSA stuff.

As I said, alsamixer, mp3's aumix etc works perfectly.. I have no reason to think that my sound is at fault, clearly Gnome is not managing to access the mixer, despite the fact that 'alsamixer' can. I suppose I could try some different ALSA packages, or even compile it from source, but frankly it's a gnome 2.6 problem and I see many people have come up against this problem when upgrading to it.

Type in OAFIID:GNOME_Mixer-Applet in google

Thanks for the advice though, but I'm confident that the problem lies with gnome rather than alsa, as I've tried a separate mixer under gnome (aumix), alsamixer, mp3's run fine, aplay runs fine, Quake3 sound works .. everything ALSA works.. but GNOME_MIXER_APPLET does not work.. problem...

GNOME 2.6 -> Mixer APPLET...

I think...

light_QQ 02-09-2005 12:11 PM

Surely someone can suggest trying something ?

egag 02-09-2005 12:31 PM

well....the 2.6.10 kernel doesn't make all /dev-devices at startup.
maybe try to run " /etc/rc.d/rc.udev "; that will make all nodes ( here... )


Danus ex 02-09-2005 08:48 PM

You guys with problems haven't said what sound card you're running!

I spent a lot of time dealing with similar problems on my machine. I would uninstall all the ALSA packages and make my own, and still have trouble. I even had three different ALSA 1.0.8 driver packages installed at one point (generic 2.4.29, generic 2.6.10, compiled/checkinstalled package) in hope of getting some sound.

But, of course, I was being an idiot. I run an Audigy 2, and if you guys are, follow along. The real problem was something I spotted only in KMix. Under the 'Switches' tab, you'll see a switch marked 'Audigy Analog'. Turn it on for sound!

I also remembered in the Windows installation that the Audigy series defaults to digital output, and you have to specify analog in the setup.

ruidh 02-09-2005 11:11 PM


Originally posted by Danus ex
You guys with problems haven't said what sound card you're running!
I think you're misunderstanding the problem. We have sound. We can adjust the volume with alsamixer. We just can't adjust the volume with the Gnome volume control applet.

I may have to resort to stracing the applet executable to see what it's trying when it reports it can't find a /dev file.

light_QQ 02-10-2005 06:22 AM

Yes indeed.

This is a GNOME problem. I have tried XFCE (very nice btw - very simple and polished looking! - under slackware type xwmconfig to try it), then startx......

Mixer in XFCE works perfectly.

noxious 02-10-2005 09:19 AM

The gnome mixer, under a root login, is hosed. I've been deleting it and adding kmix to the menu bar in it's place - works great!

I just wish the display manager after a root login wasn't broken (still!).

light_QQ 02-10-2005 01:40 PM

To be honest, it's pathetic.

slipperynips 02-13-2005 11:59 AM

I am suffering the exact same issue. (When I log in as root ((root only))and startx I get the error message: OAFIID:GNOME_MixerApplet encountered a problem while loading.

Hardware: NForce 2 MB w/ onboard sound ((Biostar M7NCD))
SW: Slackware 10.1 Default Kernel

When I log on as another user all is well only root is hosed.

light_QQ 02-13-2005 05:36 PM

Well I definately recommend trying XFCE - I kina realised I didn't use a lot of the features in GNOME (and the features that were there seemed a bit bloaty, error prone and arbitary.. (like the menu system seems so crazy).

To do this simply logout of X, type :

Select XFCE

If you don't like it, repeat the process and re-select gnome.

TO me XFCE seems simple, nice and things seem really polished !

All times are GMT -5. The time now is 07:56 AM.