-   Slackware (
-   -   SLACK 10.0, ALSA and sound (

marekjs 08-07-2004 03:24 PM

SLACK 10.0, ALSA and sound
I use the motherboard SOLTEK SL-75DRV5, with VIA8233a.
I haven't problems with OSS drivers (via82cxxx_audio).It works perfectly :).But...ALSA, hmmm, strange: completly nothing, silence. Anyway it's a short history of my battle with ALSA:
- lsmod shows all modules
- alsamixer is unmuted and 100% for all
- IRQ 10, only for VIA8233a, no conflicts
- a silence on kernels 2.4.x or 2.6.7
- modprobe.conf with standard settings from alsaconf (via82xx on slot-0) for kernel 2.6.7
- modules.conf with standard rules from the web, for kernels 2.4.x (I remember about ./snddevices...)
- .asoundrc with hw:0,0 doesn't work (from ALSA web)
- hotplug is running
- silence on XMMS from ALSA (from OSS-no problems)
- I prepared missing devices into (similar devices like snddevices for kernels 2.4.x)
- when I close KDE, I have: "ALSA lib pcm_hw:549(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe"

That's all.
Any suggestions?

PS. I have the same problem on Mandrake, and Debian with new kernels. I remember, than It worked on Slack 8.0 on my pc.

Cedrik 08-07-2004 03:33 PM

Hello, I don't know if it may help, but each time I compile a new kernel I have to rm /etc/asound.state and redo alsaconf, alsamixer, alsactl store to get the sound back (card : SB live 5.1, kernel 2.6.7)

marekjs 08-07-2004 04:24 PM

to Cedrik...good advice, but....
Thx Cedrik for the advice, but it isn't working :)

Djony 09-24-2004 07:25 PM

I have the same motherboard and I had the same problem just like you. When I had a Suse 8.2 Pro I had to install some small via driver to get it working. When I compiled 2.6.x kernel on that distro, ALSA never worked, but OSS worked only when compiled in. It worked OK. And I've installed Slack 10 (just like you) and ALSA in'st working. On the other hand, when I compile OSS in kernel (old trick from older distros) I got very weak sound. I need to turn up my speakers to max just to hear a weak sound. I don't know what made OSS sound so weak. Practically, I am without sound, and nothing helps. If you find out something, please let me know by mail or private message. I'll do the same thing for you.

Good luck!

P.S. If your OSS modules are running OK, please let me know how you fixed the volume. Thanx!

marekjs 09-30-2004 03:42 PM

goog news...still running :)
I resolved this problem.
You must put to modprobe.conf line:
"options snd-via82xx ac97_quirk=0" and.... success :)

Djony 10-01-2004 05:50 PM


marekjs, WHAT CAN I SAY? I was trying to compile 2.6x kernels and ALSA since January, and failed every time. I don't really know where did you come up with this, but I am really grateful for your information! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU!

Where did you find this information?


marekjs 10-04-2004 11:17 AM

SLACK 10.0, ALSA and sound...resolved
Dr Djony.
:) From:

There is the post like:
Wouter Null
Monday, 15 March 2004

You can use the 'ac97_quirk'-option if your volume-level is very low (probably
due to some switching of the headphone and master controls). The options:
ac97_quirk - AC'97 workaround for strange hardware (-1 = default)
-1 = default, don't override
0 = disable
1 = use headphone control as master
2 = swap headphone and master controls
3 = for AD1985, turn on OMS bit and use headphone
and from forums :).

It runs everyday without problems.
I use latesr ALSA drivers 1.0.7rc1, the kernel and KDE 3.3

All times are GMT -5. The time now is 07:10 AM.