-   Slackware (
-   -   SL14: Not enough memory to load specified image (

funkynesh 11-22-2012 05:17 PM

SL14: Not enough memory to load specified image

I remember having this problem when installing slackware 13.0 and I vaguely remember having to specify the amount of ram when using the huge.s kernel. Anyone remember what was the parameter? I can't seem to find it in the threads also.

I have 4 gigs of ram.

Thank you.

funkynesh 11-22-2012 05:40 PM

OK found it I can pass the mem parameter.

boot: huge.s mem=3072

I get farther but now it freezes once it tries to decompress the kernel. The keyboard is unresponsive and I have to reboot the machine. Any ideas?

Darth Vader 11-22-2012 06:17 PM

If you have 4GB memory in your computer, I believe that you have also an enough modern processor to use the default kernel called hugesmp.s ...

Also, looks like you have an defective memory then I suggest you to do an memtest .

funkynesh 11-25-2012 10:17 PM

Thanks for the reply, however I failed to mention that I am trying to install the 64bits version of Slackware and there is only 2 kernels available: huge.s and speakup.s.

But I could try the 32bits version, it shouldn't make a difference for my usage.

The 32bits version gives me the same behaviour both kernels.

I am guessing there is an incompatibility with my hardware somewhere. Any way I can find out?

funkynesh 11-29-2012 04:23 PM

OK I managed to install on my existing /boot partition the kernel and the boot image of Slackware 14.0. I basically followed the instruction on this web site: but without copying the whole dvd.

cd /media/Slack14/usb-and-pxe-installers
mount -o loop usbboot.img /mnt/tmp
mkdir -p /boot/slacklive
cp /mnt/tmp/* /boot/slacklive
umount /mnt/tmp

Once I get that I edited my Lilo configuration to add the new boot option. I had to upgrade Lilo first to the Slack14 version because of some errors while writing the boot loader to disk.

The important part is to include the /boot/slacklive/initrd.img.

All times are GMT -5. The time now is 05:47 AM.