-   Slackware (
-   -   skype on slackware (

alexrait1 04-23-2005 09:36 AM

skype on slackware
I am trying to install skype on slackware. So I've downloaded the compressed archive file, but when I run ./skype I get this error:

bash-3.00$ ./skype
./skype: error while loading shared libraries: cannot open shared object file: No such file or directory

Where do I get a slackware package for libdbus? Or do I have it already?
I am using slackware current

masand 04-23-2005 10:45 AM

do have all the glibc and qt packages installed??

also here the link to the source for dbus



alexrait1 04-23-2005 11:08 AM

that's what I have:

bash-3.00$ cd /var/log/packages/
bash-3.00$ ls | grep glibc
bash-3.00$ ls | grep qt

I don't want to compile anything... is there an official slackware package for that... or at least from linuxpackages?
I can't find it there...

masand 04-23-2005 11:57 AM

i cannot find any package for slackware

maybe u need to install that from source

also how did u install skype??


jimdaworm 04-23-2005 09:37 PM

Did you download the static-binary?

Tino27 04-24-2005 08:54 PM

You will need to do two things ...

Download and install the D-Bus library from here ...

It's a fairly standard "./configure;make;make install" routine. Unfortunately, even with a successful install, you will need to do one additional step.

As root, do the following ...

ln -s /usr/local/lib/ /usr/lib/

Good luck. I'm using the new version of Skype at the moment, so it will work under Slack.

gotissues68 04-25-2005 12:45 PM

I was un-lazy and compiled a slackware compatible package for you


denning 05-02-2005 06:03 PM

How did you manage to compile dbus? I tried it and it keeps failing with:

Making all in tools
make[2]: Entering directory `/home/alvin/dbus-0.33/tools'
DBUS_TOP_BUILDDIR=.. ./ ./print-introspect org.freedesktop.DBus /org/freedesktop/DBus > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
escaped service dir is: ..\/test\/data\/valid-service-files
Created configuration file ./run-with-tmp-session-bus.conf
Running ../tools/dbus-launch --sh-syntax --config-file=./run-with-tmp-session-bus.conf
Started bus pid 25055 at unix:abstract=/tmp/dbus-OHeTUAUfGP,guid=70a3764230a3608da3ac1a1d26136300
Running ./print-introspect org.freedesktop.DBus /org/freedesktop/DBus
./ line 58: kill: (25055) - No such process
killing message bus 25055
./ line 11: kill: (25055) - No such process
./ Message bus vanished! should not have happened
make[2]: *** [dbus-bus-introspect.xml] Error 1
make[2]: Leaving directory `/home/alvin/dbus-0.33/tools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/alvin/dbus-0.33'
make: *** [all] Error 2

Tino27 05-02-2005 06:17 PM

I must have compiled version 0.32 instead of the current one 0.33. My last post was on 4-24-2005 which is the day before 0.33 was released on the D-Bus site. Try version 0.32 and see if this fixes your problem.

dkpw 05-02-2005 07:45 PM

Converting this RPM at the Skype For Linux Page...

"RPM for SuSE 9 and newer (5.7 MB) Version: Release date: April 22, 2005"

using rpm2tgz and then installing the resultant tgz with KPackager under KDE worked without issue on my Compaq running 10.1 Stable with the standard 2.4.29 kernel.



The_Outlander 05-02-2005 11:44 PM

Thanks, have skype up and running on slackware 10.1. Great job.

hellasyoda 12-19-2007 07:33 AM

hello. i am using slackware 12 and i have installed skype.i am using ./skype to run the application.How can i make it run with slackware startup?

General Failure 12-19-2007 08:26 AM

It should be enough to create a symlink to skype in ~/.kde/Autostart assuming you're using KDE.

dive 12-19-2007 01:44 PM

Well dbus is included with slack already.

Jesus people picking up old threads :confused:

hellasyoda 12-19-2007 04:34 PM


Originally Posted by General Failure (Post 2995704)
It should be enough to create a symlink to skype in ~/.kde/Autostart assuming you're using KDE.

It works:) tnx

All times are GMT -5. The time now is 10:16 AM.