LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-08-2014, 01:57 PM   #76
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Rep: Reputation: Disabled

pulseaudio -k

is just killling pulseaudio, if it is not set to respawn, the above command will not restart pulseaudio, just kill it.

either set it to respawn, or then followup with a

pulseaudio --start
 
Old 08-08-2014, 02:52 PM   #77
saxa
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 458

Rep: Reputation: 49
Quote:
Originally Posted by Ilgar View Post
You might be referring to zerouno's package:

http://www.z01.eu/repo-slack/slackwa.../4.1.0.20/src/
http://www.slacky.eu/asche64/pkgs/in...er=17&pkg=2111

Unfortunately it is not updated for 4.3, so it won't help now. I myself was wondering if one could modify it to include PulseAudio.
Yeah, I was referring exactly to that one, would be nice to have it updated.
 
Old 08-08-2014, 03:38 PM   #78
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware64 -current (started with 13.37(32))
Posts: 448

Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by Didier Spaier View Post
For those of use who run Slackware 32-bit (no multilib), assuming that sqg is a symlink to or an alias of /usr/doc/sbopkg-0.37.0/contrib/sqg:
Code:
sqg -p pulsauadio (choose Queuefile)
sbopkg -k -i pulseaudio (idem)
sqg -p pavucontrol
sbopkg -k -i pavucontrol
Not that much of a hassle, IMO.
Hello Didier, I did this manually, installed pulseaudio dependencies, then pulseaudio and Skype 4.3.
I installed pavucontrol too.

I did a test. Since I'm running Slackware current, I installed a 14.1 from scratch in another partition,
then installed all that pulseaudio stuff and skype 4.3. Same thing, skype just says "aborted" on terminal.

I thought "maybe it's a pulseaudio configuration problem" and did another test, downloaded a Lubuntu 14.04.1 cd iso,
burned and booted the live cd.
I installed skype 4.3 (with some dependencies auto-installed by lubuntu), and in a terminal skype said again "aborted"!!

It seems that there is a new hardware requirement with the new skype version.
My desktop is really old (A7n8x Sempron2800+ ATI9600) but was running skype 4.2 one week ago.
Are mic and webcam mandatory now? I don't have it.
 
Old 08-08-2014, 04:19 PM   #79
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,829

Rep: Reputation: Disabled
Sorry Paulo, no clue. Only thing that I can tell, you are not alone.
 
Old 08-08-2014, 04:47 PM   #80
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware64 -current (started with 13.37(32))
Posts: 448

Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by Didier Spaier View Post
Sorry Paulo, no clue. Only thing that I can tell, you are not alone.
Thanks for reply. For me those solutions don't work, I tested with new user.
For now I will use skype in a XP vm
 
Old 08-09-2014, 02:37 AM   #81
solarfields
Member
 
Registered: Feb 2006
Location: Outer Shpongolia
Distribution: Slackware
Posts: 969

Rep: Reputation: 537Reputation: 537Reputation: 537Reputation: 537Reputation: 537Reputation: 537
I upgraded my Skype. I am running a Slackware64 14.1 -multilib system. I have a virtual machine with Slackware 32, where I compiled the following from SBo:

speex
json-c
pulseaudio


I converted them to compat32 packages using convertpkg-compat32 on my host machine and installed them. Then I just compiled the above packages on the host as 64bit and installed them along with Skype.

The sound works.
 
1 members found this post helpful.
Old 08-09-2014, 07:19 AM   #82
Totoro-kun
Member
 
Registered: Nov 2010
Location: Kaunas, Lithuania
Distribution: Slackware
Posts: 209

Rep: Reputation: 93
How about mic? I have setup pulse audio this way I can hear skype sound as well as sound from other progams. However my mic does not work. It works in ALSA, but skype/pulse does not detect it.
 
Old 08-09-2014, 07:24 AM   #83
solarfields
Member
 
Registered: Feb 2006
Location: Outer Shpongolia
Distribution: Slackware
Posts: 969

Rep: Reputation: 537Reputation: 537Reputation: 537Reputation: 537Reputation: 537Reputation: 537
i did the skype test call, i could hear my voice back
 
Old 08-09-2014, 07:41 AM   #84
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,672
Blog Entries: 3

Rep: Reputation: 478Reputation: 478Reputation: 478Reputation: 478Reputation: 478
Quote:
Originally Posted by pataphysician View Post
pulseaudio -k

is just killling pulseaudio, if it is not set to respawn, the above command will not restart pulseaudio, just kill it.

either set it to respawn, or then followup with a

pulseaudio --start
default setting for pulseaudo is auto respawn so if the person has taken the time to learn what autorespawn is then I am sure
understanding pulseaudio -k means that. only a strange developer would want to use the -k a kill sign to restart it. LOL (M$ press start to stop OMG)
but there is a reason why respawn is there. because if you do not restart pulseaudio it will not reset and if it does not reset it will not reset
jackd you will see pulseadio 5 needs jackd to actually work. other wise your just using part of it.
pulseaudio is there to tell the program to ok you can start everything needed. then load the alsa modules.
here the thing Slackware runs things vanilla so if your going to install pulse audio then go the hole 9 yards. then learn the program.
Then learn how to manipulate the two soundservers. You can use both. if it is to hard then do like I did.
For my work computer I just use google voice in hangouts. you have multi cams etc and it works much better than skype.
Get a free google voice phone number set it to hangouts so if anyone calls it will ring your mobile phone home phone and you can answer in google hangouts.
Skype just is M$ and I closed my paid accounts.
That said my hobby is Slackware so I created some packages for this for multi-lib 14.0 and 14.1 . for people that just have to have skype like my wife.
 
Old 08-09-2014, 07:42 AM   #85
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,829

Rep: Reputation: Disabled
I could get the microphone working un-muting it in pavucontrol. Clicking on the Input devices tab, selecting the Microphone port then clicking on the Mute audio button to un-mute it did the trick. That's on a Lenovo Thinkpad T61 6457-4XG, with an external headset but no docking station. I could speak through Skype with my elder brother in Toronto without a hitch.

I didn't make any specific setting for pulseaudio.

PS Maybe Microsoft detected than I own a Windows 7 license, even though I now use it only in a VM in an external HDD to save space on disk

Last edited by Didier Spaier; 08-09-2014 at 07:52 AM.
 
Old 08-09-2014, 07:49 AM   #86
Totoro-kun
Member
 
Registered: Nov 2010
Location: Kaunas, Lithuania
Distribution: Slackware
Posts: 209

Rep: Reputation: 93
I've checked pavucontrol and Microphone was unmuted, however, muted and unmuted it again. No diference. I've tried setting dmix, dsnoop and default as alsa-source device in /etc/pulse/default.pa no difference. I am also using Slackware64 14.1 on ThinkPad T61 builtin mic. Also tried to unmute and rise internal mic volume in alsamixer, to the level I could hear high pitch echo noise. But still no record in skype 4.3 No idea what to try next.

Last edited by Totoro-kun; 08-09-2014 at 07:50 AM.
 
Old 08-09-2014, 08:02 AM   #87
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,672
Blog Entries: 3

Rep: Reputation: 478Reputation: 478Reputation: 478Reputation: 478Reputation: 478
Hey Totoro-kun you want Pulse to use alsa default device then aplay -l the edit your /etc/pulse/default.pa to the device you want.
Quote:
load-module module-alsa-sink device=dmix
load-module module-alsa-source device=dsnoop
or tell it to use your default card

Quote:
load-module module-alsa-sink device=dmix
load-module module-alsa-source device=hw:0,0
I am not sure what all you installed so not sure.
if you are using a local ~/.asoundrc then
Quote:
load-module module-alsa-sink device=dmix
load-module module-alsa-source device=default

Last edited by Drakeo; 08-09-2014 at 08:05 AM.
 
Old 08-09-2014, 08:07 AM   #88
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,829

Rep: Reputation: Disabled
Quote:
Originally Posted by Totoro-kun View Post
I've checked pavucontrol and Microphone was unmuted, however, muted and unmuted it again. No diference. I've tried setting dmix, dsnoop and default as alsa-source device in /etc/pulse/default.pa no difference. I am also using Slackware64 14.1 on ThinkPad T61 builtin mic. Also tried to unmute and rise internal mic volume in alsamixer, to the level I could hear high pitch echo noise. But still no record in skype 4.3 No idea what to try next.
If you made specific settings, I'd suggest that you remove all configuration files in ~, remove and reinstall pulseaudio and Skype, then open Skype, click on the menu:
Skype => Options => Sound Devices => Open PulseAudio Volume Control => Input Devices
There's no guarantee but it worked for me ™

Last edited by Didier Spaier; 08-09-2014 at 08:09 AM.
 
Old 08-09-2014, 08:18 AM   #89
Totoro-kun
Member
 
Registered: Nov 2010
Location: Kaunas, Lithuania
Distribution: Slackware
Posts: 209

Rep: Reputation: 93
Ok, lets try from the start.
I am using PulseAudio 5.0 from SBo (pulseaudio-5.0-x86_64-1_SBo and pulseaudio-compat32-5.0-x86_64-1_SBocompat32) and Skype 4.3.0.37 On Slackware64 14.1 multilib

I went with un-intrusive setup, configured like Here

Issue: no Mic input (no matter if I use built in Mic or external Microfone connected to mic jack)

My outputs:
Code:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Code:
$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default:CARD=Intel
    HDA Intel, AD198x Analog
    Default Audio Device
sysdefault:CARD=Intel
    HDA Intel, AD198x Analog
    Default Audio Device
front:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    Front speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, AD198x Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
    HDA Intel, AD198x Digital
    IEC958 (S/PDIF) Digital Audio Output
And currently from Pulse:
Code:
$ pacmd list-sources
2 source(s) available.
  * index: 0
	name: <alsa_input.hw_0_0>
	driver: <module-alsa-source.c>
	flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: IDLE
	suspend cause: 
	priority: 9950
	volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
	        balance 0,00
	base volume: 65536 / 100% / 0,00 dB
	volume steps: 65537
	muted: no
	current latency: 0,11 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 1837,50 ms; range is 16,00 .. 1837,50 ms
	module: 0
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "AD198x Analog"
		alsa.id = "AD198x Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel"
		alsa.long_card_name = "HDA Intel at 0xfe020000 irq 48"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.name = "82801H (ICH8 Family) HD Audio Controller"
		device.form_factor = "internal"
		device.string = "hw:0,0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.description = "Built-in Audio"
		device.icon_name = "audio-input-microphone-pci"
    index: 1
	name: <alsa_output.default.monitor>
	driver: <module-alsa-sink.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: IDLE
	suspend cause: 
	priority: 1000
	volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
	        balance 0,00
	base volume: 65536 / 100% / 0,00 dB
	volume steps: 65537
	muted: no
	current latency: 0,00 ms
	max rewind: 128 KiB
	sample spec: s32le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 341,33 ms; range is 2,00 .. 341,33 ms
	monitor_of: 0
	module: 1
	properties:
		device.description = "Monitor of Built-in Audio"
		device.class = "monitor"
		device.icon_name = "audio-input-microphone"
Ive tried dmix, default, dsnoop and hw:0,0 devices as alsa-input and alsa-source in all cases - I can hear skype sound, but no Mic. I have yet to try on another computer. Hopefully, someone will have hints, because I've googled all I can for now

Last edited by Totoro-kun; 08-09-2014 at 08:20 AM.
 
2 members found this post helpful.
Old 08-09-2014, 08:25 AM   #90
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,829

Rep: Reputation: Disabled
@Totoro-kun: why do you insist to use Alsa instead of PulseAudio "out of the box"? IMHO that complicates things uselessly.

I can hardly see what benefit you get of a so-called "un-intrusive" set up, at least on a laptop. But maybe something escapes me? I'm still eager to learn...

Last edited by Didier Spaier; 08-09-2014 at 08:30 AM.
 
  


Reply

Tags
pulse audio, skype, skype slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Interruptions during Skype to Skype audio calls glupa4e Slackware 6 05-22-2013 02:46 PM
skype: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by skype Xeratul Debian 6 11-24-2012 02:12 AM
latest skype Skype 2.2.0.25 and Slackware --current anti_user Slackware 10 04-07-2011 02:22 PM
qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586 (From Installation of SKYPE)RHEL miaomiaoga Linux - Software 8 08-28-2010 07:15 AM
noise in skype to skype calls in skype v2.1 beta for fedora mq15 Linux - Software 0 01-20-2010 12:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration