LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-15-2014, 08:02 AM   #286
fsLeg
Member
 
Registered: Dec 2013
Location: Russia, Moscow
Distribution: Slackware, Debian
Posts: 88

Rep: Reputation: Disabled

Quote:
Originally Posted by brebs View Post
An ALSA config which uses dmix (and dsnoop) would be better, for sharing the sound with multiple apps
In my experience using explicit dmix via asoundrc makes sound system choke at peak system loads. It's much better to use implicit mixing which alsa already supports. This is my .asoundrc, which makes my analog sound output the default one:

Code:
defaults.ctl.card 1;
defaults.pcm.card 1;
All sounds from different apps are mixed properly, performance is much better than using `type dmix`. I'd suggest looking at /usr/share/alsa/alsa.conf, it has a lot of interesting things.
 
1 members found this post helpful.
Old 11-24-2014, 08:26 PM   #287
coldbeer
Member
 
Registered: May 2006
Location: Orion–Cygnus Arm, MWG
Distribution: Slackware, Ubuntu
Posts: 249

Rep: Reputation: 130Reputation: 130
Just documenting.

I originally downloaded Drako's skype bundle with pulseaudio and installed with his install script. It worked.

But later I installed studioware (www.studioware.org) and skype stopped working (no mic). I couldn't figure out how to fix it so I uninstalled all of studioware and uninstalled all the pulse audio packages.

I decided to try the apulse solution:

Compiling apulse after extraction:
bash-4.2$ mkdir build && cd build
bash-4.2$ CFLAGS=-m32 cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
bash-4.2$ make
bash-4.2$ sudo make install

Both my playback and capture are on hw:0,0
$ arecord -f cd -D hw:0,0 >test.wav
$ aplay -D hw:0,0 test.wav
Works!

I tried the following but kept getting errors:

bash-4.2$ APULSE_CAPTURE_DEVICE="hw:0,0" APULSE_PLAYBACK_DEVICE="hw:0,0" apulse skype &
[apulse] [error] do_connect_pcm, snd_pcm_hw_params_set_channels, Invalid argument

The solution for me was to put this in .asoundrc in my ~/ directory

Code:
pcm.!default {
         type asym
         playback.pcm {
                 type plug
                 slave.pcm "hw:0,0"
         }
         capture.pcm {
                 type plug
                 slave.pcm "hw:0,0"
         } 
}
Run with:
$ apulse skype

And it works! And no extra pulse audio packages.

P.S. And now I've re-installed all the studioware.org packages and everything still works.

Last edited by coldbeer; 12-04-2014 at 10:44 PM.
 
1 members found this post helpful.
Old 12-02-2014, 08:12 AM   #288
brebs
Member
 
Registered: May 2013
Posts: 88

Rep: Reputation: Disabled
Quote:
Originally Posted by fsLeg View Post
makes sound system choke at peak system loads
That's probably 44.1khz vs 48 remixing. With buffers set too low - which using an explicit config will remedy, ahem.

Quote:
Originally Posted by fsLeg View Post
implicit mixing
But then you're at the mercy of the sound parameters that the *first* app chooses, to open the soundcard with. As I've mentioned previously.

Also, the built-in dmix only doesn't support more than 2 speakers
 
Old 12-02-2014, 11:49 AM   #289
yars
Member
 
Registered: Apr 2012
Location: Russia
Distribution: Slackware64-current
Posts: 248

Rep: Reputation: 24
I have slackbuild for apulse (including the instruction how to install it; warning, it is link to russian slackware forum). This slackbuild was written when apulse does not ships the pulseaudio headers, for so, you don't need pulseaudio to build apulse).
Also, IMO, you don't need to have a asound.conf or ~/.asoundrc modification, if you have a single soundcard.

Last edited by yars; 12-02-2014 at 12:34 PM. Reason: Removed unneeded "/url" tag, and addition.
 
Old 12-03-2014, 12:05 PM   #290
fsLeg
Member
 
Registered: Dec 2013
Location: Russia, Moscow
Distribution: Slackware, Debian
Posts: 88

Rep: Reputation: Disabled
yars, apulse is already at SBo. Also, my SlackBuild of Skype has an option to use apulse, which IMHO is more appropriate given the apulse project's main goal.

Last edited by fsLeg; 12-03-2014 at 12:06 PM. Reason: typo
 
1 members found this post helpful.
Old 12-04-2014, 02:04 PM   #291
schmatzler
Member
 
Registered: Jan 2011
Location: Germany
Distribution: Slackware64 -current + Multilib
Posts: 405

Rep: Reputation: 178Reputation: 178
Some news at the Skype front. Microsoft has released "Skype for Web", a browser frontend that allows us to log in to the Skype network without the actual client.

Eion Robb is working on that end to create a standalone plugin for Pidgin. I made a SlackBuild for that. It's not yet ready - if you write to a contact it may get deleted from your contact list and all other kinds of weird things can occur.

However, if you want to test it, look here: http://schmatzler.de/my_slackbuilds/skype4pidgin/

Eions Blog Post: http://eion.robbmob.com/blog/2014/11...skype-for-web/
 
Old 12-08-2014, 06:35 PM   #292
Crew-L-T
LQ Newbie
 
Registered: Feb 2012
Distribution: Slackware
Posts: 4

Rep: Reputation: 0
Lightbulb No need Pulse Audio to get sound

I've had the same problem with skype. Then I did a quick search, and found "apulse" on slackbuilds. apulse is a compatibility layer between Pulse Audio and ALSA. Compiled it, installed it and I had sound again. Hope this helps.
 
Old 12-09-2014, 02:19 PM   #293
schmatzler
Member
 
Registered: Jan 2011
Location: Germany
Distribution: Slackware64 -current + Multilib
Posts: 405

Rep: Reputation: 178Reputation: 178
The "Skype Web" plugin from Eion finally works stable for me. It was segfaulting very often - we traced it down to some of my contacts having weird characters (<,",') in their status messages.

Pidgin can escape these characters with a different parser. A quick and dirty fix. I updated my SlackBuild and I am officially ditching the damn client now. I don't make calls with Skype anyway :-)
 
Old 12-18-2014, 06:03 PM   #294
a.key
LQ Newbie
 
Registered: Mar 2010
Posts: 2

Rep: Reputation: 0
It maybe useful or at least a little bit time saver to anyone wanting to use apulse which works pretty well by the way that if you have slackware64 you have to compile it for 32bit since skype doesn't bother building native 64bit binaries.
slackbuilds have a little bit of documentation on how to compile it for 32bit arch, if you are using sbopkg program it's as simple as:
COMPAT32=yes sudo -i /usr/sbin/sbopkg -i apulse
 
Old 12-31-2014, 07:59 AM   #295
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,475

Rep: Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068Reputation: 2068
I would like to thank all the contributors to this thread. With your help I now appear to have a working Skype on my Slackware64-current setup.
First, I cheated and installed the package skype_static-4.3.0.37-x86_64-3sl.txz that includes apulse from zerouno at post#251. I have to change the symlink '/lib/ld-linux.so.2 -> /lib/ld-2.20.so' to '/lib/ld-linux.so.2 -> /usr/share/skype/lib32/ld-2.17.so' for this package to work for me. (Maybe I should do a rebuild?)

I then followed the instructions under the heading "Skype with a grain of salt" in the README.SLACKWARE linked by Didier Spaier in post#268. I needed to add a line '#includedir /etc/sudoers.d/' using visudo to /etc/sudoers to complete this and also remember to logout and login for the new settings to take effect.

I am using a webcam with an inbuilt microphone, which appears as a second sound card in alsamixer. To get the microphone to work I added a ~/.asoundrc file slightly modified from the one posted by coldbeer at post#287 for the dedicated skype user with the contents
Code:
pcm.!default {
         type asym
         playback.pcm {
                 type plug
                 slave.pcm "hw:0,0"
         }
         capture.pcm {
                 type plug
                 slave.pcm "hw:1,0"
         } 
}
Now, 'xhost +local: && sudo -u skype /usr/bin/skype' starts skype.

Last edited by allend; 12-31-2014 at 08:04 AM.
 
Old 04-19-2015, 08:16 PM   #296
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,982

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Skype is by far the most annoying thing I have ever had to install and deal with. While skype 4.2 was doable, skype 4.3 seems to be close to impossible. I've tried most things in this thread (slackbuilds, static, etc), but never managed to install it with working audio. I ended up dual-booting Mint just for Skype. This is NOT something I would normally do, but pressure from people at my job has forced me to Eventually, I'll be able to afford a smartphone and maybe then I won't ever have to deal with it again on my computers.

Hello Firefox is a great alternative tho and maybe more people will adopt it. I'll certainly try to get people to try it out.

Last edited by metaschima; 04-19-2015 at 08:18 PM.
 
Old 04-19-2015, 08:23 PM   #297
drlukacs
Member
 
Registered: Oct 2012
Location: Halifax, NS, Canada
Distribution: Slackware
Posts: 34

Rep: Reputation: 4
Quote:
Originally Posted by metaschima View Post
Skype is by far the most annoying thing I have ever had to install and deal with. While skype 4.2 was doable, skype 4.3 seems to be close to impossible. I've tried most things in this thread (slackbuilds, static, etc), but never managed to install it with working audio. I ended up dual-booting Mint just for Skype. This is NOT something I would normally do, but pressure from people at my job has forced me to Eventually, I'll be able to afford a smartphone and maybe then I won't ever have to deal with it again on my computers.

Hello Firefox is a great alternative tho and maybe more people will adopt it. I'll certainly try to get people to try it out.
Did you try what is suggested in this thread?

Getting Skype 4.3 did cost me a lot of time, but since then it has been working OK. If you could tell me more about your system (distribution, version, 32-bit or 64-bit, etc.), I might be able to help you.
 
Old 04-19-2015, 08:59 PM   #298
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,982

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
I was trying to install it on Slackware 14.0, but it's gone now, I'll try again with the next slackware version when it comes out (which may be soon). Part of it was me being lazy and not upgrading to Slackware 14.1, where the chances of it working are higher.
 
Old 04-19-2015, 09:02 PM   #299
drlukacs
Member
 
Registered: Oct 2012
Location: Halifax, NS, Canada
Distribution: Slackware
Posts: 34

Rep: Reputation: 4
Quote:
Originally Posted by metaschima View Post
I was trying to install it on Slackware 14.0, but it's gone now, I'll try again with the next slackware version when it comes out (which may be soon). Part of it was me being lazy and not upgrading to Slackware 14.1, where the chances of it working are higher.
I managed to get it working on Slackware64 13.37, so I do not think that the version should really be an issue.

Are you working with the 32-bit or the 64-bit version of Slackware?
 
Old 04-19-2015, 10:22 PM   #300
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,982

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
It was 64-bit, but I can't diagnose it anymore, I already installed Mint over it and will install next version Slackware when it comes out.

I mean I installed Alien Bob's multilib, I tried the various skype slackbuilds (in this thread and slackbuilds.org) and the static package and various asoundrc, but nothing made the audio work. Probably, more time spent on it may have finally fixed it, but I draw the line at around 5 hours spent trying to make it work. Installing Mint took less time, so I took the easy way out, but I don't like pulseaudio or skype, so I expect that buying a smartphone will no longer require me to keep Mint around.
 
  


Reply

Tags
pulse audio, skype, skype slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Interruptions during Skype to Skype audio calls glupa4e Slackware 6 05-22-2013 03:46 PM
skype: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by skype Xeratul Debian 6 11-24-2012 03:12 AM
latest skype Skype 2.2.0.25 and Slackware --current anti_user Slackware 10 04-07-2011 03:22 PM
qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586 (From Installation of SKYPE)RHEL miaomiaoga Linux - Software 8 08-28-2010 08:15 AM
noise in skype to skype calls in skype v2.1 beta for fedora mq15 Linux - Software 0 01-20-2010 01:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration