LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Skype 4.3 (https://www.linuxquestions.org/questions/slackware-14/skype-4-3-a-4175508618/)

shoshia 08-27-2014 02:02 PM

Quote:

Originally Posted by Drakeo (Post 5214248)
here is a fresh build for skype 4.3 Slackware64 14.1 and option to install 32comapt dependencies you need Alien Bobs multi lib installed first. I had a few people request it. it has the install script that will add all your groups and users. you may enable the alsa plugins or not I have them installed and it works great for me. And still using dmix. I only use it for skype.

well from my install I am using them with the plugins and I am able to control everything
that does not require pulseaudo with kmix. The skype after grabbing the mic from my webcam.
I have 4 mics two analog usb digital and a webcam mic. Skype grabbed my webcam.
this allows me to still use skype and broadcast with Mixxx. i had no issues been testing it
with multiple multimedia programs running.

Hi I have installed from link above...
had few problems:
needed libffi compack32 /I use ajuta and compiled installed 64 bit, but ssystem was giving messege that can not load 32 bit librares. Also skype on startup
was sayng 'can not find libffi.so.'...so recompiled it and installed as compack32.

skype starts.

Here are 2 problems
1.
when i start it as user it gives error:
Code:

Failed to create secure directory (/tmp/xdg-shoshia/pulse): Permission denied
after su error is gone but caan it be fixed?
maybe i need to add user to pulse group?

2.
hav not tryed video call but laptop webcam is detected.

but there is no sound /sound works on system mplayer plays files fine/
in skype config i see "virtual devise" for sound

any help?
:)

shoshia 08-27-2014 06:11 PM

now pulseaudio is running...(een i chmod rc.pulseaudio)
pavcontrols says no connection..

then i start pulse audio it on console/before X/ as
pulseaudio --system
and than startx
now pavcontrols connects but onlu pulseaudio server is in options.
and still no sound withh skype

p.s.
i noticed on startup :
i got gdk2 updatemodules segfaults/32 bit/ what i need to reinstall?

i was installing some other gtk progs..mabe broke some dependencies?

will try everything on fresh install

audriusk 08-28-2014 02:48 AM

I successfully set up Skype 4.3 on freshly installed Slackware-14.1 (32 bit) a couple of weeks ago. Here's what I did:
  • Installed only PulseAudio and its required dependencies, didn't bother with pavucontrol.
  • Set up PulseAudio as a minimal unintrusive dumb pipe to ALSA (thanks to Totoro-kun for the link).
  • Installed Skype (obviously).
  • What tripped me up at first was disabled capture device (due to fresh Slackware install). In alsamixer I needed to switch to capture view (press F4) and enable it by pressing space key. When it's disabled, there's a line of dashes below the volume bar, after pressing space it should change to word 'CAPTURE'. After that set the volume level so that the microphone would pick up sound. I also unmuted (by pressing M key) mic in playback view (F3). These settings will vary depending on the system, so my instructions should be treated as guidelines.
After these steps Skype calls were functioning properly.

shoshia 08-28-2014 03:06 AM

yes on 32bit system it works..
i think have messed with compat32 packages..
....
I see error in log
"can not load module-native-protocol-unix adress in use"

do fresh install and will report results :)

shoshia 08-28-2014 04:46 AM

3 Attachment(s)
yeps it works.. i did not reinstalled.

this is my setup if someone needs/del inspiron laptop/:
1. slack64 14.1
2. alien bobs multilib
3. install this http://www.mediafire.com/download/yk...1-build.tar.gz
4. make sure alsa is working/before i had disabled /etc/rc.alsa but video/soundplayers adobeflash were still working ..strange magick :) /
5. this is system.pa file :
Code:

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev/hal support)
load-module module-detect
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Automatically restore the volume of streams and devices
load-module module-stream-restore
load-module module-device-restore

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### Enable positioned event sounds
load-module module-position-event-sounds

other configs are in attachment

this setup worked for me...

thank to all for a great work :)

shoshia 08-28-2014 04:53 AM

but there still is a problem...i hear sound but microphone/recording does not work... :(
but this is not skype and pulseaudio related in my case

p.s.
this is also fixed...I had enabled 'CAPTURE' in alsamixer but it did not worked...
but then i enabled capture with k mix it magically worked/of course wm does not matter after this/
but why i need to enable capture with kmix? if i dnt have kde installed then?......

p.s.s.
yes no need to run /etc/rc.pulseaudio what i was writing in previous post... pulse setups run pulse audiio on demand as i guess,
which itself calls/uses alsa

Bindestreck 08-28-2014 09:08 AM

Still not working, this is what I get:

Quote:

bash-4.2$ pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

bash-4.2# /etc/rc.d/rc.pulseaudio start
E: [pulseaudio] core-util.c: Failed to create secure directory (/var/lib/pulse/.config/pulse): No such file or directory
Starting pulseaudio...
W: [pulseaudio] authkey.c: Failed to open cookie file '/var/lib/pulse/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/pulse/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to open cookie file '/var/lib/pulse/.pulse-cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/pulse/.pulse-cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to open cookie file '/var/lib/pulse/.config/pulse/cookie': No such file or directory
W: [pulseaudio] authkey.c: Failed to load authorization key '/var/lib/pulse/.config/pulse/cookie': No such file or directory
No protocol specified
E: [pulseaudio] client-conf-x11.c: xcb_connection_has_error() returned true
E: [autospawn] core-util.c: Failed to create secure directory (/var/lib/pulse/.config/pulse): No such file or directory
W: [autospawn] lock-autospawn.c: Cannot access autospawn lock.
E: [pulseaudio] main.c: Failed to acquire autospawn lock



Hmm, no such file o directory...

shoshia 08-28-2014 09:16 AM

Quote:

Originally Posted by Bindestreck (Post 5228687)
Still not working, this is what I get:
bash-4.2$ pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.


Should I make an asoundrc?

you dont need run it 'by hand'
try pavucontrol if it conects to pulseaudio and check sounddevises using kde if pulseaudio is listed and test it

p.s.
I messed again something..libffi..reinstalled from slack package 64 bit and from multilib...no i get skype segfoult :( ...pulseaudio
is running it is listed on kde sound devises and sounds :) ...

has someone encountered skype segfault

Bindestreck 08-28-2014 09:22 AM

How do you guys make pulseaudio work so smoothly? Pulseuadio is just a mess for me, nothing works. I added myself to group "pulse" and also added the user 216 as proposed in the README-file in SBo for pulseaudio.

Is there something I missed?

audriusk 08-28-2014 09:40 AM

Quote:

Originally Posted by Bindestreck (Post 5228698)
How do you guys make pulseaudio work so smoothly? Pulseuadio is just a mess for me, nothing works. I added myself to group "pulse" and also added the user 216 as proposed in the README-file in SBo for pulseaudio.

Is there something I missed?

Well, I already wrote what worked for me, but it's just one of many possible configurations. And it wasn't that smooth, it took me some time to figure out that I needed to enable capture device, while I was looking for problems in PulseAudio setup.

In my case PulseAudio only starts when Skype is started and exits when Skype is closed. No need to run any daemons or add user to any groups. PulseAudio acts as a pipe to ALSA and doesn't get in my way.

Bindestreck 08-28-2014 11:02 AM

Quote:

Originally Posted by audriusk (Post 5228704)
Well, I already wrote what worked for me, but it's just one of many possible configurations. And it wasn't that smooth, it took me some time to figure out that I needed to enable capture device, while I was looking for problems in PulseAudio setup.

In my case PulseAudio only starts when Skype is started and exits when Skype is closed. No need to run any daemons or add user to any groups. PulseAudio acts as a pipe to ALSA and doesn't get in my way.

How did you install pulseaudio? If using SBo it requires pulse as group (http://slackbuilds.org/repository/14...io/pulseaudio/). Did you change the SlackBuild or did you install pulseaudio manually?

shoshia 08-28-2014 11:25 AM

1 Attachment(s)
this thing drives me crazy :)
now everything works again...
as i posted i messed with libffi/was trying to compile anjuta and its dependences/
so i started checking everything for skype again...install reinstall and so on..
so basicly what i posted on top of this page works..
and after several times of reboot i found that skype segfaults and no way to get it work.
and desided just change xfce4 WM to kde to check pulseaudio...
and magick happened...
I see skype screen "Agree terms and conditions"..and it is working...
i dont know why...maybe some gnome gtk libs are broken and if fails to start with xfce4?

so Resume:
no need to run pulseaudio as daemon

link of package on top of page is working package for 14.1 64 bit. /chmod installme.sh . dont install .txz files by hand..
this script does great work..thanks to package author/

than if doesnot work out of box try config files of pulseaudio i have posted.

to avoid some misunderstandings choose kde as WM ..than you can change it back after skype will be working

Bindestreck

check this http://www.mediafire.com/download/yk...1-build.tar.gz Drakeo's package + multilib and config files i have posted...this way works..at least for me ..

p.s.
skype still segfaults with XFCE4,but for fluxbox, KDE, enlightement it works fine....dont know why? and really dont care as it works :)

Bindestreck 08-28-2014 11:40 AM

Quote:

Originally Posted by shoshia (Post 5228770)
this thing drives me crazy :)
now everything works again...
as i posted i messed with libffi/was trying to compile anjuta and its dependences/
so i started checking everything for skype again...install reinstall and so on..
so basicly what i posted on top of this page works..
and after several times of reboot i found that skype segfaults and no way to get it work.
and desided just change xfce4 WM to kde to check pulseaudio...
and magick happened...
I see skype screen "Agree terms and conditions"..and it is working...
i dont know why...maybe some gnome gtk libs are broken and if fails to start with xfce4?

so Resume:
no need to run pulseaudio as daemon

link of package on top of page is working package for 14.1 64 bit. /chmod installme.sh . dont install .txz files by hand..
this script does great work..thanks to package author/

than if doesnot work out of box try config files of pulseaudio i have posted.

to avoid some misunderstandings choose kde as WM ..than you can change it back after skype will be working

Bindestreck

check this http://www.mediafire.com/download/yk...1-build.tar.gz Drakeo's package + multilib and config files i have posted...this way works..at least for me ..

p.s.
skype still segfaults with XFCE4,but for fluxbox, KDE, enlightement it works fine....dont know why? and really dont care as it works :)

Ah, ok, I will try that package! Thanks!

shoshia 08-28-2014 01:02 PM

dont forget to turn on "CAPTURE" using alsamixer/and if it does not help/ using kmix

audriusk 08-28-2014 01:25 PM

Quote:

Originally Posted by Bindestreck (Post 5228759)
How did you install pulseaudio? If using SBo it requires pulse as group (http://slackbuilds.org/repository/14...io/pulseaudio/). Did you change the SlackBuild or did you install pulseaudio manually?

Yes, the script requires the group to exist, but there's no need for your user to belong to it. pulse group (and user) is there in case you want to run PulseAudio all the time as a daemon (started by rc script). I configured PulseAudio to be started on demand, when some application needs it. This way it is run with the same privileges as the application itself.


All times are GMT -5. The time now is 06:10 AM.