-   Slackware (
-   -   skype 4.1 package for x86_64 available (

zerouno 11-16-2012 06:14 AM

skype 4.1 package for x86_64 available
The new package of skype for x86_64 is now available on my repository.

As previous versions, the package is called "static".
Despite its name this version does not use the 'static' tarball from (that is not available at moment) but the 'dynamic' tarball.
The package remain called "static" becouse it include all 32bit libraries needed, so it works without install 32bit compatibility libraries (for who want to leave slackware64 clean).

The new skype version allow to integrate MSN contacts as skype 6.0 for windows. (Microsoft want to drop itself :))

I like feedback (specially for videocall and msn integration).

chrisretusn 11-16-2012 06:55 AM

Thanks. Installed and working A-OK.

mrclisdue 11-16-2012 08:36 AM


kenjiro 11-16-2012 11:29 AM

Downloaded, installed, I run skype, it asks for my user and pass. It logs in... but nothing shows up. The whole GUI desappears. Any tips on how to solve this?

Oh, and I guess it didn't stoped/crashed because I can see it with "ps aux" and I even get sound notifications if someone messages me.

By the way, I am using KDE-4.9.3 (from alienBob)

kenjiro 11-16-2012 12:01 PM

OK, I solved it myself. Looks like having the preferences and stuff from earlier versions was problematic. I removed the "~/.Sype" folder, then ran skype again. This time it worked as intended.

Iuz 11-16-2012 02:45 PM

./skype: line 12: /usr/share/skype/lib32/ No such file or directory

What am I missing ?

edit: thank you by the way..

zerouno 11-16-2012 04:02 PM

@kenjiro: thanks for tip ;)

@luz: have you modified /usr/bin/skype in any part?
the md5 is
2bbed3bd631f31e6cf27859db599e10d /usr/bin/skype

also give me
$ ls -lL /usr/share/skype/lib32/
try to run manually:
$ /usr/share/skype/lib32/ --library-path /usr/share/skype/lib32/ /usr/share/skype/skype
This in not sufficient to load all libraries but useful for troubleshooting

If this unsolve, give me the output of
/usr/share/skype/lib32/ --library-path /usr/share/skype/lib32/ --list /usr/share/skype/skype

Iuz 11-16-2012 05:06 PM

theres nothing on /usr/share/skype/lib32, it says nothing is found

ls -la /usr/share/skype/lib32/
total 8
drwxr-xr-x 2 root root 4096 Nov 17 18:39 .
drwxr-xr-x 6 root root 4096 Nov 17 18:39 ..

zerouno 11-16-2012 05:49 PM

you have a problem :D

Try to uninstall and reinstall the package

bgeer 11-16-2012 06:45 PM

Thank you, zerouno, for easy skype package for slack64.

tramni1980 11-17-2012 02:37 AM

Many thanks, skype is up and running!

mlpa 11-17-2012 07:46 AM

With a skype account it worked perfectly.
But with a msn account it did not connect.

Nevertheless many thanks :)

Alien Bob 11-17-2012 10:04 AM

I was able to merge my Skype and MSN accounts by logging into Skype with my MSN credentials. You'll be asked to login with your Skype credentials after that and then get a chance to merge the two accounts, so that the MSN credentials will be your Skype login credentials afterward.

I was not able to see my MSN contacts in Skype nevertheless...

For the record: if you do run a multilib 64-bit Slackware 14.0 or current, installing my latest set of multilib packages is enough to get Skype up and running, without the need for zerouno's package of bundled 32-bit library files. I just synced my 14.0 multilib repository with the missing sqlite package.

I used a slightly modified skype.SlackBuild, originally from SBo:

--- /var/lib/sbopkg/SBo/14.0/network/skype/skype.SlackBuild    2012-09-29 06:34:32.000000000 +0200
+++ /var/lib/sbopkg/SBo/14.0/network/skype/skype.SlackBuild.sbopkg      2012-11-17 16:32:38.470586967 +0100
@@ -23,7 +23,7 @@
@@ -78,9 +78,15 @@
 mkdir -p $PKG/usr/{bin,share/{skype,pixmaps,applications}} $PKG/etc/dbus-1/system.d
 cp -a skype $PKG/usr/bin
 cp -a avatars lang sounds $PKG/usr/share/skype
+cat skype.conf > $PKG/etc/dbus-1/system.d/skype.conf
+# Desktop menu and icons:
 cat skype.desktop > $PKG/usr/share/applications/skype.desktop
 cat icons/SkypeBlue_48x48.png > $PKG/usr/share/pixmaps/skype.png
-cat skype.conf > $PKG/etc/dbus-1/system.d/skype.conf
+for size in 16 32 48 ; do
+  mkdir -p  $PKG/usr/share/icons/hicolor/${size}x${size}/apps
+  cp -a icons/SkypeBlue*${size}*.png $PKG/usr/share/icons/hicolor/${size}x${size}/apps/skype.png
 # If we strip it, it segfaults, so lets disable this for now.
 #find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \


zerouno 11-17-2012 10:32 AM

Yes, for who uses the multilib your package is the best ;). Thanks for your big works.

But I known some people that want to use the clean slackware64, and the only 32bit package used is skype.

However the problem with login on msn (in my package) is for the libssl that I forgot to upgrade from 0.x to 1.x

I'd just uploaded the correct package.

why you have removed system.d/skype.conf ? is not needed now? (ehm, I do not know very well dbus)

Alien Bob 11-17-2012 11:08 AM

My post was not meant to discourage people from using your package, zerouno. In fact it is exactly as you say, not everybody wants to change his Slackware64 to multilib. And your package will be essential to those people.

Cheers, Eric

All times are GMT -5. The time now is 10:26 PM.