-   Slackware (
-   -   Simple GAIM "ssl support needed" fix (

Mainframe 03-03-2004 11:20 AM

Simple GAIM "ssl support needed" fix
Guys, this is my first post to the linux questions forms but I've been a Slackware user for about 4 yeras now.

Im gonna start my posts off with a simple fix for GAIM.

I searched the boards here for a fix to the "SSL support required" error when you run GAIM, but after not having much luck I did find a simple fix and for all I know it could already be posted here, but i'll post it again anyway so people can
find it easier

To get GAIM working with Slackware Linux 9.0 or 9.1 you need to edit the following file and add one line.

kpomeroy@Athlon:~$ less /etc/


changes to

/usr/lib/mozilla-1.4 <--------------

save the file, and fire up GAIM, no need to download anything, including the latest and greatest mozilla packages or any third party packages.


Marsanghas 04-10-2004 06:58 PM

Thanx ! It would've taken me for ages to find this.

I just recently installed 9.1 and updated everything. Today I re-installed (new HD)... basically did the exact same thing (well.. almost, I guess).
First time gaim had no problem. This install.. ssl required.

Checked the backup of from the first install... and yes.. there it was.. the mozilla line. 2nd install.. it wasn't there.

Added it. Works again :-)

Thanx, and happy gaiming ;-)

coffeedrinker 04-10-2004 07:12 PM

My fix was to run kopete (part of KDE) :)

coffeedrinker 04-10-2004 07:17 PM

That is good info, Mainframe. I have installed a different version of Mozilla (a xft enabled build) to /opt/mozilla.

For others that have done this, follow Mainframe's advice but change the directory to:


or to wherever you have installed mozilla.

nedwardss 05-12-2004 06:01 PM

one more step for me
thanks mainframe, this finally solved my ssl problem with msn, however i had to do one more thing to get it working...
i ran ldconfig as root
and then it was able to log on to msn as well.

physics_kat 05-19-2004 02:14 PM

I'm having the same troubles... but I can't figure out how to edit that file. I typed:
less /etc/
and the screen gave me those four lines:


but I don't know how to edit the file. Help, please?

Systematic 05-19-2004 03:19 PM


Originally posted by physics_kat
I'm having the same troubles... but I can't figure out how to edit that file. I typed:
less /etc/
and the screen gave me those four lines:


but I don't know how to edit the file. Help, please?

use pico, vi, kedit, emacs or any other type of editor..

Less will only print out the bottom of the file.. it doesnt let you edit..

i suggest using Pico from a terminal session

open a terminal window and SU


pico /etc/
enter the text in and press ctrl+X and say Y to save changes and press enter to save it to the specified file name.

and you should be all set.

mint567 05-19-2004 09:01 PM

That is a fix but it is recommended to go the other way with gaim and install gnutls and other packages for SSL. The reason being is that if you update your mozilla to 1.5 gaim and mozilla 1.5 have issues I beleive. But either way as long as you are happy. Who uses mozilla anyways? :) its ok but Opera is the best in my opinion.

physics_kat 05-20-2004 09:47 AM

Okay. So now my file has changed since I last saw it:


....I don't know what this means.

mint567, I'd rather do the best way but I'm so unfamiliar with all this that I'm not even sure how to do what you said. I couldn't find where to download SSL without it being OpenSSL, and Gaim won't recognize OpenSSL. Do you know where I can find these packages? (and maybe installation instructions too?)

otherwise, why did my above file change? should I change it back to what it was in my last post? Thanks for any help, it's really appreciated..

mint567 05-20-2004 12:51 PM

hopefully these two directories are still in your
if not I would add them.
I am not sure why it changed unless you ran ldconfig as root.

the way to add SSL support without using mozilla. here is a link that tells specifically how to. I am sure the versions of the different libraries are newer now but these still work with gaim .77.
here is one for Mozilla
Gaim faq

Just follow one of those links for GAIM and SSL.
I do not beleive that GAIM supports file transfers through msn and also no display pictures. That is why I recommend aMSN for msn. Good Luck hopefully this helps.

Personally for MSN support I use aMSN. It is by far the best in my opinion.
It is great, has file support, display pictures, logging, timestamps, many other features.

All times are GMT -5. The time now is 08:18 AM.