LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-18-2004, 05:17 PM   #1
chestnut
Member
 
Registered: Jan 2004
Location: Sydney, Australia
Distribution: FC3, Ubuntu (Hoary)
Posts: 86

Rep: Reputation: 15
Shutdown when in run level 4


Hi

I have changed my Slackware 9.1 system to boot into runlevel 4, so as to avoid having to 'startx'. Everything works fine, but to shutdown/power-off system when at the log-in screen, I have to open up a new virtual terminal, log in as root and shutdown -h now

There does not seem to exist the option of shutting down system from this graphical log-in screen?

Ctrl, Alt & Del do not also work from graphical log-in.

Any ideas?

Thanks & regards
 
Old 02-18-2004, 05:54 PM   #2
Justin_Time
Member
 
Registered: Feb 2004
Posts: 53

Rep: Reputation: 15
Which windows manager do you have? Most of them have this options. (kde and gnome have them)
 
Old 02-18-2004, 11:44 PM   #3
joeln
LQ Newbie
 
Registered: Dec 2003
Location: Northern Colorado
Distribution: slack 9.1 replacing mandrake 9.2
Posts: 23

Rep: Reputation: 15
I tried to set this up using the sessions tab in the kde login manager. it no work. Finally I broke down and set it up with sudo. If somebody can explain to me why kde implies that I can get this to work, then doesn't, I sure like to know.

I tried doing that to avoid typing startx, but didn't much like it, so I just mad a .profile and put startx at the end of that - works like a charm.

-Joel
 
Old 02-19-2004, 03:31 AM   #4
chestnut
Member
 
Registered: Jan 2004
Location: Sydney, Australia
Distribution: FC3, Ubuntu (Hoary)
Posts: 86

Original Poster
Rep: Reputation: 15
I have managed to solve probelm. I was going into Gnome log-in manager (with yellow flower bottom right of screen?), and only options on screen were for change of language, or session. By commenting out the lines to run gnome login manager in script /etc/rc.d/rc.4, I now go into KDE login manager by default, and have the option to close down system

Thanks for your sugestions
Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What is Run Level? Khmer Linux - General 5 10-18-2005 01:25 PM
Run Level 3 webwolf70 Mandriva 5 01-17-2005 11:41 PM
Run level Joey.Dale Linux - General 4 06-18-2003 05:59 PM
run level whaase Linux - General 3 10-07-2002 10:07 PM
Run Level POWERBOOKM Linux - Newbie 2 12-01-2001 09:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration