-   Slackware (
-   -   Shutdown problem (

joel1 06-20-2002 11:41 PM

Shutdown problem
Doesn't seem to shutdown properly. I type power off it halts everything unmounts and then it just says 'System shutdown.' or 'Shutdown complete.' something like that anyway (I'll check tonight and post exact message. But it doesn't turn off like it did under redhat.

Is this normal? or is something wrong?

Using Slackware 8.1

Half_Elf 06-21-2002 12:23 AM

Herm try to enable "advanced power management" in your kernel and the "use real time APM bios to power off", I heard sometime this can help.

But I have this problem too, my box doesn't shutdown by it self.... I can reboot, but I can't shutdown... Dunno why.

joel1 06-21-2002 12:27 AM

Yeah exact same problem reboot works fine but not shutdown, very strange!

Thanks for the suggestions, I will look into it and try it out over the weekend...

Aussie 06-21-2002 06:17 AM

Just modprobe apm and all should be well.

Jeff Sadowski 06-21-2002 11:45 AM

With a multi-processor kernel ACPI must be used not APM
I haven't tried to get ACPI because I only need a single
processor kernel It works for me. You'll either need to
a) look into acpi and disabling apmd.
b) dissabling multiprocessor support in the kernel options
c) turn off the power by hand
:) I hope that this was helpful

joel1 06-21-2002 11:50 PM

Thanks guys modrpobe apm fixed it all up. :)

Darkstar 06-23-2002 06:46 PM

Actually, if you edit the rc.modules file, you'll see a line commented out that enables apm so you don't have to do a modprobe each time. I think this works better.

joel1 06-23-2002 07:05 PM

Yeah I just added 'modprobe apm' to the bottom of the rc.modules file.

de_guiche 06-25-2002 08:51 AM

I have the exact same Pb under SUSE but nothing has worked for me

ccool 01-16-2003 02:20 PM

euh, guys... it does'nt work for me...

I recompile the kernel (2.4.20) with acpi and apm and the shutdown still does'nt work. When I shut down my computer, everything is turning off and then, it says : "Power down" but it hangs there :(

modprobe apm does'nt work for me, becaus I compiled it in the kernel, and not as a module...

Can somebody help me ???

Half_Elf 01-16-2003 03:37 PM

ccool: some motherboard are just bad and you will not be able to shutdown properly... however, try to enable Acpi alone or Apm alone. Apm will always be taked by default I think, so if you enable it and you motherboard does not support it, it will never use acpi unless you disable APM.

NSKL 01-16-2003 03:39 PM

You should not have both APM and ACPI enabled. If you dont have SMP, or a laptop, i suggest using APM. Recompile the kernel, this time including both APM and ACPI as modules, then first modprobe APM, and try to shutdown. If that doesn't work, then reboot, and insted load ACPI and try. If that doesn't work you'll have to recompile again. This time include APM to be built in the kernel, and play with APM options. This can involve a couple of kernel re-compiles, and get very annoying... in the end however, it usually works with only APM, or APM and "use real time bios call to power off"
Good luck

ccool 01-16-2003 09:52 PM

thanks nskl....

I will try that

PS: thanks half_elf, but my motherboard work correctly with windows (and I tried mandrake 8.2 and it was working too..) I should have mentioned that...

still, thanks for your replys, I will try that

fskmh 01-18-2003 05:10 AM

Here's a solution that works well for me on more recent Gigabyte (2001+) mobos:
Enable ACPI support:
Then add support for System, Processor and Button (Button is the one that does the poweroff). I compile these directly into the kernel.
On older machines that support APM and which have ATX power supplies I do:
Enable APM BIOS support:
Then enable real mode APM BIOS call to poweroff. I also compile these directly into the kernel.
Note that you have to pick ONE of these methods, it makes no sense trying to use both.

ccool 01-18-2003 12:56 PM

ok, I'll try your solution with acpi, because it did'nt work with apm... :(

All times are GMT -5. The time now is 06:35 PM.