LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Shutdown not available with KDE (https://www.linuxquestions.org/questions/slackware-14/shutdown-not-available-with-kde-310300/)

larienz 04-06-2005 07:42 AM

Shutdown not available with KDE
 
Hi,it's my first thread here,I hope to help everyone and also to be helped :-)
My issues is:my distribution is Slackware 10.1 with Kde,I have a problem with shutdown,even in shell that in GUI.In a shell (as root) if I type "shutodwn -h now" the system really shut down but it doesn't turn off automatically,when it makes all operations before shutting down (umount disks etc..) it appears "Power down" and I have to press power switch button on the tower,so the system turn off.Is there a way to really turn off completely the system?

In GUI,instead,in Kde menu I have only "logout" (as root but also as normal user),is there a way to add a button "shutdown" (if I use Gnome in place of Kde it is present on menu)?
Thank you very much!

larienz

Thoreau 04-06-2005 07:48 AM

Enable APM in the motherboard BIOS.

sporks 04-06-2005 09:45 AM

Re: Shutdown not available with KDE
 
Quote:

Originally posted by larienz
Hi,it's my first thread here,I hope to help everyone and also to be helped :-)
My issues is:my distribution is Slackware 10.1 with Kde,I have a problem with shutdown,even in shell that in GUI.In a shell (as root) if I type "shutodwn -h now" the system really shut down but it doesn't turn off automatically,when it makes all operations before shutting down (umount disks etc..) it appears "Power down" and I have to press power switch button on the tower,so the system turn off.Is there a way to really turn off completely the system?

In GUI,instead,in Kde menu I have only "logout" (as root but also as normal user),is there a way to add a button "shutdown" (if I use Gnome in place of Kde it is present on menu)?
Thank you very much!

larienz

To get the shutdown option in KDE you need to use KDM as your login manager not GDM.

subekk0 04-06-2005 10:13 PM

do the following:

cd /etc/rc.d [enter]
vi (or pico) rc.modules [enter]
look for a line that start with APM you will see the module has a # in front of it, remove the #, save and close rc.modules
type insmod apm [enter]
shutdown -h now should power off the system as normal

sporks 04-06-2005 10:16 PM

Quote:

Originally posted by subekk0
do the following:

cd /etc/rc.d [enter]
vi (or pico) rc.modules [enter]
look for a line that start with APM you will see the module has a # in front of it, remove the #, save and close rc.modules
type insmod apm [enter]
shutdown -h now should power off the system as normal

:oops:

That too. Sorry I missed that part. Had to do that on my HP, enable APM, shuts down but doesn't reboot with APM.

larienz 04-07-2005 08:48 AM

I have resolved both issues,thank you!For the GUI it has been sufficient to shift to kdm,for the power off I follow subekk0 instructions and that's ok!
Anyway thank you to everyone has tryed helping me! :-)


All times are GMT -5. The time now is 02:54 AM.