LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-05-2005, 11:43 AM   #1
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Rep: Reputation: 30
shut down and reboot options gone from gnome 2.10


dear all,

since the upgrade to gnome 2.10, when i select to log out from gnome i do not get a choice of three option (this neither as root nor normal user), only a choice to log out.

is there a way to have the dropline 2.8.2 functionality which allows to shutdown directly from gnome? or do i have to logout, su to root, poweroff?

this look pretty annoying...

cheers,

aj.
 
Old 04-05-2005, 12:53 PM   #2
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
I haven't tried Gnome 2.10 yet. Are you using Dropline Gnome?

I can provide you with a work-around (basically a sudo entry and a script that I used to use with Windowmaker so that my wife could shut the puter down without having to open a terminal)

If you're on Dropline then I would try posting in their forums, as 2.10 is still in beta and it's an issue that they can probably fix.

slight
 
Old 04-06-2005, 12:49 AM   #3
Arch Stanton
LQ Newbie
 
Registered: Nov 2004
Location: Halifax, Nova Scotia
Distribution: elementaryOS
Posts: 23

Rep: Reputation: 15
I just installed dropline 2.10 the other day and I do have shutdown and reboot options on logout.

can't tell ya why I do and you don't, but I had set permissions on /sbin/halt and /sbin/shutdown to 755 before the install... might have something to do with it.

Last edited by Arch Stanton; 04-06-2005 at 12:51 AM.
 
Old 04-06-2005, 04:30 AM   #4
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
hi and thank you for taking the time to reply.

well yes, i'm on dropline and have installed gnome 2.10 from them. i did not do any sudo nor any other particular operation before install, and i guess doing that now is a bit too late.

what is weird to me is that with 2.8.2 i had these options (still dropline).

any workarounds welcomed, or maybe i should just wait a final release?

tx,

aj.
 
Old 04-06-2005, 04:51 AM   #5
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
I know this won't add a option in the menu, but at least will let you reboot and shutdown with your user.
Run as root: visudo
This "program" (it's actually the vi editor) will let you edit the sudoers privileges so you can allow a user to run a root command with sudo.
I'll make a quick editing guide here in case you never used vi.
Go with the arrow keys to the end of the file, press the "i" to get to Input mode, and type something like:
Code:
gbonvehi desktop= NOPASSWD: /sbin/shutdown -h now
gbonvehi desktop= NOPASSWD: /sbin/shutdown -r now
Then press ESC key and finally type, :wq and ENTER.
Replace gbonvehi with your username and desktop with your machine name.
Now you'll be able to reboot with your user by typing: sudo /sbin/shutdown -r now
or shutdown with: sudo /sbin/shutdown -h now
 
Old 04-06-2005, 04:57 AM   #6
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
thank you gbonvehi,

i was aware of this solution however i'd still ike to have this kind of menu from within gnome itself.

cheers,

aj.
 
Old 04-06-2005, 12:38 PM   #7
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
This was removed from the gnome-panel, and relies on GDM for the functionality now. You must have your system set to runlevel 4 for this menu option to appear.

The default runlevel may be changed in /etc/inittab.

Code:
# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
 
Old 04-06-2005, 03:41 PM   #8
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Quote:
Originally posted by acidjuice
hello zborgerd,

well, i was using the first beta version then

apparently still no luck after applying the latest PAM, i still have no HALT nor REBOOT option when logging out of gnome, but only LOG OUT and the 'save current session' checkmark.

...do you happen to have other reports on this?

thanks,

aj.
I'm replying to your post that you placed here ( http://www.linuxquestions.org/questi...postid=1576465 ), because I assume that this is the right thread:

I take it that you do have GDM enabled then? Was this a fresh installation of Slackware 10.1? We had someone report that he had such a problem on his machine, but he also said that he's been "upgrading" his Slackware box since version 4.

If you log out, does GDM have any "shutdown" or "reboot" options? If not, try reinstalling the GDM pack. This should be the right one:

http://prdownloads.sourceforge.net/d...l.tgz?download

Make sure that it's listed in /var/log/packages. If it is, it probably wouldn't hurt to reinstall it anyway.
 
Old 04-06-2005, 04:07 PM   #9
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
hi zborgerd, and thank for taking the time to reply.

no i am not using GDM right now since i boot in level 3. will definitely try that then, i've seen that you already took care (or maybe was it pat?) of creating the necessary poweroff rights for common users to halt from the prompt.

thank you, will try using GDM and see if that works.

cheers, and keep up the good work,

aj.
 
Old 04-06-2005, 04:23 PM   #10
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Quote:
Originally posted by acidjuice
hi zborgerd, and thank for taking the time to reply.

no i am not using GDM right now since i boot in level 3. will definitely try that then, i've seen that you already took care (or maybe was it pat?) of creating the necessary poweroff rights for common users to halt from the prompt.

thank you, will try using GDM and see if that works.

cheers, and keep up the good work,

aj.
Yeah... As I noted above, GDM is unfortunately required (e.g., you must be in runlevel 4) now for these menu options to appear. This was a change that was done by the GNOME developers. Even modifying permissions for shutdown and reboot won't help (we have pam_console/consolehelper functions for these anyway, so normal users can do this regardless), since it's basically a design change in GNOME.

Regards,

Zach
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wont reboot or shut down scandog Red Hat 3 12-05-2005 02:30 AM
strange messages on shut down or reboot dr0n3 Fedora 0 09-26-2005 01:32 AM
Disappearing reboot options on Mandrake 9.1 U777132 Mandriva 0 11-21-2003 10:59 AM
KDE - No options on choosing reboot Jongi Mandriva 1 08-28-2003 10:26 AM
no reboot options after first logout in mandrake 9.1 hobylinux Linux - Software 1 08-17-2003 06:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration